View Full Version : Cannot get Teensy Loader to work with Teensy 3.0

11-28-2012, 05:25 PM
I guess I am doing something stupid. I've tried this on four different computers, three different cables, three different Teensy boards. The only commonality is me so I guess I am the idiot. I haven't even soldered the headers on yet so I know the boards are undamaged in any way.

I plug the Teensy 3.0 into any computer via USB and it blinks as advertised. I am using the right cable, the flat micro-B USB type cable. On most of the computers, when inserted the first time I get a driver installation failure which I guess is to be expected. I download and run Teensy Loader from http://www.pjrc.com/teensy/loader_vista.html for the three Windows 7 64 computers I have tried this on. It runs fine. I press the hardware button on the Teensy board and the Teensy stops blinking but nothing happens. In one case, at this point, the computer gave a success message for the USB driver:


But in all cases, the Teensy Loader has done nothing. It has not enabled any menu entries, changed text in verbose mode, changed the background image, or done anything else. I have tried this on an Windows XP SP3 32 bit machine as well with the Teensy XP loader at http://www.pjrc.com/teensy/loader_xp.html with the same results. I changed up the boards and the cables with the same results.

Oddly, despite the message saying the USB driver was successfully installed, Windows still thinks it is an unknown device:


Is this a problem by itself or expected? What am I doing wrong? Thank you for any advice.

11-28-2012, 05:41 PM
The default teensy loader on that page has not yet been updated for teensy 3. Use teensy loader >= 1.0.7. For example from here (http://forum.pjrc.com/threads/430-Teensy-3-0-quot-beta8-quot-Software).

11-28-2012, 05:48 PM
That doesn't seem to be the loader as much as it is a full-scale IDE. Downloading now... We will see in a 7 minutes, 18 seconds. Thank you.

11-28-2012, 06:22 PM
OK, it seems to work fine. I have modified the example sketch blink and uploaded it and now the Teensy doesn't blink anymore. Has the LED pin been relocated? I tried both 11 and 6. Thanks again..

const int ledPin = 6; // Teensy has LED on 11, Teensy++ on 6

// the setup() method runs once, when the sketch starts

void setup() {
// initialize the digital pin as an output.
pinMode(ledPin, OUTPUT);

// the loop() methor runs over and over again,
// as long as the board has power

void loop() {
digitalWrite(ledPin, HIGH); // set the LED on
delay(200); // wait for a second
digitalWrite(ledPin, LOW); // set the LED off
delay(200); // wait for a second

11-28-2012, 06:39 PM
Yes, the pin is different. I can't remember what it was off hand (8?), but the LED pin you want is listed on the sheet that was shipped with the Teensy 3.

11-28-2012, 06:45 PM
OK, by trial and error I determined it is 13. It's not on the data card that came with the board. Anyway, it all works now. Today, an LED. Tomorrow, THE WORLD! (add Dr. Evil laugh)

Thanks for your help!

EDIT: I am totally wrong, it is listed on the card. I just missed it.