PDA

View Full Version : SoftPWM on Teensy 3?



johncc
12-29-2012, 02:24 AM
I am trying to use SoftPWM on Teensy 3.

The sketch SoftPWM_Arduino_LED_Blink compiles and runs on Arduino and Teensy 2 using teensyduino beta 9.

When compiling on Teensy 3 though, I get:

C:\Program Files\Arduino\teensyduino_1.0.2_beta9\libraries\So ftPWM\SoftPWM.cpp:70: error: expected constructor, destructor, or type conversion before '(' token


In SoftPWM line 70 is:

// Here is the meat and gravy
#ifdef WIRING
void SoftPWM_Timer_Interrupt(void)
#else
ISR(SOFTPWM_TIMER_INTERRUPT) <<<<<<<------------------- Line 70
#endif
{
uint8_t i;


Apologies if this has been discussed, I didn't find anything about this through a search of the forum or Google.

Cheers,
John

johncc
12-29-2012, 02:10 PM
Browsing further on this forum I see that interrupt support on Teensy 3 is not ready yet, so that probably explains the error. Not a problem, for my current project a Teensy 2 will be quite sufficient.

Cheers,
John