PDA

View Full Version : Is current Teensyduino compatible with Arduino 1.0.2 IDE?



ausserirdischegesund
11-30-2012, 07:18 AM
The description of Teensyduino lists it compatible with Arduino 1.0.1. Is this because that was the most recent version when it was last updated, and should it be compatible with 1.0.2. or should I stay with 1.0.1 for now?

TIA
Ralph

PaulStoffregen
11-30-2012, 08:44 AM
Yes, it supports 1.0.2.

To find out which versions are supported, just run the installer and look at the intro page.

ausserirdischegesund
12-01-2012, 08:19 AM
Thanks, Paul!

I've been playing for a few hours with it now, and I am having a lot of fun!

Johan1005
12-06-2012, 01:39 PM
Hello

I actually use an LPD8806 rgb led strip(advancedLEDbelkit example).
There is a missing definition in the file arduino-1.0.2/libraries/TimerOne/config/known_16bit_timers.h if i want to use the new arduino/adafruit micro base on an atmega32u4.

You can wait for the new release of teensyduino release or you can edit the "known_16bit_timers.h" file
you have to copy in this file the defintion for teensy 2.0

// Teensy 2.0
//
#elif defined(__AVR_ATmega32U4__) && defined(CORE_TEENSY)
#define TIMER1_A_PIN 14
#define TIMER1_B_PIN 15
#define TIMER1_C_PIN 4
#define TIMER1_ICP_PIN 22
#define TIMER1_CLK_PIN 11
#define TIMER3_A_PIN 9
#define TIMER3_ICP_PIN 10


And paste it after (remove && defined(CORE_TEENSY)

// Arduino Micro
//
#elif defined(__AVR_ATmega32U4__)
#define TIMER1_A_PIN 14
#define TIMER1_B_PIN 15
#define TIMER1_C_PIN 4
#define TIMER1_ICP_PIN 22
#define TIMER1_CLK_PIN 11
#define TIMER3_A_PIN 9
#define TIMER3_ICP_PIN 10


Also you can remove && defined(CORE_TEENSY) from Teensy 2.0 definition but I don't like to modify it.

Johan