PDA

View Full Version : Compile error cannot find -lc



sonny
11-09-2012, 05:03 AM
Hello,

I tried to google solution to the problem below but no luck so I install linux mint 64bit and erase the ubuntu 32 bit and download beta7 64 bit and started arduino, pick board T3, cpu 24 mhz, pick teensy blink example and tried to compile and get the error 'cannot run program "/home/sonny/arduino-1.0.2/hardware/tools/arm-none-eabi/bin/arm-none-eabi-g++": error=2, No such file or directory. I then tried to navigate to the directory and I can see the file O.K. I get this error running as root or regular user.


Original problem:

I just received my T3, downloaded beta7, 32bit linux (I'm running Ubuntu 12.10 32 bit), started arduino, pick board T3, cpu 24 mhz. Pick File->Example->Teensy->Tutorial1->Blink, change led pin to 13, click verify, got error cannot find -lc. Any clue where to start?

Thanks,
Sonny

sonny
11-10-2012, 07:46 PM
I managed to get teensy running on a linux mint 12 64 bit.

Paul
11-10-2012, 08:41 PM
The arm compiler is 32 bits, even in the 64 bit version. The rest of the stuff is all 64 bits, but the compiler is 32 bit.

These problems are caused by missing 32 bit libraries from your linux distro.

Eventually I'll replace the compiler with a 64 bit build. My first attempt at a 64 bit build (back in "beta5") appeared to work, but compiled bad code for some things, like Serial.print(float). For now, there's only a 32 bit compiler.

Hopefully anyone else seeing this error will find this thread and at least know to look for their distro's 32 bit libraries, or use a different distro that provides better 32 bit compatibility.