PDA

View Full Version : Problems with Teensy 3 and bottloader



ma_a
01-31-2013, 12:46 AM
I bought Teensy 3 modules recently but can not get them working. I installed Bootloader application. Once I connected the device to the host computer the on-board LED is flashing (once per second) and the bootlooder application suggest to press button on the module. Once I press the button the host computer recognizes the device (USB serial, PID and VID as specified) the LED stops flashing but the application button appearance has not been changed ( the same arrow accross with label suggesting to press button and the operation buttons (Program and Reboot ) in the boot loader application are diabled. Hex file example provided with the boot loader are loading without errors but the bootloader does not recognizes the Teensy 3 and I am not able to load/run the program.

I tried two modules in Windows 7 PC and in MAC OSX with 2 different USB cables, but the result is the same. Any lead/tips would be appreciated.
MarkA

BambooSam
01-31-2013, 01:57 AM
Whenever that happens to me re-booting my macbook pro always fixes it. Either that or you have have the wrong port set. I use: cu.usbmodem:12341

ma_a
01-31-2013, 02:25 AM
Whenever that happens to me re-booting my macbook pro always fixes it. Either that or you have have the wrong port set. I use: cu.usbmodem:12341

I tried Teensy 2 as well with the same computer. Behave is very different and the Boot loader program recognizes the Teensy 2 ( Shows the right image of the board) and the Operation buttons are active.
I think the problem is not in host computer but in Teensy 3 hardware.

BambooSam
01-31-2013, 03:11 AM
Did you try restarting your mac? just try it, its a mac. Itll take 30 seconds.

PaulStoffregen
01-31-2013, 02:42 PM
Are you using Teensy Loader 1.06, which only supports Teensy 2.0?

You need to download the latest beta version (http://forum.pjrc.com/threads/16349-Teensy-3-0-Beta12-Software) for Teensy 3.0.