PDA

View Full Version : Teensy 3.0 DSP libraries?



wintrmute
05-14-2013, 04:45 AM
Hi,
I have a project that currently uses the BeagleBone with libfftw, as the AVR chips just don't have enough CPU grunt for the signal processing.
However I was wondering if the Teensy 3.0 would suffice - I saw it has DSP functions in the Cortex M4 CPU.
Are there any libraries available that can be linked into the Teensy compiler pipeline to use the DSP?

I've already ordered my Teensy 3.0, and am hoping I can figure something out with a little help.

Cheers,
Toby

el_supremo
05-14-2013, 07:07 PM
See: http://forum.pjrc.com/threads/14845
The library is part of the Arduino Due 1.5 distribution.
As mentioned in the later part of that thread, there's now an option you can put in boards.txt to include the library.

Pete

wintrmute
05-15-2013, 12:55 AM
Thanks! It hadn't shown up in my search results, but that looks like what I'm after.