PDA

View Full Version : Teensyduino 1.32 Beta #1 Available



Paul
11-23-2016, 05:12 PM
Here is a first beta test for Teensyduino 1.32.


Edit: old beta test linkes removed. Full non-beta release is here:
http://www.pjrc.com/teensy/td_download.html


Changes since Teensyduino 1.31:


Support for Arduino 1.6.13
Serial monitor shows status in title bar, Arduino 1.6.13 only
Ethernet library now supports W5500 chip
Fix SD library with old SD cards on Teensy 3.5 & 3.6
Fix IntervalTimer start/stop bug
Fix Audio library SPI hogging with Teensy 3.5/3.6 build in SD card (Frank B)
Libraries updated: Snooze, Time, TimerThree

mconsidine
11-26-2016, 07:08 PM
"Blink" works as advertised, using Teensy 3.2, 64-bit Linux Mint ("Sarah") Cinnamon, and Ubuntu 16.04 on an old Dell Inspiron 1545, and Arduino IDE 1.6.13
Matt

firehopper
11-26-2016, 09:24 PM
I cant get it to install on a brand new windows 10 rca tablet, it pops up a compatability wizard thingy and does nothing. what do I need to give you the info you need?

KurtE
11-26-2016, 09:30 PM
I cant get it to install on a brand new windows 10 rca tablet, it pops up a compatability wizard thingy and does nothing. what do I need to give you the info you need?

How did you install Arduino and which version?

If you used the windows installer, try right clicking on Teensyduino app you download and "Run as Administrator"

firehopper
11-26-2016, 09:37 PM
installed a fresh 1.6.13 arduino via the exe version. and tried the run as admin.. no luck.
could try rebooting the tablet and see if that helps

firehopper
11-26-2016, 09:47 PM
rebooted and downloading a fresh copy. will see what happens

firehopper
11-26-2016, 10:05 PM
must have had a bad downloaded copy or something. worked this time..

defragster
11-28-2016, 09:33 AM
IDE 1.6.13 and TD_1.32b1 running fine on my Win 10 machine. Fresh unzip to a new larger SSHD on my old laptop

4styler
11-28-2016, 12:46 PM
Hello Paul,

Teensy 3.6 looks very nice. I will hope that i can test it soon. But i have one question:
I have installed Arduino IDE 1.6.13 and after that i installed TD 1.32 B1 but i did not see Teensy 3.6 under the Teensy Boards. Is that normal?
How can i program the Teensy?

8929

Thanks for your great work.
Greetings Stefan

KurtE
11-28-2016, 12:58 PM
That does not look correct, are you sure you are running the new IDE with Teensyduino installed?

Should look more like:
8930

What type of computer and OS? Open up "About Arduino" menu item and see which versions you are running

4styler
11-28-2016, 01:03 PM
Hey, thanks:
8931

Microsoft Windows [Version 10.0.10240]

Computer is no special type. I build it on my own. Asus Mainboard, Geforce Card, SSD, I7 and so on....

KurtE
11-28-2016, 01:16 PM
Not sure what happened, hopefully Paul might.

If it were me, I would probably try:

a) Look at the boards.txt file to see if it looks correct (where you installed Arduino\hardware\teensy\avr\boards.txt) and see what is in it.


menu.usb=USB Type
menu.speed=CPU Speed
menu.keys=Keyboard Layout

teensy36.name=Teensy 3.6
teensy36.upload.maximum_size=1048576
teensy36.upload.maximum_data_size=262144
teensy36.upload.tool=teensyloader
teensy36.upload.protocol=halfkay
teensy36.build.board=TEENSY36
...


b) try again. Download Teensyduino again, make sure Arduino is not running (maybe right after reboot) and run Teensyduino again....

c) Make sure I did not have something screwy setup. Like not sure what would happen if you had an old copy of Teensyduino installed at some place like:
(my documents)\Arduino\Hardware\teensy ...

4styler
11-28-2016, 01:27 PM
Hey,
step c was it... i did not know why it exists....
Thank you very much...

raphaelcno
11-29-2016, 05:27 AM
I see you are working on improving the Ethernet library regarding W5500 chip, thank you very much!
https://github.com/PaulStoffregen/Ethernet/commit/ee1eacf88b4c7d5e0b0a7f7ea1c94cc8ce8de7e1
If I understand correctly, the Reset signal is not needed any more. Is that correct?

KurtE
11-29-2016, 02:16 PM
When looking at someone asking about making stuff with Arduino IDE, I looked at the makefile:

And wonder if:

# options needed by many Arduino libraries to configure for Teensy 3.0
OPTIONS += -D__$(MCU)__ -DARDUINO=10600 -DTEENSYDUINO=121
If the TEENSYDUINO version should be updated in the makefile

PaulStoffregen
11-30-2016, 01:10 PM
If I understand correctly, the Reset signal is not needed any more. Is that correct?

Correct, I removed the reset signal code. I also adopted Adafruit's Ethernet.init(pin) extension, so it can hopefully be compatible with more types of hardware.

W5200 without hardware reset is questionable. The problem is W5200 doesn't restart its SPI state machine when CS goes low. So if it hears "garbage" or you simple stop using it (like uploading new code), it can believe it's in the middle of a long transfer and it ends up ignoring more SPI communication you send later.

I'm considering extending init to something like Ethernet.init(pin, pin), where the 2nd optional pin would be for reset. Still undecided on this.

PaulStoffregen
11-30-2016, 01:13 PM
If the TEENSYDUINO version should be updated in the makefile

Done.
https://github.com/PaulStoffregen/cores/commit/8807de5d61565a58662b22a0053c646f452a09c9

manitou
12-01-2016, 01:13 PM
You might consider expanding SPI clock tables in SPI.cpp (I filed a github issue). Some discussion at
https://forum.pjrc.com/threads/40394-SPI-clock-not-uniform

Paul
12-09-2016, 10:40 PM
Teensyduino 1.32 has been released.

http://www.pjrc.com/teensy/td_download.html