PDA

View Full Version : Teensyduino 1.33 Beta #2 Available



Paul
12-13-2016, 08:24 AM
Here is a second beta test for Teensyduino 1.33.

This version attempts to fix a serious bug in version 1.32 which prevents uploading sketches.


Old beta download links removed. Please use the latest version:
https://www.pjrc.com/teensy/td_download.html


Changes since Teensyduino 1.33-beta1 (https://forum.pjrc.com/threads/40784-Teensyduino-1-33-Beta-1-Available):


Fix first-use communication error between Arduino & Teensy Loader

kophi
12-13-2016, 08:42 AM
I can confirm that the problem from 1.33-beta1 (error on first-use) is fixed in my setup.

Thanks for the quick fix!

znevans
12-13-2016, 12:13 PM
Confirmed here as well (same setup as kophi though, on mac, T3.2, A1.6.13). Thanks for working on this!

MichaelR
12-13-2016, 01:34 PM
Thank you Paul, this solved the compiler error problems (MacBook Pro macOS 10.11.6).

glenngineer
12-13-2016, 01:46 PM
Paul, I can confirm 1.33-Beta2 works with Teensy 3.2 under Windows 10 - Arduino1.6.13 and vMicro/VS.

Thank you so much - Glenn

PaulStoffregen
12-13-2016, 11:52 PM
Looks like this fixed the trouble.

I'm going to do another round of testing here tomorrow, and then release this as 1.33... unless I discover any problems, or anyone reports any more issues.

If anyone sees anything wrong, please please please speak up ASAP.

drewfish
12-14-2016, 04:14 AM
This worked for me as well. For completeness the log is attached.
9148

PaulStoffregen
12-14-2016, 02:37 PM
I've released Teensyduino 1.33. There were no substantial changes after 1.33-beta2.

http://www.pjrc.com/teensy/td_download.html

This 1.33 release is mainly to fix the bug with first-time upload errors from Arduino.

KurtE
12-14-2016, 03:24 PM
I ran into an issue installing Teensyduino on my Windows 10 64 bit Arduino 1.6.13... I get error messages like:
9152
I tried with the current one 1.33 as well as the current one here and get this error.

I tried rebooting, I deleted the old Arduino and unzipped a new 1.6.13 to c:\ tried running as Admin... Will try to download fresh copies again...

el_supremo
12-14-2016, 03:57 PM
I had that error while installing 1.13b2 but I had forgotten to kill a T3.6 project that I had open in the IDE. Killed it, started again, all OK.

Pete

KurtE
12-14-2016, 04:42 PM
This time I tried it again, with a freshly downloaded Arduino IDE, I just rebooted, then unzipped the Arduino IDE to c:\ and then tried running the Teensyduino, same error...

Maybe should try on another machine... Will try later, now getting ready for company...

Edit: I also tried installing Arduino in my Documents folder and rerun the Teensyduino... Failed there too.

At times like this I wonder if 1.6.13 now is the same 1.6.13 when it was released

defragster
12-14-2016, 04:54 PM
I ran the TD_1.33b2 install over my prior 1.6.13 install with no problems with TD install

el_supremo
12-14-2016, 07:06 PM
BTW. I install Arduino/Teensyduino on a SSD. I start by unzipping the Arduino stuff and that goes really fast. Up until recently, the Teensyduino install was really slow. But 1.33 installs MUCH faster than previous versions.
Excellent ;)

Pete

KurtE
12-14-2016, 09:07 PM
This time I tried it again, with a freshly downloaded Arduino IDE, I just rebooted, then unzipped the Arduino IDE to c:\ and then tried running the Teensyduino, same error...

Maybe should try on another machine... Will try later, now getting ready for company...

Edit: I also tried installing Arduino in my Documents folder and rerun the Teensyduino... Failed there too.

At times like this I wonder if 1.6.13 now is the same 1.6.13 when it was released
Update: I think it is the Virus detector:mad: must have changed. I turned McAfee real time scanning off for 15 minutes and was able to update the two directories that failed earlier :D

PaulStoffregen
12-14-2016, 09:20 PM
But 1.33 installs MUCH faster than previous versions.

Oh, yeah... I made a couple little improvements to the installer. Should speed things up on Mac and Windows. Linux was already very fast.

Markus_L811
12-16-2016, 10:59 AM
Oh, yeah... I made a couple little improvements to the installer.
Woah really fast, damn.