View Full Version : Teensyduino 1.39 Beta #2

09-05-2017, 12:04 PM
Here is a second beta test for Teensyduino 1.39.

Old beta download links removed. Please use the latest version:

Changes since Teensyduino 1.39-beta1 (https://forum.pjrc.com/threads/46089-Teensyduino-1-39-Beta-1)

Stream find functions now take const pointers on Teensy 2.0
Update Print class for Teensy 2.0
Don't redefined BYTE (for ancient Arduino compatibility) if already defined
Support AVR pgm_read_ptr() on Teensy LC & 3.x
Fix srandom conflict
Raspberry Pi builds with 2017-07-05-jessie (previous builds were on 2014-12-24-wheezy)
Updated libs: Adafruit_NeoPixel, Snooze, TFT_ILI9163C
Fix compiler warnings & improved error messages: EEPROM, Adafruit_CC3000, Adafruit_GFX, Adafruit_ILI9340, Adafruit_ILI9341, Adafruit_RA8875, ADC, FastCRC, FrequencyTimer2, i2c_t3, ILI9341_t3, IRremote, Keypad, ks0108, OctoWS2811, OneWire, openGLCD, OSC, RA8875, SerialFlash, SoftPWM, ssd1351, ST7565, Talkie, Time, TimerOne, TinyGPS, Tlc5940, x10

09-05-2017, 06:03 PM
My goal is to finalize version 1.39 within the next few days.

Please give 1.39-beta2 a look if you can. My hope is we can have 1.39 as a really stable release, before going after some long-planned improvements like restructuring HardwareSerial and changes deep within the USB buffer management.

09-05-2017, 06:35 PM
Sounds good, I have installed on Windows 10 64bit, Arduino 1.8.4 and appears to work fine. Built my version of USB_Host code for Mouse and now Joystick and it builds... Run test case of ili9341_t3n library to see about if rotations worked...

I have been hit again by could not rename file... Solved by closing Arduino and rerun... Have been having this since Last beta of 1.38, but also could be due to 1.8.4... Will let you know if I hit it with some reproducible steps. Had it happen a couple times yesterday as well...

I also installed linux Arm version on Odroid Xu4 running Ubuntu and Ran fine and programmed T3.2 with blink...

Edit I assume too late for more usb host code update...

And as you mentioned the Hardware Serial code changes... (I do have a version that all is one class, with multiple instances (almost)) and you can add buffer space.

Frank B
09-05-2017, 07:51 PM
No problems so far:

Bibliothek Teensy64_new im Ordner: C:\Users\Frank\Documents\Arduino\libraries\Teensy6 4_new (legacy) wird verwendet
Bibliothek SdFat-master in Version 1.0.3 im Ordner: C:\Users\Frank\Documents\Arduino\libraries\SdFat-master wird verwendet
Bibliothek SPI in Version 1.0 im Ordner: C:\Arduino\hardware\teensy\avr\libraries\SPI wird verwendet
Bibliothek Audio in Version 1.3 im Ordner: C:\Arduino\hardware\teensy\avr\libraries\Audio wird verwendet
Bibliothek SerialFlash in Version 0.5 im Ordner: C:\Arduino\hardware\teensy\avr\libraries\SerialFla sh wird verwendet
Bibliothek reSID im Ordner: C:\Users\Frank\Documents\Arduino\libraries\reSID (legacy) wird verwendet
Bibliothek Wire in Version 1.0 im Ordner: C:\Arduino\hardware\teensy\avr\libraries\Wire wird verwendet
Der Sketch verwendet 347432 Bytes (33%) des Programmspeicherplatzes. Das Maximum sind 1048576 Bytes.
Globale Variablen verwenden 232728 Bytes (88%) des dynamischen Speichers, 29416 Bytes für lokale Variablen verbleiben. Das Maximum sind 262144 Bytes.

No warnings.

09-05-2017, 09:09 PM
Edit I assume too late for more usb host code update...

Yeah, for 1.39 we're in the final day or two of testing. Only bug fixes make sense now. Really hoping everyone who sees this can give it a try with their favorite project & hardware. I'm doing more testing here too.

09-05-2017, 10:22 PM
Looks like Sumotoy's RA8875 library is broken, and was broken in prior releases too. The non-optimized Adafruit_RA8875 seems to work fine.

Does anyone else have a RA8875 display for testing?

09-06-2017, 12:58 AM
Looks like Sumotoy's RA8875 library is broken, and was broken in prior releases too. The non-optimized Adafruit_RA8875 seems to work fine.

Does anyone else have a RA8875 display for testing?
I don't, but played with an updated version using my spin library and I know a few users tried it in the thread https://forum.pjrc.com/threads/40252-Teensy-3-6-with-RA8875-TFT?p=125295&viewfull=1#post125295
Also in that thread there was talk about some needed to change speed

09-06-2017, 11:18 AM
I tested several more libs on different boards. Things seem to be working, at least as well as they have in 1.37 & 1.38.

I do believe some of the older libs might have issues with newer Arduino or perhaps just newer versions of the hardware they use. But with 1.38 not working at all on Teensy LC, it's time to get a 1.39 release pushed out that works as well as possible at this point.

09-06-2017, 11:23 AM
Been running it on my rover with no problems. Just a couple of warning in adafruit libraries (motor shield). Ran it against a few other projects and everything compiled without any issues.