PDA

View Full Version : [Posted] TeensyCEC: The teensy 3.6 Console Emulators Collection



Jean-Marc
08-19-2018, 01:50 PM
A new project featuring few emulators running full speed on the teensy 3.6 with ILI9341 and VGA display
- Atari2600, Colecovision and Odyssey currently supported
- NES is on its way

Visit the project at:
https://github.com/Jean-MarcHarvengt/TeensyCEC/blob/master/README.md

Jean-Marc
08-27-2018, 07:51 PM
now added the support for Nintendo NES 32k games in teensynes

Jean-Marc
08-31-2018, 07:03 AM
ZX spectrum core added

tonton81
08-31-2018, 07:05 AM
no N64? :P when I saw CEC I thought this was for HDMI control hehe

Jean-Marc
08-31-2018, 08:43 AM
No, sorry for the confusion indeed...

Jean-Marc
09-02-2018, 06:47 PM
for the one interested in ZX spectrum emulation, I now added support for a custom I2C keyboard with 40 keys

Robin
02-21-2019, 10:53 PM
This went up on the blog today :)
https://www.pjrc.com/console-emulators-collection/

Jean-Marc
02-23-2019, 08:13 PM
Thanks Robin, that's cool to be on the main page...!

Jean-Marc
02-23-2019, 08:19 PM
I moved the NES emulator to the NoFrendo emulator core.
It is running full speed with sound!
At least it is possible to run 48k games on the TFT now. Unfortunately I miss some memory for the VGA output so only 32k games there...

Code https://github.com/Jean-MarcHarvengt/TeensyCEC in teensynofrendo sub-directory
Have fun...

Frank B
02-23-2019, 09:07 PM
This will be very great with the T4.. someone has to port the VGA-Code to the T4 :)
It's mentioned here already: https://forum.pjrc.com/threads/54711-Teensy-4-0-First-Beta-Test?p=193719&viewfull=1#post193719

Robin
03-05-2019, 07:15 PM
The project has now been covered by Hackster.io (https://blog.hackster.io/run-a-whole-bunch-of-video-game-emulators-on-a-teensy-3-6-fef5a062adcd) :)

Jean-Marc
03-08-2019, 07:04 AM
Cool Thank you Robin!
Still busy to port the building blocks to a new MCU, guess which one...;-)

guago1
10-03-2019, 07:10 AM
Will it work with teensy 3.5?

Jean-Marc
10-03-2019, 06:06 PM
Will it work with teensy 3.5?

Not tried on the T3.5 (I don't have one) but it now works on more platforms including the cheap and great Teensy4.0 allowing AtariST emulation

https://github.com/Jean-MarcHarvengt/MCUME/

Jean-Marc
11-24-2019, 05:16 PM
More emulators ported to the derived project
Recently added PC engine, Gameboy, Sega Master System, Megadrive and AtariST using external a PSRAM module..
https://github.com/Jean-MarcHarvengt...ster/README.md

The list becomes bigger every day: Atari 2600,Odyssey,colecovision,Atari5200,Vectrex,NES,PC Engine,Sega Master System,Sega Game Gear,Sega Megadrive and Gameboy.
And for the computers: ZX81and spectrum, Atari800,C64,AtariST, 8086 XT.
Only theTeensy 4.0 supports them all!

https://youtu.be/j2sKw7KYpEo