PDA

View Full Version : Teensyduino 1.45 Released



Paul
12-10-2018, 08:07 PM
Teensyduino 1.45 has been released.

https://www.pjrc.com/teensy/td_download.html

The main new feature is support for Arduino 1.8.8.


The only change since 1.45-beta2 (https://forum.pjrc.com/threads/54543-Teensyduino-1-45-Beta-2) was commenting the 256 MHz overclock lines in boards.txt, as Frank B suggested.

defragster
12-10-2018, 10:44 PM
...
Changes since Teensyduino 1.44

Support for Arduino 1.8.8
Updated libraries: i2c_t3, Snooze
Teensy 3.6 overclock to 256 MHz (Frank B)
Fix serial begin() lockup if framing error received in FIFO when end() called
Audio add AudioControlTLV320AIC3206 (Chip Audette)
Teensy Loader icon added for Gnome desktop on Linux


...

Changes since Teensyduino 1.45-beta1 (https://forum.pjrc.com/threads/54518-Teensyduino-1-45-Beta-1)

Add 256 MHz Teensy 3.6 to Tools > CPU Speed menu
Fix asm in delayMicroseconds on Teensy LC (Frank B)
Audio: Fix ADAT output with 168 MHz (Frank B)

… The only change since 1.45-beta2 was commenting the 256 MHz overclock lines in boards.txt, as Frank B suggested.

<edit>: and the cool thing is TyCommander still works

NebulaH
12-12-2018, 10:35 AM
I'm afraid some stuff is broken for the 8-bit series of controllers:
- Teensy 2.0(++) worked fine with Arduino 1.8.7 + Teensyduino 1.44
- the hardware definitions in Teensyduino 1.45 are probably corrupted because I only get the 32-bit operating speeds with the Teensy 2 boards.

PaulStoffregen
12-12-2018, 11:38 AM
Can't reproduce the problem here. Looks fine when I try. Here's a screenshot.

15342

Maybe I tried the wrong way? Any chance you could be more specific about the problem? Maybe show a screenshot, so we can actually see the same problem you're seeing?

Frank B
12-12-2018, 08:40 PM
Works for me, too.

defragster
12-12-2018, 08:55 PM
Never had any Teensy_2 - but IDE board select does show the choices like post #4

defragster
12-14-2018, 08:04 AM
Paul: Have you changed the factory boot test Blink code to present the Teensy Type to the SerMon Teensy_ports indication? It seems that would work as a diagnostic since the IDE supports that now - I asked as that was released with TD update and not sure if it got answered?

TD 1.45 didn't get the change for usb_init_serialnumber() to return MCU Ser# when -1 was the result of one time serial # reading? @crees left code he saw working but I never tried it - and this K66 PROTO board could use it.
POST :: Custom-Teensy-Write-Once-Memory-quot-Burn-quot-Direction-needed (https://forum.pjrc.com/threads/53627-Custom-Teensy-Write-Once-Memory-quot-Burn-quot-Direction-needed?p=191807&viewfull=1#post191807)

<edit>: I just tested that on the K66 PROTO board and it works to have Serial # for TyCommander … mostly :: 1313158531-Teensy
On Power up plug in and AFTER reprogramming TyCommander shows that as the Serial#.
BUT - on transition with TyComm RESET or Upload with reset it reverts to showing:: 4294967295-Teensy until it restarts. And that confuses TyComm as it expects Serial# continuity. Seems the bootloader chip returns the chip's one time write Serial # when it gets control?

PaulStoffregen
12-14-2018, 06:30 PM
Paul: Have you changed the factory boot test Blink code...

No, and I'm not planning to mess with the test fixtures we use, at least not anytime soon. This sort of update is pretty much at the bottom of my priority list right now.

crees
12-14-2018, 10:54 PM
<edit>: I just tested that on the K66 PROTO board and it works to have Serial # for TyCommander … mostly :: 1313158531-Teensy
On Power up plug in and AFTER reprogramming TyCommander shows that as the Serial#.
BUT - on transition with TyComm RESET or Upload with reset it reverts to showing:: 4294967295-Teensy until it restarts. And that confuses TyComm as it expects Serial# continuity. Seems the bootloader chip returns the chip's one time write Serial # when it gets control?

interesting. I have the same issue hitting reset on tycommander. However if I hit reset twice I get the board back again the way it should. This issue will add some complexity to custom teensy boards. I have some ideas on a work around but will need to do some tesing

defragster
12-14-2018, 11:12 PM
@Paul : I can see that being low import - might help newbies, and risky to change the tested and working system without extensive testing.

@crees : Same process - I removed the code :( … I posted on the TyComm thread to see if koromix has an idea to fix the transition through reset change. Best thing would be to implement a write to the one time area.

crees
12-15-2018, 12:15 AM
@Paul : I can see that being low import - might help newbies, and risky to change the tested and working system without extensive testing.

@crees : Same process - I removed the code :( … I posted on the TyComm thread to see if koromix has an idea to fix the transition through reset change. Best thing would be to implement a write to the one time area.

Arduino / teensyduino doesn’t seem to have issue with the load / reset and the board comes back with the expected ID. Be interesting to see what tycomm thread has in regards to this.

NebulaH
12-16-2018, 10:44 AM
Hi all, sorry... it took me a while to get back on my reported issue.
Apperently it was me. I did a clean GNU/Linux install on a laptop and copied my ~/Arduino folder over.
Maybe there were incompatible remnants in there. Now that I reverted to Arduino 1.8.7 + Teensyduino 1.44, I can no longer reproduce the behavior with Arduno 1.8.8 and Teensyduino 1.45.

gimpo
12-18-2018, 09:05 AM
It works very well for me, but... again that noising java exception when starting the Arduino IDE for the first time (i.e. after running TeensyduinoInstall.linux64).
The graphic is messed at the first start. I've tested it again on a fresh new installation of IDE 1.8.8 on Ubuntu 16.04.

15389

Again that exception when setting the serial port:
Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
at processing.app.EditorLineStatus.setSerialPort(Edit orLineStatus.java:136)
.
.
.

After setting the port for programming the Teensy 3.2 (e.g. /dev/tty/ACM0), the problem don't arise anymore, even after restarting the IDE more times.
So seems that the program needs the port to be set in order to not block the thread refreshing the graphic interface. Anyway, it's a minor bug.

bicycleguy
12-30-2018, 08:05 PM
On mac 10.14.2, Arduino 1.8.8, runs great, no problems, no warnings.

thanks

HWGuy
01-02-2019, 09:20 PM
again that noising java exception when starting the Arduino IDE for the first time same/similar error here on a new computer with windows 10. If I change the size of the window, the surface will be displayed again normally. Prior to the Teensyduino installation Arduino loaded normal.


Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
at processing.app.EditorLineStatus.setSerialPort(Edit orLineStatus.java:136)
at processing.app.EditorLineStatus.paintComponent(Edi torLineStatus.java:101)
at javax.swing.JComponent.paint(JComponent.java:1056)
at javax.swing.JComponent.paintChildren(JComponent.ja va:889)
at javax.swing.JComponent.paint(JComponent.java:1065)
at javax.swing.JComponent.paintChildren(JComponent.ja va:889)
at javax.swing.JSplitPane.paintChildren(JSplitPane.ja va:1047)
at javax.swing.JComponent.paint(JComponent.java:1065)
at javax.swing.JComponent.paintChildren(JComponent.ja va:889)
at javax.swing.JComponent.paint(JComponent.java:1065)
at javax.swing.JComponent.paintChildren(JComponent.ja va:889)
at javax.swing.JComponent.paint(JComponent.java:1065)
at javax.swing.JComponent.paintChildren(JComponent.ja va:889)
at javax.swing.JComponent.paint(JComponent.java:1065)
at javax.swing.JComponent.paintChildren(JComponent.ja va:889)
at javax.swing.JComponent.paint(JComponent.java:1065)
at javax.swing.JLayeredPane.paint(JLayeredPane.java:5 86)
at javax.swing.JComponent.paintChildren(JComponent.ja va:889)
at javax.swing.JComponent.paintToOffscreen(JComponent .java:5217)
at javax.swing.RepaintManager$PaintManager.paintDoubl eBuffered(RepaintManager.java:1579)
at javax.swing.RepaintManager$PaintManager.paint(Repa intManager.java:1502)
at javax.swing.RepaintManager.paint(RepaintManager.ja va:1272)
at javax.swing.JComponent.paint(JComponent.java:1042)
at java.awt.GraphicsCallback$PaintCallback.run(Graphi csCallback.java:39)
at sun.awt.SunGraphicsCallback.runOneComponent(SunGra phicsCallback.java:79)
at sun.awt.SunGraphicsCallback.runComponents(SunGraph icsCallback.java:116)
at java.awt.Container.paint(Container.java:1978)
at java.awt.Window.paint(Window.java:3906)
at javax.swing.RepaintManager$4.run(RepaintManager.ja va:842)
at javax.swing.RepaintManager$4.run(RepaintManager.ja va:814)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessI mpl.doIntersectionPrivilege(ProtectionDomain.java: 74)
at javax.swing.RepaintManager.paintDirtyRegions(Repai ntManager.java:814)
at javax.swing.RepaintManager.paintDirtyRegions(Repai ntManager.java:789)
at javax.swing.RepaintManager.prePaintDirtyRegions(Re paintManager.java:738)
at javax.swing.RepaintManager.access$1200(RepaintMana ger.java:64)
at javax.swing.RepaintManager$ProcessingRunnable.run( RepaintManager.java:1732)
at java.awt.event.InvocationEvent.dispatch(Invocation Event.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.j ava:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessI mpl.doIntersectionPrivilege(ProtectionDomain.java: 74)
at java.awt.EventQueue.dispatchEvent(EventQueue.java: 728)
at java.awt.EventDispatchThread.pumpOneEventForFilter s(EventDispatchThread.java:205)
at java.awt.EventDispatchThread.pumpEventsForFilter(E ventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarch y(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispa tchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispa tchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThre ad.java:82)

15481

gimpo
01-02-2019, 09:57 PM
So, I'm not the only one seeing it! :D
Anyway, a minor bug.

PaulStoffregen
01-03-2019, 07:31 AM
Yup, it's a bug. Already fixed in the 1.46 betas, if you want to grab the installer from msg #2 in the huge beta test thread.

HWGuy
01-03-2019, 12:46 PM
Can confirm it's fixed in 1.46-beta5.

phijun
02-07-2019, 08:16 PM
Can confirm it's fixed in 1.46-beta5.

Please what's is the link for 1.46-beta5 ?
Thanks

defragster
02-07-2019, 10:44 PM
post #2 on this thread Teensy-4-0-First-Beta-Test (https://forum.pjrc.com/threads/54711-Teensy-4-0-First-Beta-Test)

Latest Beta now #9

phijun
02-08-2019, 01:38 PM
post #2 on this thread Teensy-4-0-First-Beta-Test (https://forum.pjrc.com/threads/54711-Teensy-4-0-First-Beta-Test)

Latest Beta now #9

got it, many thanks