PDA

View Full Version : RFM12 library



se5a
11-18-2012, 11:01 PM
so I got a couple of the little RFM12BS radios to play with, and wired them up as per the https://github.com/tht/T3Libs readme on two different T3s

uploaded the example sketch in the library and opened the serial window, but got nothing on either of the two t3s (connected to two different PCs)
noticed the band was wrong and changed it to 433 (line 27 in the example) but still nothing, tried 434 since the radio's had 434MHz on the silkscreen but 434 is not defined. don't know enough to mess with that, or if 433 or 434 is correct.

I *should* be getting "Starting..." in the serial output even so, but not even seeing that (I stuck in a 5s delay to allow me to connect to the serial port) it's using uart rather than serial which I've not messed with before either, so I'm not sure there.

not sure where to troubleshoot from here.

JBeale
11-18-2012, 11:07 PM
The actual frequencies are near to 433.95 MHz, and it is usually called the 433 MHz band although it it is in fact closer to 434 MHz if you were rounding. Beyond that I don't know where to start troubleshooting. If you have a scope, you can check that the current spikes up when transmitting.

se5a
11-19-2012, 12:41 AM
Thanks John, I wondered if that might be the case.
unfortunately I don't have a scope, so trying to rely on serial output for debugging, except I'm not getting serial output.

ended up just changing uart to serial and got going that way.

simulacrum01
11-21-2012, 02:00 AM
Having the same problem. We hooked up our Teensy 3.0 and our RFM12B, loaded up the the demo sketch provided with the library and... nothing. My first thought was to change uart to serial but that didn't resolve the problem. se5a, did you get it working? if so, did you change anything else?

se5a
11-21-2012, 03:08 AM
changing uart to serial and changing the band to what my radios were operating at was all I needed to do to get it going
I stuck a delay(10000) in the startup before the serial.printline("Starting.....") to give me a good 10 seconds to connect the serial port.

Once I'd got it going I messed around a bit and changed the library to make it easier to change the IRQ pin, I've forked it on github.

simulacrum01
11-21-2012, 06:51 PM
Thank you!!! The delay() was exactly what we needed

se5a
11-21-2012, 08:44 PM
I've not tried this but you can also do this in the setup:

Serial.begin(57600);
while (!Serial) {} //wait for serial

which is supposed to delay the whole program until the serial monitor is connected if usb is connected.
getting the T3 to autoreboot when opening a serial connection from arduino is on Paul's todo list.