Search results

  1. barahlo

    Teensy 3.6 attempt to integrate Audio Adaptor to PCB

    I connected Teensy 4.1 through jumper cables to my pcb, swapped 3.6 pin order to 4.1. Loaded Scanner example and added "analogWrite(23,20)" in a loop... "No I2C devices found" Voltages on VAG and HP_VGND are also wrong. So looks like its a fake chip problem(
  2. barahlo

    Teensy 3.6 attempt to integrate Audio Adaptor to PCB

    Yeah, i heard that fake semiconductors are a big problem, but I'm in Ukraine and local suppliers don't have this chip in stock now, so i tried Ali... Is there any way to test-check if the chip is fake/not working? Maybe there is some correct resistance or voltage on pins that i can check? But i...
  3. barahlo

    Teensy 3.6 attempt to integrate Audio Adaptor to PCB

    Hi! I'm trying to integrate an audio adaptor into the PCB of my synth. Copied Schematic, Rev C For some reason, there is nothing on a headphone output, meanwhile, USB output works correctly. I believe i made some mistake but I cannot find it, schematic seems to be right, voltages also. Could it...
  4. barahlo

    ILI9341 SPI and noise

    You are right about the green wires, it connects dacs to a 3.5 jack, the orange one is a ground of audio input, its not active at this moment so I don't think it has any effect on a noise situation, but i will definitely move it to a different place in future. Here is a SCK wire, highlighted by...
  5. barahlo

    ILI9341 SPI and noise

    Yeah tried USB output just before reading your comment, sound is clear there. Probably you are right poorly designed board is a reason, which is not a surprise) Will try to add 100ohm resistor to SCK. Also was thinking about to try output audio through PT8211 DAC, it uses pins 9,23 and 22 maybe...
  6. barahlo

    ILI9341 SPI and noise

    At first, i thought that it's maybe a software issue, that's why I decided to message you. Now I'm not that certain about it but maybe you or someone else can point me in a direction of the answer. I have close to zero experience in EE and programming so this project is my way of learning it...
  7. barahlo

    ILI9341 SPI and noise

    Hi! I'm working on my teensy synthesizer project and ran into a problem. I use teensy 3.6, without an audio shield. And want the synth interface to be displayed on a ILI9341. Every time the display updates with new text or any other graphic it produces short high pitch noise, changing SPI speed...
  8. barahlo

    Audio glitches when using ILI9341.

    hey, it was a long time since your post, but i have a similar problem. Have you figured out the reason of the sound glitches
Back
Top