Search results

  1. H

    Waveshare 1.54 inch mono epaper/e-ink module and Teensy (problem and answer)

    I've answered my own question - I put it here to help others who make the same mistake. I recently bought a Waveshare 1.54 inch e-ink module and tested the sample Arduino code from their github. The results were confusingly erratic, ranging from sometimes 'not working at all' to sometimes...
  2. H

    Teensy 3.6 on ubuntu, serial monitor is not available

    Just a note to say that this change to the udev rule helped me with a standard arduino problem. I had a Mint Linux system that had been running arduino (and Teensy) perfectly, using a modified version of the Teensy udev rule file for the arduino. Then suddenly (probably after a Linux update)...
  3. H

    [?] Cross compiling bypassing completely Arduino IDE

    Also @luni - could you may have missed my post on another thread reporting a small problem I had with VisualTeensy... https://forum.pjrc.com/threads/53604-Compiling-Teensy-Sketches-with-VisualCode-(Win10)?p=190601&viewfull=1#post190601
  4. H

    [?] Cross compiling bypassing completely Arduino IDE

    Doh! OK, somehow by some google cross device history/search magic I was in a reduced/mobile version of the site on my PC after browsing on my phone a few days ago. Only a small 'goto full site' button at the bottom of screen as a giveaway. So - here is the .rtf :D
  5. H

    [?] Cross compiling bypassing completely Arduino IDE

    I did look in advanced mode. I may be in some 'Newby' mode as I only registered recently (I had to put the CODE tags in manually - or is that normal?)
  6. H

    [?] Cross compiling bypassing completely Arduino IDE

    Hmm... I produced a lovely .rtf file with changes highlighted - any idea how I can attach it here or send it to you via this forum @luni? In the meantime here is the linux makefile #****************************************************************************** # Generated by VisualTeensy...
  7. H

    [?] Cross compiling bypassing completely Arduino IDE

    Certainly. Let me review what I did and I'll send you a project with with some comments on what I did. Much was obvious (paths etc.) but there was at least one change that took a bit of thinking about and more learning about make than I really wanted!
  8. H

    Compiling Teensy Sketches with VisualCode (Win10)

    @luni I had a problem when I first ran VisualTeensy (V0.8.2). I got an "Object not set" exception on startup. I downloaded the source and stepped through it in debug. The problem turned out to be my non standard Arduino install directory (G:\Arduino). I had to manually edit...
  9. H

    [?] Cross compiling bypassing completely Arduino IDE

    I too became quickly frustrated with the Arduino IDE (some years ago now). It's great for beginners but not for someone who has used a 'grown up' IDE... I tried my own makefile which worked well but was a pain to edit (I don't really know make very well). I tried the Eclipse Arduino plugin. It...
  10. H

    Teensy Qt

    Why have I only just found out about TyCommander?! Excellent tool - many thanks @Koromix. I hate to think how many times I've had to restart putty over the years!
Back
Top