Search results

  1. V

    Teensy 4.0 can´t see a I2C device in port 1

    That cables (yellow and Blue) are the reference power for the level shifter (5v and ground)... Do you think could be the library? Maybe someone knows another library that I can use for I2C in teensy 4.0?
  2. V

    Teensy 4.0 can´t see a I2C device in port 1

    Hello Pete! Here are some photos First the connections in teensy, red wire in pin 16 (SCL1) and blue wire in pin 17 (SDA1) Then, connections in level shifter. Red in LV1, Blue in LV2, 3.3v(orange) and GND(Blue) from Teensy. Then in the other side Green to HV1, Yellow to HV2, and 5v and GND...
  3. V

    Teensy 4.0 can´t see a I2C device in port 1

    Thanks for running the code, I think everything is fine with the LCD because if I connect in port 0 (pin 19, 18) the scanner detectets inmediately, but in port 1 (pin 16, 17) nothing happened.
  4. V

    Teensy 4.0 can´t see a I2C device in port 1

    Thank you again! I tried that code, but is still showing "No I2C devices found" :( Maybe I should use the i2c_t3 library? But the documentation tells that is not compatible with teensy 4.0
  5. V

    Teensy 4.0 can´t see a I2C device in port 1

    Thanks for your answer, actually I checked the connection many times and that is ok... I think is a problem of the port 1, because there is no problem if I use the port 0
  6. V

    Teensy 4.0 can´t see a I2C device in port 1

    Hi everyone! I'm trying to solve this, but I can´t find any information who helps me untill now, so I decide to ask the community. This is the problem: I'm trying to use an lcd 1602 through I2C port 1, when I did in port 0 everything goes perfect, but I can´t do it in port 1. I used the...
Back
Top