Search results

  1. M

    Using SPI1 pins on the Teensy 4.1

    Hey all, I am trying to use the second set of SPI pins on my Teensy 4.1 since the first set is being used by an RFM95W. My project is nearing completion but I've decided to use the second set of SPI pins instead of the third I2C. This is mainly because SPI seems to provide the data faster. As...
  2. M

    Teensy 4.1: Multiple I2c and SPI devices

    It worked! Thank you!!!
  3. M

    Teensy 4.1: Multiple I2c and SPI devices

    Thank you! I will give this a try!
  4. M

    Teensy 4.1: Multiple I2c and SPI devices

    Hey all, Re: Teensy 4.1 I am having difficulty connecting multiple I2C devices (using the SDA, SCL, SDA1, and SCL1). I am trying to connect a BMP390 via I2C and an LC709203F via I2C. I have the LC709203F connected to pins 19 and 18 and this works. The BMP390 is connected to 16 and 17 and is...
  5. M

    PlatformIO: 'BUILTIN_SDCARD' was not declared in this scope

    Thank you so much!!! That fixed it!!!
  6. M

    PlatformIO: 'BUILTIN_SDCARD' was not declared in this scope

    Hey All, I have been having difficulties with PlatformIO and Teensy 4.1 lately. I solved some of my issues by reinstalling Windows, but now I am having other problems. - When compiling my code, I get the following error: "'BUILTIN_SDCARD' was not declared in this scope." When using the SD.h...
  7. M

    Can no longer upload to Teensy 4.1 via PlatformIO or Arduino IDE

    So I think I fixed it... Well, mostly. I did a fresh install of Windows 11 and I can upload and open the serial monitor from PlatformIO. The only thing is, I have to press the Teensy's button after clicking the "Upload" button, and once the terminal says "Uploading." Also, I was getting an...
  8. M

    Can no longer upload to Teensy 4.1 via PlatformIO or Arduino IDE

    Hey All, I have been trying to figure out my problem for hours today and have come up with nothing. I can no longer upload to my Teensy 4.1 from platform IO and can't open the serial monitor in the Arduino IDE. I can INTERMITTENTLY upload via the Arduino IDE, however. The problem started...
Back
Top