Adafruit RA8875 the Sumotoy libray and the Teensy 3.6 = distorted graphics

Not open for further replies.


Well-known member
I have a 5" Adafruit touch display, the Adafruit RA8875 driver board a Teensy 3.6 all connected. When I run an Adafruit example it looks great. When I try one of the Sumotoy library examples things get weird. It's a bit distorted like an old TV that's out of sync (those of you old enough recall scramble porn on HBO) sort of like that.

In my searches I ran across references to lowering the SPI speed. I tried that ( think I did it correctly ) but to no adavantage. The initial culprit is often the wiring and wire lengths but the fact the Adafruit library is fine leads me away from that for now (unless Sumotoy runs it higher). I tried various branches of their library with no difference.

I'm hoping somone might have ran into this and have some insights. Below is it running the Adafruit.


This is the Sumotoy clock example.

I have one of these displays as well. Just a quick thought did you remember to use "Adafruit_800x480" instead of "RA8875_800x480"? Had to ask.

The Sumotoy library is a bit out dated and i don't really really use that version. A few of us did some modifications and updates of the library to get it to work with the T4 but I can't remember how much testing of this version we did on T3.6... I you are interested you can try this version Sumotoy's library:, [/QUOTE]

EDIT: if you do search for RA8875 on the forum:

there are more....
I did use Adafruit_800x480. However, I don't believe I've tried that version of the library. I'll give a try.

It's as if there is some sync issue when the display tries to draw about half way across.
OK, I found that I was still using a default library in C: after turning on the verbose warnings.

The library suggested renders this for the clock example now. It's not wavy now but the lines are obviously not correct.


The blue screen was with the original library's pattern example.


  • 20191214_101647.jpg
    128.5 KB · Views: 121
Last edited:
Seems the only one that works normally for me is the default .70. Otherwise text goes to odd places and I get those lines in the clock.
Just hooked up my Adafruit RA8875 to a T3.6 and saw the same problem. Resolved it though by going into RA8875UserSettings.h and changed the MAXSPISPEED from 22000000 to 12000000 and that seemed to clear the problem up with the display.
I must have changed the wrong area. I was changing where there are several speed distinctions. I'm not at the computer now so I can't check exactly. I will try again. Thanks.
I changed it to 12000000 here. It seems to be stable and normal now.

	#if defined(__MK20DX128__) || defined(__MK20DX256__)  || defined(__MK64FX512__) || defined(__MK66FX1M0__) || defined(__IMXRT1062__)
		const static uint32_t MAXSPISPEED	= 12000000UL;  //don't go higher than 22000000!;
It's all working now thanks. However, I didn't account for the display flicker issue (not related to previous issue) when drawing new text. So, after all of this it looks like I will have to abandon the RA8875 since I will be updating several text fields about 4 times a second and I can't seem to find a satisfactory way to eliminate the strobe effect.
Anyone know how to get back to the default internal font after having selected a different one?
If your display variable is called tft, try:

That sets the internal font point to NULL, which tells the code to use the default internal font.
If your display variable is called tft, try:

That sets the internal font point to NULL, which tells the code to use the default internal font.

Won't compile if left empty. I tried 0 and NULL and whatever else I could think of as well.
I will try the INTFONT next.

Well whatever I did it didn't like it. I went back to to where things were working (original font settings) but now it won't display anything at all.
Last edited:
Not open for further replies.