Arduino IDE gone all screwy


Well-known member
Hi all

Been programming my Teensy 3.2 fine.

Today, it throws up:

Previously selected Teensy port is offline.
1 other Teensy board found. Please select
this Teensy from the Tools > Ports menu.

But I have changed nothing. Updated the Teensy boards manager (it was the latest one anyway).

There are 2x ports listed in the Tools menu. One is for Teensy 3.2(serial), and the other for Teensy 3.1/3.2. Code says it uploaded using the Teensy 3.1/3.2 version, but doesn't. Then it throws that error above.

If you use the Teensy 3.2(serial) selection, then the code definitely loads, but then the serial monitor throws up this when you try to open it:
Error opening serial port 'usb:0/140000/0/6'. (Port busy)

So tired of this temperamental Arduino IDE. IT SUCKS
Error opening serial port 'usb:0/140000/0/6'. (Port busy)

Have you tried rebooting your PC?

Usually a port busy error means some other program is holding the port open. It might be a stalled copy of Arduino. Or might be something else unrelated. If you're not active running something which does that, if it's just a leftover instance of something that stalled, rebooting might cure it.
I am so angry.... dead 3.2? Looks like it for no apparent reason. This project board worked fine for weeks and then I left it a while. Back to it tonight and dead.

Just grabbed my last 3.2 from the workshop and that appears in the Device manager list, but this one doesn't. Yet, if I press the Teensy button on the dead one, it refreshes the device list, but never appears...

Yes ... rebooted
What the hell is going on.

OK. The apparently dead 3.2 didn't show up at all in Device manager. Another Teensy 3.2 however did.
So I put the 'probably dead' Teensy 3.2 onto my cheapy backup laptop and all is fine. Appeared in Device manager and accepted Blink immediately.

Plug it back in the original laptop where is was ignored, and it appears.

Serial ports for serial debug don't work at all however... still get the Error opening serial port 'usb:0/140000/0/6'. (Port busy)

Please tell me I don't have to uninstall the Arduino IDE for the 10th time in a year. It never uninstalls correctly, it then takes forever to get all the boards etc back.

I need a new hobby, this one sucks the big one most of the time.. bah

I also just notices there are no programmers available in the Teensy list. When I reinstalled the Teensy boards manager, it did fail the first time (can't remember the error). Maybe that screwed it up.
Windows sets aside a COM# to assign a given device when it is first seen - it seems.

I recently had come Bluetooth device then get stacked on that same COM# and when it did the lookup it didn't treat the old device properly. Had to RegEdit and find the overlap and remove things - made a post then - don't recall full process details now - it was a hassle.

One quick test would be to build the sketch a 'DUAL SERIAL'. That shows Windows what it thinks is a 'New Device' and the two ports get new COM#'s - IIRC. Then while building as 'Dual Serial' that Teensy might work, and it will confirm that.

One other thing to do {with Teensy unplugged} is in the IDE do a 'Verify' build that preps the Teensy Loader with a known sketch to upload ( this might work as 'normal Single' Serial ).
With that done prepare to plug the Teensy in while holding the button down.
Holding the button plug the Teesny and wait a half second then release the button and the Loader ( using the HID interface ) should upload the program.
> Question then is if it programs - does it appear as a COM# device and can the Serial Monitor connect to it?
I think the whole thing is a mess.

I only re-installed the IDE a few weeks ago after it corrupted and messed up a whole pile of things. Tonight I went to edit my Teensy 3.2 project and realised the Teensy boards had not been added back in.
I added them through the boards manager, which failed with some odd error, so I tried again and it worked.

But then all the ports got screwed up.

If I uninstall the IDE yet again, I doubt it will clear the problem. These crap uninstallers never remove everything (a quick C drive search proves that)

Not sure I understand your suggestions defragster!

I did notice that on my old rubbish laptop (that works), the Teensy board manager isn't listed in boards manager (or the preferences text file), yet the Teensy loader works fine. How did I load that then?
I assume I added the Teensy boards manager from outside the Arduino IDE.
@SteveCS - For IDE 1.8.19 there is the TeensyDuino installer from the that bypasses the Board Manager as the only way to add Teensy support.

For IDE 2.0.3 there is Board Manager support for 'Teensy' where like above the current version is 1.57. It also shows 0.58.3 as the current Beta version under test.

Not sure which version is in use? Indeed installers have issues. For using the IDE 1.8.x here has been 'installed' using the ZIP version unpacked to a folder. For IDE 2.x that worked at first but as soon as they let you pick UPDATE as it evolves they use their 'Installer' for the update - this Orphans the old ZIP install.

So this 2 yr old computer never had an IDE 1.8.x install done - but the IDE 2.x has installed with installer. Perhaps the problem is in the SKETCHBOOK folder that is used from version to version - depending on the location indicated in the Properties page?

The verbose console output shows the paths used for build and source and library files. Giving that a scan may show that installations are mixed up or getting confused with files in 'Sketchbook'\Libraries?

Wow - been here 8 years now - the IDE has its issues from an idividual programmer perspective - but one thing it generally offers is 'one stop shopping for easy installation' for a consistent development environment - well 'one stop' the IDE and then the TeensyDuino installer for ver 1.8.x and now Board Manager for ver 2.x.

What OS is in use on the two machines? Using Windows here as noted the troubles showing there have not appeared here (thankfully).
I have had lots of problems with the latest Arduino IDE. In fact, I find version 1.8.5 to be the most stable for my needs. Higher than that breaks quite a lot of my projects for various reasons.

I just wish that uninstall meant... uninstall, not leave a pile of crap on the drive anyway. It's not just the IDE that does it, I find that with many programs.

Win 10 on both laptops. The crappy £399 HP laptop is biblically slow, but usually works bulletproof. The £2800 Asus however..... troublesome puppy
This is the download page, where you got the software previously.

The older 1.8.x versions of Arduino have a "portable mode", which you might like. Portable mode causes everything to be stored within the Arduino software folder. All settings, installed libraries, saved files, etc are stored within that copy of Arduino, so it doesn't use files anywhere else on your PC. This mode was meant for students to have a completely self contained copy on a USB stick which could be used on any PC, even university computers which regularly get reformatted. It's really convenient if you just want a copy that's independent of everything else on your PC. Of course the downside is you can't really upgrade to newer versions and have all your settings and saved data accessible, because everything it embedded within the folder of 1 specific copy of Arduino software. But with all active development now on 2.0.x, it's pretty safe to assume Arduino will never publish 1.8.20.

To use it with Teensy, follow the "Windows Non-Admin Installation" steps. But between step 2 and 3, add the portable folder inside the freshly extracted Arduino.

When you run the installer, it will automatically detect you've created the portable folder and do the install accordingly.
I just wish that uninstall meant... uninstall, not leave a pile of crap on the drive anyway. It's not just the IDE that does it, I find that with many programs.
IObit Uninstaller takes out all the registry entries and other stuff that gets installed with a program. Might be worth a try.
The Teensy installer doesn't work, can't find lib/version.txt. But I have checked at that file is there.

Is it because I am currently running IDE 1.8.18? It worked fine before.

The IDE is screwed too, as it basically shows no ports at all for anything. Not re-installing that again.

I Finally got the Teensy stuff re-installed and its the same. Screwed up ports and no programmers to pick from. Can't talk to the 3.2 (Arduino Mega works fine)

Time to walk away and find a new hobby. Unfortunately, life is too short for this
Last edited:
exec: "C:\\Users\\steve\\AppData\\Local\\Arduino15\\packages\\teensy\\tools\\teensy-tools\\1.57.2/precompile_helper": file does not exist
Error compiling for board Teensy 3.2 / 3.1.

Maybe Windows Defender or some anti-virus program mistook it for a threat and deleted or moved it to a quarantine folder?
Is it because I am currently running IDE 1.8.18?

When you run the installer, on the very first screen before clicking Next it shows a list of the supported Arduino versions.


1.8.18 is not on the supported list for Teensyduino 1.57.

I uninstalled everything. Deleted the arduino folder in x86. Could find no other associated folders.

Then I re-installed version 1.8.19 and it starts up with the file I last had open, and all the goddam libraries I had added in the preferences text file. UNINSTALL means get rid of
So, it's not a clean install, it's just populated it back as it was.
Therefore, the ports issue won't have changed.

What idiots design this stuff
There is additional Arduino stuff to be found here: C:\Users\<yourname>\AppData\Local\Arduino15.
This is also where the file preferences.txt resides.
Not sure whether this directory is also emptied when an uninstall is done. If not, just delete the Arduino15 directory.

Opening the IDE 1.8.19 and doing 'Ctrl+,' open the preferences. There is a button to open 'More preferences can be edited' - it is a simple text file.
> That file and folder will not be destroyed as it can be shared across IDE 1.x and 2.x. It tracks last open sketch

And libraries installed in 'sketchbook'\libraries are also "your property" to manage.

@PaulS crosspost - confirm what he said.
6.2GB - 61,000 files. That's what a search of 'arduino' on the the 'C' drive has brought up.
Uninstalled my *rse
Here the 2 year old Win 11 machine shows 133,997 files and 28,236 folders using 21.3 GB on C: disk with search for 'arduino'.

Again - some of those files are 'for IDE use' that are not part of the IDE. The IDE has no right to remove those things as they may contain edits or custom sources or libraries that are not part of the IDE installation.

There are ARDUINO15 folders in %appdata% holding IDE shared files as well - like the "preferences.txt" used between one or more instances of the IDE 1.x or 2.x. Having those persist also prevents 'loss of custom changes' - but includes file history and other things as well.
Well, binned all the files it would let me (except for ones that I obviously want to keep like CAD files etc named Arduino)
There were a few it would not let me delete (system)

Re-installed. Early signs are good. Lets see how it goes

ArduinoPins.h file (or something along those lines) in appdata. HUNDREDS of them
What idiots design this stuff
normally a uninstall don't delete personal files including the preferences file
this would in most cases be the preferred way when upgrading the IDE

Have you deleted the Arduino15 folder?
this should fix your problem,
otherwise it's a Windows problem which you cannot blame Arduino for

there is also the libraries folder at your sketchbook location (which should only be removed when having problems with library related issues)
the default location of the sketchbook is
C:\Users\<your username>\Documents\Arduino
ArduinoPins.h file (or something along those lines) in appdata. HUNDREDS of them

I empathize with your frustrating situation. Most of my experiences with Windows are like this or worse. I use a couple laptops for testing, where I regularly restore the entire Windows partition to a clean install, because I always have such bad luck with Windows systems getting all messed up. Linux and MacOS have their own issues (especially Linux), but I understand them much better than the way things tend to go wrong with Windows.

Emotional support is all I can offer with with this vague description.

Technical support requires much more specific detail. But to be honest, my solution to all such Windows problems is to just restore the entire partition to a clean install. Probably not so helpful...
Well deleting literally every file with the word Arduino in it appears to have worked.
We are talking 6000+ files (after an uninstall). But, the IDE seems to be back to normal again.
I understand that a lot of files might be third party (and therefore, not the IDE's fault), but the majority of them were associated.

See what happens
When it comes to the IDE 1.8.x the Windows UnZip method was used for running it. Not only was it easy to have multiple installs of the evolving IDE during Beta of IDE and TeensyDuino, but there seemed to be some 'assumptions' going on for things that were messing with things from the IDE's "proper Installer".

Using the UnZip method to a chosen folder it was stand alone with TeensyDuino in that folder. Whatever the mysteries of the year 2015 when starting stopped hitting.

There were COMMON things: Preferences.txt and 'Sketchbook'\libraries : but those were usably accepted things.
For IDE 1.8.x only the UnZip is used here and is recommended - perhaps the issue(s) that pushed that move are still possible problems there?

IDE 2.x is a new beast and it seems to be not having those forgotten 'mystery' issues. And it is becoming more useful and robust.
First 'Pre-Release' installs of 2.x were also 'UnZip' - but the first 'AUTO UPDATE' to a new version pulls down the Windows installer and everything moves to the %appdata% section and orphaned the UnZip folder. So far it has been working properly.

Note: Many/Most builds here are using Windows 'TSET' as a command line build from SublimeText editor. The IDE uses a build line process and that is replicated so the same path and process details result in the same build outside the IDE.
Also TyCommander is typically used for Serial Monitor as it can handle multiple online Teensy output SerMon well and easily, where the IDE SerMon interface is tuned for a single online device (though IDE 2 can see multiple in some fashion IIRC - it isn't yet properly 100% connecting)