Having some trouble compiling AgOpenGPS PANDA

JMky

New member
I am currently attempting to compile a file that others seem to have no problem with and I would like a little push.
I am getting the following errors, specifically the error: 'class HardwareSerial' has no member named 'addMemoryForWrite'
I have installed Arduino 1.8.19 with Teensyduino. I have had the same error in different versions. Hardware is Teensy 4.1, BNO085 IMU , and ZED-F9P rtk gps.
If in wrong area, please advise.
thanks in advance,

Arduino: 1.8.19 (Windows 10), TD: 1.59, Board: "Teensy 4.1, Serial, 450 MHz, Faster, US English"

C:\Users\jmc\Downloads\PandaTPU-main\PandaTPU-main\Teensy4-0_v56_PandaTPU\Teensy4-0_v56_PandaTPU.ino: In function 'void setup()':

C:\Users\jmc\Downloads\PandaTPU-main\PandaTPU-main\Teensy4-0_v56_PandaTPU\Teensy4-0_v56_PandaTPU.ino:202:20: error: 'class HardwareSerial' has no member named 'addMemoryForRead'

202 | SerialGPS->addMemoryForRead(GPSrxbuffer, serial_buffer_size);

| ^~~~~~~~~~~~~~~~

C:\Users\jmc\Downloads\PandaTPU-main\PandaTPU-main\Teensy4-0_v56_PandaTPU\Teensy4-0_v56_PandaTPU.ino:203:20: error: 'class HardwareSerial' has no member named 'addMemoryForWrite'

203 | SerialGPS->addMemoryForWrite(GPStxbuffer, serial_buffer_size);

| ^~~~~~~~~~~~~~~~~

C:\Users\jmc\Downloads\PandaTPU-main\PandaTPU-main\Teensy4-0_v56_PandaTPU\Teensy4-0_v56_PandaTPU.ino:211:21: error: 'class HardwareSerial' has no member named 'addMemoryForRead'

211 | SerialGPS2->addMemoryForRead(GPS2rxbuffer, serial_buffer_size);

| ^~~~~~~~~~~~~~~~

C:\Users\jmc\Downloads\PandaTPU-main\PandaTPU-main\Teensy4-0_v56_PandaTPU\Teensy4-0_v56_PandaTPU.ino:212:21: error: 'class HardwareSerial' has no member named 'addMemoryForWrite'

212 | SerialGPS2->addMemoryForWrite(GPS2txbuffer, serial_buffer_size);

| ^~~~~~~~~~~~~~~~~

Error compiling for board Teensy 4.1.



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
 
quick fix: change occurences of "HardwareSerial" to "HardwareSerialIMXRT".
Proper fix: contact the author of the project and tell them to update their code to match Teensyduino updates.

(Note that there is a comment at the top of the source code saying to use Teensyduino 1.57, because 1.58 doesn't work and future versions are unknown...)
 
Last edited:
Thanks,
That solved the compile errors, still no PANDA sentences.
I see the PANDA 5 setup may not be final and I may have to go with the AIO board if I want AgOpenGPS with IMU.
I really appreciate the quick response. I hope to be able to add to the community farther down the road.
 
Back
Top