Hi,

swathi

New member
I'm working on ili9341 2.8 TFT 240x320 LCD. I driver is loading while boating the board but i can see only the backlight of the lcd as a white in colour. Can anyone help me please
 
Maybe 1 or more wires are not connected properly? If you show us photos of your wiring, perhaps we'll be able to see the problem?
 
Hii,
@PaulStoffregen
I am using kernel version 5.10 and below are the modifications i did in dtsi file.


display: ili9341@0 {
compatible = "ilitek,ili9341";
reg = <0>;
spi-max-frequency = <50000000>;
// clock-frequency = <6350000>;
dc-gpios = <&gpio2 5 1>;
reset-gpios = <&gpio2 6 1>;
rotation = <270>;
rgb;
fps = <60>;
regwidth = <16>;
buswidth = <8>;
debug = <0>;
width-mm = <43>;
height-mm = <57>;
bits-per-pixel = <16>;
status = "okay";

panel-timing {
hactive = <240>;
vactive = <320>;
hfront-porch = <10>;
hback-porch = <20>;
hsync-len = <10>;
vback-porch = <2>;
vfront-porch = <4>;
vsync-len = <2>;
hsync-active = <0>;
vsync-active = <0>;
de-active = <1>;
pixelclk-active = <0>;
};
};
Please check and let me know further what i need to do.
 

Attachments

  • Image.jpeg
    Image.jpeg
    70 KB · Views: 26
  • 1Image.jpeg
    1Image.jpeg
    53.5 KB · Views: 33
what is RST (may be called reset) on the display connected to? I cannot see anything in the photos. And what does you display object create line say (are you specifying the reset line in that statement)?
 
I am using kernel version 5.10 and below are the modifications i did in dtsi file.

I have no idea what software you're using. It doesn't look like anything for Teensy. Normally on Teensy a library like ILI9341_t3 is used.

This forum is about Teensy. If you're using some other board, and especially if also using completely different software than is used on Teensy, this forum is the wrong place to ask for technical support.
 
I'm using customized phyboard ubuntu 20.04 software and BSP Kernel version is 5.10. RST connected to Gpio through resister.
2.8 inch SPI Screen Module TFT Interface 240 x 320 without Touch
 
Back
Top