How to tell my Teensy is dead?

Hello Forum,
Hello Paul,

maybe my nickname here looks a bit outdated as I have question related to the much newer Teensy, the 3.1 and the 3.2 versions that might go to Paul directly.

Actually I do have a bunch of Teensys that don't show up in the Arduino IDE anymore.
I can do what ever I want, and I also did what ever it needed, but there is way to make them appear in the IDE.
I do have some other Teensys ()I do have a lot of them, all purchased from official dealers in Germany, so they are no fakes, or such) that are still visible in the IDE, so I have to assume that this is not the error source.

My question here is
How to determine that a Teensy board is dead?
Is there a way to have a look on that? Maybe measure points that I could use to determine what component went down the river?

Assuming that a component is dead, which one would die first if, lets say I accidently made a short cut? I did not, but just in case.

The bad part of this is that I have two 3.2 boards here that were never in use.
I just opened the package and soldered pins to them.
I do have another 3.1 board that even does not have pins yet, but also does not appear in the IDE as well.

I am a bit nervous, because at the end this would make up almost 100€ of dead boards here if they are gone...

Thank you for your time helping me with this.
Maybe it is the cable. . Try another USB-Cable. Some of them have no data-connections and are for charging only!

p.s. do they blink ? If yes, they are ok.. :)
Last edited:
brand new teensy 3 come preprogrammed with the blink example, so you should at least see the LED blink when power is applied. First law of debugging: thou shalt check voltages ;) Do you measure 3.3V when USB is plugged in? About 5V at Vin?
Run Teensy Loader. With Arduino, it should automatically appear after any successful Verify.

Look for Teensy Loader (not Arduino) to respond when you press the button on your Teensy. There are all sorts of things that can change how Arduino looks. Ultimately Teensy Loader is what matters for troubleshooting whether your computer can program your Teensy.

If Teensy Loader isn't responding, that's a grim sign. But the trouble still could be a bad USB cable, bad hub, power supply issues (if Teensy runs from external power), or PC software issues, such as a missing Linux udev rule.

If you get down to hardware troubleshooting, first disconnect all other circuitry from the Teensy and make sure the VUSB-VIN connection is in place so Teensy is getting power from the USB cable. You should have a solid 3.3 volts on the 3.3V pin. If that checks out, your next step is measuring the Program and Reset lines. Both are supposed to be high (3.3V) normally. Both are supposed to go low while you hold the pushbutton. If they hardware really is damaged, usually you'll see that test fail.
Hello all,

- Yes, I do have some other Teensy 3.x boards and they do appear in the Arduino IDE.
- Yes, I know about the "cable thing", and I made sure to use a cable that is working on the boards that I know to be functional.
- Yes, I know that the boards do come preprogrammed and that they will run the "Blink" program after plugged in to a power source.
Thank you very much for your help, guys, I appreciate your efforts to help me a lot.

Yes Paul, Teensy Loader is not responding.
Nothing happens what ever I try to do. I also installed a software called "TyQt", which also does communication between my PC and the Teensy board, and also it shows proper informations like the serial number of the board, the location and the Interface. I even can upload the firmware if needed. For example the serial of the functioning board is 1361860.
Connecting one of the boards I fear to be broken, nothing shows up here and all the of the field in this software remain grayed out.
I can use those boards I fear to be broken to lit up a separate green 5mm LED that I have here laying around connecting it between the 3V pin and ground, but thats it. Nothing more.

Do you have any further idea?

Thank you in advance
Can you do a high impedance voltage measurement (with a multimeter, not lighting an LED) on the Reset and Program signals? See Pauls post #5
Reading the above - about the two new boards - they were just opened and soldered and not powered first to see the blink - and for clarity - I assume they don't blink now?

Nothing shows as bridged or damaged on close inspection of each of the soldered pins? Did you only solder the 28 edge pins? Any end or internal pins soldered?

Were the above post #5 hardware test tips possible or show anything?

These steps might help if the OS or Teensy is just in a confused state: What OS? Does it change anything to hold the button as you connect the Teensy then pause and release the button (with TYQT open and the TeensyDuino 'Help/Verbose Info' window open? After rebooting the computer?
Try touching the processor when you're plugged in to USB to check if it gets hot to the tough within 10 seconds or so.
Also have a thorough look at all the CPU legs under a lupe. I recently had one Teensy that had a tiny (very tiny) string of solder shorting 3 CPU legs from when I was soldering something to the pins. The Teensy would not show up as a USB device, bot otherwise worked fine (running the loaded program). Removed the solder and all is fine.
Last edited:
@Ben - Yes, I will do a high impedance voltage measurement, but can not do it now because I don't have a meter right now.

@defragster- Yes, I unpacked one of the 3,2 boards, soldered pins to it, plugged it in and it didn't work. The other 3,2 board that I assume was already attached to a circuit, running a neopixel matrix with 121 LEDs. It had a resistor and a condensator in place. (I just had the opportunity to check this again right now, because my stuff is spread at different hackspaces in my hometown and another one a bit away from here)
And yes, both of them are not do the blink, I cannot upload any programs to them, because they do not appear in the Arduino IDE nor in Sublime text editor. I just soldered the "normal" 28 pin headers to them, I made sure not to short cut them, and no internal pins were used or soldered.
The OS I use is Linux Mint on my desktop machine and Xubuntu on my laptop. There is no difference/change pushing or not pushing the Teensy buttons while booting up the PCs or using any software to reprogram the boards.

@Fyod - the boards dont get hot, not even warm
So, the post above was yesterday, today this changed.
But I just wanted to post it anyway because I had it written yesterday already and didn't send yet.

I was able to inspect one of the 3.2 boards under a friends microscope I and saw a tiny tiny tiny solder connection between the pins of the small chip next to the USB port.
Resoldering this with a very small solder tip made this chip come to life again.
HAPPINESS all over my face.

I wasn't able to do this with the other boards as I did not have them with me.
Today I desoldered the 28 pin headers from another 3.2 board and I will report later on what happened. provides helpful step-by-steps.

My Teensy LC had been working while connected to the PC. I shut down properly and removed the Teensy. Plugged it into a USB power brick expecting it to run. It did not.

So, I tried the reset by holding down the program button, connecting to power and waiting for a count of 15. I also swapped USB cables and tried other devices, cables were good, power was good. Teensy LC still unresponsive.

A multimeter showed me that on-board 5v and 3.3v were good. Shorting the program pin to ground had no more effect than holding the program button, no reset.

Reconnecting to the computer I had Teensy Loader 1.51 open with the verbose info screen open and demo program blink_fast_TeensyLC.hex loaded and ready to go. Windows Device Manager was ready, too. Could not see the Teensy.

So, I gathered all the micro-USB cables I had used together and started swapping the cables. Windows started beeping, Device Manager started jumping, and the Teensy Loader Verbose Info panel started scrolling. The built in LED began to flash.

Long story. My problem was running code froze up device. Then a bad cable went undetected.
I have Teensy 3.6. USB cable and pushing code were working then suddenly it stops. USB cables don't work, The led is not blinking, when I check with multimeter 3.3V and GND pins have between ~0.15 - 1.5 V and Vin pin is around 5.2V. Does it mean my Teensy is dead? :(
Does it mean my Teensy is dead? :(
Not necessarily. It sounds more like the onboard 3V3 regulator is overloaded.
Can you see any metal/solder pieces on the board that don't belong there and that could cause a short on the 3V3 line? I'm assuming you have not connected any other electronic circuitry to the T3.6.

Does the regulator get hot? (the part in the red circle)


Not necessarily. It sounds more like the onboard 3V3 regulator is overloaded.
Can you see any metal/solder pieces on the board that don't belong there and that could cause a short on the 3V3 line? I'm assuming you have not connected any other electronic circuitry to the T3.6.

Does the regulator get hot? (the part in the red circle)

View attachment 27106


Thank you for your answer.

I've connected two stepper motor drivers then I removed all other connections. just teensy 3.6. I've checked the red circle that you marked on Teensy everything seems ok. 15th pin consistently output 1.13V and Vin pin have 5.10V

I feel The regulator is hot, not too much but it is. :confused:
Hmm, doesn't sound encouraging.
With the bare Teensy not connected to power or USB, can you measure the resistance between pin 3V3 and GND?

That seems to be on the low side - I expected a higher value for an unpowered board.
Unfortunately I don't have a T3.6 here, but I measured on a T4.1: ~11K5 between 3V3 and GND.
Perhaps someone else on the forum who has a T3.6 can check that?