MacOS 10.15 Catalina

Everything worked as expected on my MacBook running macOS 10.15.1 (19B88).

With WiFi turned off,

  • App downloaded from Internet
Capture d’écran 2019-12-07 à 14.31.58.png

  • Access to files from the Documents folder
Capture d’écran 2019-12-07 à 14.32.08.png

  • Not sure about this dialogue box
Capture d’écran 2019-12-07 à 14.32.16.png

When turning WiFi on,

  • Allow network connection
Capture d’écran 2019-12-07 à 14.36.06.png

Well done!
Works great so far!
I don't have a touch bar though.
MacBook Pro (15 inch Mid 2015)
16GB Memory
Sorry, missed this thread and just installed the 1.49 beta #1 yesterday.
For any help I might provide should I install the version at #43 above or wait for 1.49 beta#2 or ? Will betas be code signed in the future?

It sounds like congratulations are in order from the comments above. I don't think I have any other open source code signed apps. Once you figure it out (which as you found is a major nightmare) it doesn't seem to cause too much difficulty. I have been code signing my apps running on IOS and OS X for a few years now but never distributed or sold, just used on my families and friends machines. With this method if I forget to update my credentials in a timely fashion (yearly) all the apps automatically quit running ! Great for letting iffy friends use my apps!
Sorry, missed this thread and just installed the 1.49 beta #1 yesterday.
For any help I might provide should I install the version at #43 above or wait for 1.49 beta#2 or ? Will betas be code signed in the future?

Definitely use 1.49-beta1 from msg #43.

Unless any Mac-specific problems turn up or Arduino makes a non-beta release, all remaining work planned for 1.49 is for the code running on Teensy. The Macintosh stuff will remain this same, including code signing, hardened runtime, and Apple notarization. For the foreseeable future, we'll offer 2 downloads for Macintosh... the traditional installer for 10.7 to 10.14, and this all-in-one package for 10.15 and later.
Installed the 1.49-beta1 from msg #43 and was a little confused.

2013 iMac with Catalina 10.15.1

1. When I ran the TeensyDuino App it overwrote the Arduino App in my application folder (with no questions asked) that I had renamed to Arduino_1_8_10 so I could still go back to it. This was with TeensyDuino still in the downloads folder.
2. Didn't realize the TeensyDuino icon is now the whole app. Ok.
3. The TeensyDuino App is called Arduino in the process manager, TeensyDuino on the icon and Arduino1.8.10 on the top pane of the Arduino window.
4. The version of the Arduino_1_8_10 mentioned above does not run. It doesn't crash, just quits like the gatekeeper is quitting it. I know its been replaced because I had some custom board files in it.
5. Seems even more unusual now that quitting the main app leave the TeensyDuino still running.

Still messing with actual programming on T4, T3.6 and T3.2 with no problems so far.
After removing the existing Arduino app I performed the Catalina upgrade and then installed TeensyDuino from the Msg 43 link. Absolutely no issues with programming T3.6 & T4 so many thanks to Paul Stoffregen. If only I had such a brain.....
Definitely use 1.49-beta1 from msg #43.

Unless any Mac-specific ...
For the foreseeable future, we'll offer 2 downloads for Macintosh... the traditional installer for 10.7 to 10.14, and this all-in-one package for 10.15 and later.

I was a little surprised (and thankful) that I was able to modify the boards.txt file in the app and gatekeeper didn't seem to mind. I even transferred the modified app to a mac mini running 10.13.6 and it ran fine. Tried to run it on a 2007 MacBook with 10.7.5 but got the message it had to be 10.8 or above.
Tried to run it on a 2007 MacBook with 10.7.5 but got the message it had to be 10.8 or above.

Maybe try editing Contents/Info.plist. Look for these lines:


Arduino 1.8.5 definitely does work on 10.7. It has an older Java runtime.

Normally 1.8.6 and later can't run on MacOSX 10.7. But maybe this Catalina one can? To meet the Apple's newer SDK notarization requirement, I replaced the Oracle JRE with a freshly compiled OpenJDK one....

I was a little surprised (and thankful) that I was able to modify the boards.txt file in the app and gatekeeper didn't seem to mind.

Supposedly Catalina will re-check it occasionally. How often, I have no idea.
Tried the LSMinimumSystemVersion key and no go, same message. I already have 1.8.5 and TL 1.44 running on it, was just curious why your not recommending this code signed version for 10.8+ to save yourself some effort supporting two versions on mac.

edit. Think I can answer my own question. This way you can use 1.8.5 with a newer Teensyduino installer for T4+ on older 10.7.5-- macs
Just to say that I do have a touch bar macbook pro (which I hate). I rarely use the touch bar, and when I do it's with Better Touch Tool.
All the info I've found so far is sandbox is meant for programs distributed by Apple's app store and hardened runtime is intended for programs distributed outside the Apple app store.

My (perhaps bad) attitude is to do only what's necessary for passing Apple's notarization process and giving Mac users with Catalina a good experience. I've already poured nearly 1 week of dev time into Catalina support. I will do more if necessary. But if there's an optional MacOS feature that would be nice, but isn't absolutely necessary at this time, I'm going to ignore it and put my limited dev time into things like the missing USB types, porting libs, and adding new features that benefit everyone.
FWIW, we are currently using these 5 hardened runtime entitlements on the JRE and top-level bundle, because they're required for Java 8:

We're also using this 1 entitlement on all the command line utils, because the gcc toolchain needs it. The linker appears to load plugins by mmap(), which hardened runtime blocks unless this entitlement is used.

Some of the command line utils probably don't need this. Maybe in the distant future I'll figure out which ones truly need it, but for now the simplest thing was to just sign all the command line stuff the same way. But perhaps a future version of the toolchain will switch from mmap() to something more MacOS specific that will avoid the need for this entitlement?

Again, my focus is only to get everything working smoothly on Catalina. Extra dev time beyond the minimum MacOS requirements is going into improving the USB code and libs.
I downloaded the beta, installed it on Catalina. Works like a charm (and solves a problem I had with Serial.available() ). I have a Mac with the touch bar, although I am not using it much with Arduino. Everything I tried concerning the touch bar worked as expected.
Not working on a clean Catalina install:

View attachment 18448

Assuming everything else is working OK, I would wipe what you've got and download again from the Msg43 link. MacOS error code 47 is so vague as to tell you nothing, but since you know from reports here that the app does indeed install successfully under Catalina I would be fairly confident.
@Arbutus - Can I talk you into trying 1.49-beta5?

Unless any serious bugs turn up, I'm planning to release 1.49 within the next few days.

Also in just a few weeks, Apple will tighten their notarization requirements, but previous notarized programs are supposed to keep running. So we're rapidly approaching the final opportunity for a properly notarized copy of Teensyduino using Arduino 1.8.10. After Feb 3, Apple's notarization service will reject 1.8.10 because 6 minor command line utils where built with an Apple SDK older than 10.9.... which is mostly a leftover from efforts that we've all been trying to keep Mac compatibility for users back to Lion 10.7 or Mountain Lion 10.8. Apple made some major change at 10.9 and wants all software built against nothing older than 10.9... and we're all forced to now (or in ~3 weeks) comply.

Arduino is working towards a notarized 1.8.11, mostly using the stuff I sent them while working on Teensyduino. So if there is some obscure Catalina problem here, it will very likely impact Arduino too, since they've done the same things I did (minus the extra parts for Teensy of course). I'm not hopeful I can do much with only that numerical error code, but I'd sure like to get to the bottom of any bug that could potentially affect many Mac users. Maybe download the Arduino 1.8.11-prerelease1 and see if it works or gives the same error on your Mac?
@Arbutus - Can I talk you into trying 1.49-beta5?

I removed all references to Arduino / Teensyduino from a Catalina 10.15.2 i7 iMac system.

A)) i7 iMac with Catalina 10.15.2 and a previous version of Arduino/Teensyduino:
Downloaded 1.49-beta-5 and installed with <ctrl>Open on a Mac which had a previous Arduino installation.
The prior install was removed before running 1.49-Beta-5
Installation was immediate and did not trigger any OS X warnings or actions.

B)) MacBook Pro with a new installation of Catalina 10.15.2 no prior Arduino/Teensyduino installation

Downloaded 1.49-beta-5 and installed by double clicking the 1.49-beta-5.dmg
This Mac had no prior Arduino/Teensyduino installed.
Install by single clicking the downloaded .dmg file
Installation did not trigger any OS X warnings or actions.

C)) Both scenarios

Open the installer and this unzips into the /Downloads folder <-- it should be located in the /Applications folder
when started from the /Applications folder works correctly

All good!

Minor request - could you change the process name to reflect Teensyduino instead of Arduino?
I'm running OSX Catalina 10.15.3 since yesterday and i've updated my Arduin IDE to 1.8.12 and i can't get my Teensy 4.0 to work.
I can remember i struggled a lot with getting it setup on Catalina before but now i'm quite lost on what to do to be honest.

I tried installing Teensyduino (Macintosh OS Software (10.10 - 10.15)) from it shows me the boot screen and after it says `starting` it just kills it.

Anyone else running into similar issues?
If it is any help im running am early 2015 13" MacBook Pro with a Core i5 processor.
Nothing special is supposed to be needed. Just download the 1.51 copy for MacOS 10.10-10.15 and run it.

It's a complete copy of Arduino and Teensyduino, so you do *not* download something from Arduino's website. All the other copies (older Macs and Windows & Linux) are installers which requires a copy of Arduino. But the new one for Catalina is a complete copy of Arduino with Teensyduino. Starting with Catalina, Apple no longer allows this sort of installer approach for one program to add its files to another. So we were forced to make the new Mac version as 1 huge download with everything, rather than a smaller installer which adds to a copy of Arduino.

Just download that 1 file and run it.

As a quick sanity check, I downloaded another copy just now, onto my Macbook Air with 10.15.3. The first time to run it, there is a slow "verifying" step, then you will see this message. Click Open.


Arduino takes a while to start, especially if you have a slower Mac or non-SSD hard drive. Once it does start, you should see this:

(click for full size)

As you can see in this screenshot, it definitely does run on MacOS 10.15.3.
Starting with Teensyduino 1.51, you can tell the difference between a regular copy of Arduino and the copy with Teensyduino by the name shown on the left of the menu bar.


If it says "Arduino", you're running the original copy of Arduino's website. The copy of Arduino with Teensyduino which works on Catalina says "Teensyduino" in the menu bar.
I see all the messages and windows like you posted except for the Arduino IDE window. I even see the Teensyduino name popup in the control bar but after the boot screen of the app it exists and kills it.
I do see the following line in the system.log in Console:

Code:[1] (cc.arduino.Arduino.teensyduino.10556[5743]): Service exited with abnormal code: 255

After a Google search i found this post ( in the Arduino forum and that seems to be the same issue and when i try to open it using the following command in the Terminal


it does actually open and i can continue working on my project.
Any idea what the issue could be?
Any idea what the issue could be?

Nope, no idea. It definitely does not do that when I run it here on 10.15.3.

Any chance it might be simply a corrupted copy? If you download the zip file (don't automatically extract) and run "md5", the correct result is 293c1012da9e13c60668e8a763db3b18. Maybe download a fresh copy, check the md5 hash, then extra and run. Maybe that will help?