micro-ROS+ Teensy gcc error

Jhiggy

New member
Hi Paul!

I'm working on the common robotics platform for the PARTS club here in Portland. Currently, I'm trying to integrate a Teensy 4.0 with micro-ROS and ROS2 Humble.

I could not get micro-ROS to compile at all on a Teensy 4.0 and Teensyduo 1.58.1 or 1.58.0. It looks to be throwing some sort of gcc error for 11.3.1 and the guys at micro-ROS thought maybe it was because my PC had gcc 11.4 on it.

When I switched to Teensyduo 1.57.2, applied the platform.txt patch, it started working.

I tested on both Ubuntu 22.04 and Windows 10 with the same result. Tested on both Arduino IDE 1 and Arduino IDE 2 on both OSs.

I'm not a super strong programmer- so a lot of this is over my head- but I'm happy to do the leg work for anything that might help you help me fix this =)

Here is the issue on the micro-ROS github: https://github.com/micro-ROS/micro_ros_arduino/issues/1634


Is this something you'd be able to help us with please?

-Jeff H
 
Still hoping to get some help with this pretty please! I'd like to be able to use the latest version of your arduino board and simplify our install instructions. =)
 
Just guessing, but you might try the latest 1.59 beta 5. Some tools-related issues that occurred in 1.58 that have been fixed in 1.59.
 
Back
Top