Need help for a CS42448 nightmare serial-breakdowns [SOLVED]


Active member
Hi everybody,
I'm not really happy since 3 of my CS42448 boards from aliexpress had a "failed to config CS42448",and don't give no sound all
at the 4 outputs,unless a small humming sound.
Checked the I2c and it's was ok with one ADS115 found,i tried also a sine-generator on each outputs,but i heard
only a humming sound.
This happened along 2 days time,all was working before,i was using a teensy 4.1 with a ra8875 and a ext sdcard
and suddenly no more sound.
I understand a cs42448 chip is fragile but maybe a simple trick can get it to work again.
Any thoughts to debug?

CS42448 board


  • cs42448 board.jpg
    cs42448 board.jpg
    45.2 KB · Views: 17
Hello Paul,
All my breakdowns did not come with those pcb,it is with a prototype on the fly wiring,also the new pcb
i made needs a little correction,but is not involved at all.
I want to be sure why it was not safe before i use the last new cs42448 that i took from ali express.
I think you have a great knowledge with cs42448,maybe there is a trick to do.
There is one cs42448 left and working,so if you have some ideas...:rolleyes:
Problem solved,all the cs42448 boards work now allright,
it was because the wiring was getting not so well tighten with the time,i made a solid rock connector upon the cs42448,
cold sweat away :giggle: