New Arduino Eclipse Plugin V2.2 and Arduino Eclipse IDE

Status
Not open for further replies.
I've upgraded to:
Arduino 1.0.6
Teensyduino 1.20
Eclipse Arduino Plugin V2.4

This required an update to the boards.txt file
The new boards.txt file is attached.
 

Attachments

  • boards.txt
    22 KB · Views: 211
Are you running Eclipse on Linux?
My current setup is an iMac 27" mid 2010 with OSX Yosemite 10.10.1.
When I wrote the instructions for the installation last year I tested all of it successfully on a Win Vista and Ubuntu installation. Both of these run in a virtual machine on my Mac.
I have not yet tried if these work in Linux or Windows 7 but there is very good reason to believe that this works on Linux as well as Jantje the main Developer develops the plugin exclusively on Linux.
 
Last edited:
My current setup is an iMac 27" mid 2010 with OSX Yosamite 10.10.1.
When I wrote the instructions for the installation last year I tested all of it successfully on a Win Vista and Ubuntu installation. Both of these run in a virtual machine on my Mac.
I have not yet tried if these work in Linux or Windows 7 but there is very good reason to believe that this works on Linux as well as Jantje the main Developer develops the plugin exclusively on Linux.

My setup uses Arduino 1.5.8 – somehow I made it work :)

I have to point to Teensy's hardware folder in Eclipse, and Teensy-specific libraries (in the global settings).

But I am able to blissfully compile and upload sketches all from inside Eclipse Luna, 64bit, using 2.4 version of the plugin, and Arduino 1.5.8. This is also on Mac OS-X Yosemite, and also on iMac :)

K
 
I've tried to install Eclipse and I get an error that my JVM is not recent enough (i.e. 1.6.x vs. the 1.7 that's required). Curiously, I just updated my Java to the latest build and thought that would take care of the issue, but no such luck. Is the JVM a separate download? FWIW, I'm running Yosemite.
 
Hi Headroom and thanks for the quick reply.

Ok, so I noodled my way through getting the older version of Java uninstalled and the new version downloaded and enabled. FWIW, it would be helpful to mention in your instructions that the JDK version of Java is required, not just the 'regular' Java download (this may be obvious to you, it wasn't to me).

Now the JRE is at version 1.8.x but the 32bit version of Eclipse still won't launch.
Screen Shot 2014-12-26 at 9.24.20 AM.png

Eclipse 64bit does launch but it won't find the plugin as described in step 7 of the installation instructions.
Screen Shot 2014-12-26 at 9.58.11 AM.png

I later found the Arduino-bundled version of Eclipse and that didn't work either. It wouldn't accept Arduino 1.5.8 as valid and 1.05 was rejected on the basis that this was v2.3 of the plugin.
Screen Shot 2014-12-26 at 11.43.30 AM.png

This has been a somewhat frustrating experience! :D

I think I'm going back to BBEdit and the Arduino IDE. Devil you know, and all that.
 
Last edited:
Eclipse Arduino + Teensy 3.1 - Large Hex Files

Wow -- first off props to Headroom, and all the others that have worked hard to build up Arudino Eclipse IDE. I've been tired of the Arduino IDE for a bit and am eager to get Eclipse running.

After following Headroom's installation instructions, I managed to get everything tweaked up, etc, and can now compile and load code onto my Teensy 3.1. In fact, it feels faster than loading code through the Arduino IDE. Nice so far.

Where I get stuck is in the discussion of compiler optimizations. All the tutorials out there talk about this, but in the newer version of the IDE, I cannot figure out where to enter the settings. I've tried several places, and in the end it makes no difference.

Why am I looking at this? Well, for the simple "blink" example, the compiled hex file for the teensy 3.1 is 42k!!!! Whoa, bucky, that's a big hex file for a few lines of blink code.

When I compile the same file for an Arduino Uno target, it drops to 3k.

What am I missing? Hints welcome.......guidance.......whatever. I feel like I'm so close to being able to code for the Teensy3.1 within Eclipse.....

Thank you!
 
Supposedly if one uses Freescale's KDS it comes with a ready to go Eclipse and GCC ARM and Processor Expert just install without the frustrations of the bare naked Eclipse DIY.
Supposedly.

I'm considering KDS. Not being Windows-shy, I have been using free Visual Studio [community edition] + VisualMicro for Arduino lib usage, and also cheap VisualGDB targeting ARM M4s using CMSIS/HAL. Also using IAR for my pro work.


Teensy large size. There are posts on how to tweak the Teensy 3 builds to allow the linker to omit unused object files. By default it doesn't.
The 3K size you see probably omits all the USB driver code.
The C++ startup code with support for class constructors adds space too versus a bare naked C only blinky with simple startup.
 
Last edited:
Thank you very much for the feedback!
As stevech has already pointed out there is USB code that would not be needed on the UNO. Of course the Teensy 3.1 in a 32 MCU vs. 8bit on the UNO, which also accounts for some code space.

I am not one of the Developers of the Arduino Eclipse IDE, but I did write the instructions. If you like the Arduino Eclipse plugin/IDE, please go to the website and make a small donation. Do not assume that there must be enough funding because many others donate. I've had a number of conversations with Jantje, the main developer and the sad reality is that there are almost no donations.

But back to the original topic, Optimisations.
I believe that is also possible with the Arduino Eclipse Plugin, however, I have never run out of space so at the moment I am at a loss of how that would work. If you cannot do this through the Plugin then perhaps it is possible by editing the board.txt file. My instructions provide two links under the section " other resources" you could ask the question there. jantje and the other developers are usually very quick to answer.
 
8 vs. 32 bit.
I have a large C++ app that builds to 22KB on the AVR 9 bit with Atmel Studio 6.2 but 1/3 less in size compiled with IAR for an ARM M4. I look at the ASM code and the ARM code's optimizer and assembler uses a lot of clever techniques, like the ARM's IT (if then) instruction. The AVR code (from GCC) is kind of brute force and has a lot more load/store going on. (this code uses stdint.h declarations and uint16_t when possible, and never just int, except locally in for() loops)

Who has installed Freescale's KDS? It's supposed to have Eclipse built-in so no fuzzy instructions on Eclipse-alone are needed. I've used Eclipse as embedded in the overall tool from Digi International, and it, as I hope happens for KDS, just installed along with all the rest. I also tried the CooCox IDE which embeds Eclipse. It just ran. But CooCox itself is no bueno.
 
Last edited:
Hi guys,

i am new to this board. Fount it, while searching for a solution to use eclipse...
Can one of you point out, which guide is the most recent ?
I would like to use Eclipse for developing Teensy 3.1 programs.


Thanks in advance,

Christian
 
I struggled with Eclipse for Teensy on Win 7 for some time. Gave up. It's a career, not a tool
I had used Eclipse for Python development - and I didn't like Eclipse - too esoteric.
Then I moved to what I consider the best IDE I've used - though it's Microsoft's.
New Free Visual Studio 2013 COMMUNITY edition plus the free VisualMicro plug-in for Teensy/AVR.
 
Hi stevech,

i tried Visual Micro. The installation was very smooth and easy.
But unfortunately, there is no Auto Completition / Intellisense ? Or do i missed something to enable it ?
 
A limited number of users struggle with The Eclipse Plugin but many ar quite happy with it, based on feedback.

I am sure Visual Micro offers many nice features as stevech certainly knows his stuff but perhaps keep we should keep Visual Mircro questions to a visual micro thread.
 
Hi stevech,

i tried Visual Micro. The installation was very smooth and easy.
But unfortunately, there is no Auto Completition / Intellisense ? Or do i missed something to enable it ?

It works in mine by default. It's a major appeal of that IDE. As is "go to where defined" and related. Best of breed.
Did you use Atmel Studio 6 (VS 2010) or MS Visual Studio 2013 community (free), or an older licensed VS, with Visual Micro?
check the VisualMicro user forum or ask Tim, the guru. He's very helpful.
 
Last edited:
Clarify paths in Eclipse?

My setup uses Arduino 1.5.8 – somehow I made it work :)

I have to point to Teensy's hardware folder in Eclipse, and Teensy-specific libraries (in the global settings).

But I am able to blissfully compile and upload sketches all from inside Eclipse Luna, 64bit, using 2.4 version of the plugin, and Arduino 1.5.8. This is also on Mac OS-X Yosemite, and also on iMac :)

K

This makes sense--but would you share your path settings? My configuration is slightly different but I only had the instructions here to go on.
 
I haven't used Eclipse with Teensy in a long time.
Since I don't oppose using Windows 7, I use the new Free Visual Studio Community product + free Visual Micro plugin. (no Atmel ties).
I prefer it hands-down, to Eclipse.
 
Last edited:
I see Jante has released a new version (3.0) and it looks better than the previous one, which I gave up on.
One thing I cannot figure out is how to tell it about teensy boards. There are two options:
1) give it the URL of a json file that supplies the definitions
2) put something into ~/Arduino/hardware

I have not found a json file location for a teensy 3, there is one listed for teensy 2 at https://github.com/arduino/Arduino/wiki/Unofficial-list-of-3rd-party-boards-support-urls
The stuff that goes into ~/Arduino/hardware is probably something like what is in my arduino directory under hardware but the various combinations I tried did not work.

There's another similar Eclipse plugin around now too: https://marketplace.eclipse.org/content/arduino-c-ide
But that also needs a json file to tell it about teensy.
I was able to use ATTiny and ESP8266 and they worked well, so I am keen to try it out on my teensy projects.
 
Status
Not open for further replies.
Back
Top