Problem installing teensyduino on Ubuntu 18.04.1 LTS

Not open for further replies.

Roger Parkinson

Active member
It was running just fine even after the Linux upgrade but I was messing about with my libraries and screwed up something, thought it best to just install the latest Arduino and latest Teensydunino.
Ardunio loaded just fine, so I downloaded the teensy file, unzipped and ran the teensy file that comes with it.
It returns immediately, no errors, nothing. I saw somewhere that 18.04 might not have been tried yet with teensyduino but that was when 18.04 was just out and it isn't so new now.
I checked I downloaded the correct file and I've done this a dozen times in the past so I'm probably not doing it wrong (though that's always possible).
Any ideas?

Probably not relevant but this is Xubuntu rather than Ubuntu, different UI layer, which has always worked just fine in the past.
Unzipped? The Linux Teensyduino installers are executables, not zipped.

I believe
sudo apt install libexpat1 libfontconfig1 libfreetype6 libgcc1 libpng12-0 libstdc++6 libx11-6 libxau6 libxcb1 libxdmcp6 libxft2 libxrender1 zlib1g
will install all necessary packages for Teensyduino 1.44 on Debian, Ubuntu, and Mint. However, I checked the libraries and packages on 16.04.4 LTS, so I am not 100% certain.
Kubuntu 18.04 LTLS

I restored some backups and went back to 1.8.3 which is working fine.
But thanks for the responses, guys.

anyone ever figure this out? I'm having issues with 18.04, won't install.

seems like it has no idea what to do with the install download file.
can't get Teensy to work since I installed Ubuntu 18.04, some time ago.
Compilation (Blink) works but download fails.
lsusb gives
Bus 001 Device 031: ID 16c0:0478 Van Ooijen Technische Informatica Teensy Halfkay Bootloader
dmesg gives
[ 6102.873221] usb 1-1: USB disconnect, device number 30
[ 6103.373305] usb 1-1: new full-speed USB device number 31 using xhci_hcd
[ 6103.522183] usb 1-1: New USB device found, idVendor=16c0, idProduct=0478
[ 6103.522185] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=1
[ 6103.522186] usb 1-1: SerialNumber: 00056929
[ 6103.523297] hid-generic 0003:16C0:0478.000E: hidraw1: USB HID v1.11 Device [HID 16c0:0478] on usb-0000:00:14.0-1/input0

I have another one where lsusb only gives
Bus 001 Device 032: ID 1b4f:9206
and dmesg gives
[ 6511.783079] usb 1-1: USB disconnect, device number 31
[ 6519.796034] usb 1-1: new full-speed USB device number 32 using xhci_hcd
[ 6519.947622] usb 1-1: New USB device found, idVendor=1b4f, idProduct=9206
[ 6519.947628] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6519.947633] usb 1-1: Product: SparkFun Pro Micro
[ 6519.947637] usb 1-1: Manufacturer: SparkFun
[ 6519.948560] cdc_acm 1-1:1.0: ttyACM0: USB ACM device
This one gives
No Teensy boards were found on any USB ports of your computer.
despite a picture of the teensy appearing on the task bar.
Thanks manitou. That worked. In fact my 49-teensy.rules had got itself renamed to 49-teensy.rules.txt in the changeover from 16.10 to 18.04.
So the rules file effectively did not exist.
Not open for further replies.