Snooze.h not working with Arduino 1.8.11 and Teensyduino 1.50

Not open for further replies.


New member
I spent the past few hours trying to troubleshoot the Snooze library and was unable to even run the example codes for the Snooze library on a Teensy 3.6, with Arduino 1.8.11 and Teensyduino 1.50. None of the examples worked when tested on two separate Teensy 3.6s, and instead both would enter the sleep state but never wake to any of the triggers (RTC, alarm, or digital).

I then reverted back to Arduino 1.8.10 and Teensyduino 1.48 and the Snooze examples all worked as expected, as well as all the projects I had been working on. Reinstalling Arduino 1.8.11 and Teensyduino 1.50 caused the Snooze library examples to fail again. There is no mention of Snooze in the Arduino or Teensyduino change logs/release notes, so I can only guess some dependency got effected. As such, I was wondering if anyone has encountered a similar issue. My OS is Windows 10 Pro.

I should also mention I tried multiple different clock speeds and compiler optimizations, but still was unable to get Arduino 1.8.11 and Teensyduino 1.50 to run Snooze properly.
I posted it as an issue to the Github account (#74). However, before investigating deeper I was first curious if it is just something odd about my particular setup, or if other people are able to reproduce this issue.
I'm hoping to have an update today on my GitHub. The changes are to make Snooze's main class decoupled from the underlying HAL for each Teensy chip. This broke a lot of things so I had to rewrite a lot of how things for Snooze to work again, this is why it has taken so long.
No worries, and I am very grateful you are still actively maintaining this library. Looking forward to the update!
Not open for further replies.