Soft reboot is not implemented for Win32


New member
Hello everyone.
I'm trying to upload a complied sketch to my Teensy 4.1 board using CLI without pressing the button.
I'm working on a standalone Windows computer with no internet access and I had trouble compiling the CLI so I've downloaded an already complied teensy_loader_cli.exe I found here on the forum.
When I type: "teensy_loader_cli --mcu=TEENSY41 -s skecth.hex" I get the error: Soft reboot is not implemented for Win32.

The funny thing is that I'm almost sure I was able to execute this command once and it worked.

Any ideas? Thank you!
Grab the teensy_reboot.exe program from an Arduino IDE install.
@Paul, I grabbed it and placed it in the same folder, still doesn't work.
In addition, I tried to call it before and after the upload command "teensy_loader_cli --mcu=TEENSY41 -s skecth.hex" and I get the error:
"Unable to find Teensy Loader. (r) Is the Teensy Loader application running? Is a firewall (eg, ZoneAlarm) blocking localhost communication?"
teensy_reboot.exe only works when I manually open the Teensy Loader but I still need to push the button so I didn't achieve anything.

Am I missing something? tnx!
Did you actually run teensy_reboot.exe?

Simply having the file in the same folder does nothing. You have to run it to cause Teensy to go into bootloader mode. Then run the CLI loader and if your Teensy did successfully reboot, it should find the device automatically.

FWIW, this is more-or-less what Arduino IDE does. Arduino runs a teensy_post_compile utility which tells the GUI loader about the new HEX file and puts it into auto mode, and then it runs teensy_reboot. When the reboot happens, auto mode causes the Teensy Loader to program the HEX file.