Teensy 2.0 appears unresponsive; tried posted troubleshooting steps


New member

I purchased a Teensy 2.0 some time ago. I went through a couple of the tutorials and then got distracted by something else and shelved the Teensy.

I pulled it out the other day and it appears to not be accepting any code.

I'm using Arduino 1.0.6 with Teensyduino 1.2.

Originally I was using Windows 8, but in following the troublshooting tips I moved to a Mac with Mavericks.

The code that was left on it from the last time I used it should have been controlling an LED on the breadboard, but the Teensy did nothing when powered. I tried reloading the sample Blink program and nothing happens.

Power is definitely going to the Teensy; I can light the external LED by positioning wires on the breadboard.

Is there something else I can try? Could the Teensy be dead?

So I found the problem. It was the USB cable. That was one thing I had not tried because I did not have a spare mini-USB. Everything is micro now.