Teensy 3.2 with FastLED library doesn't work

marilux

New member
Hi,
I use a Teensy 3.2 with a WS2812B LED ring.
In my Arduino code, I use the FastLed library to drive this ring of LEDs. I need to use this library because I'm pairing this assembly with an LD06 lidar. When the lidar detects an object at a certain distance, the LEDs on the side of the object will light up in a certain colour.

I first tested an example of the FastLed library : blink. It uploaded the code to my teensy but nothing worked on my LED ring...
Then I tested an example of the NeoPixel library : blink. It uploaded the code to my teensy and it worked ! Then I continued coding with this library but after a while, the lidar data started to bug, given that the data retrieved by my lidar goes much faster than the LED display. That's why I have to use the FastLed library.

So, I'm back to the Blink example code from the FastLed library, trying to figure out why it won't work with my Teensy 3.2.

Does anyone have any information about the compatibility of the FastLed library with a Teensy 3.2 ?
 

Attachments

  • Blink.ino
    3.7 KB · Views: 19
What version of TeensyDuino is in use?

IIRC: Another recent poster found 1.58 to work when the new 1.59 did not on a T_3.2.
 
Can confirm the observation by @marilux.
Tested a few combinations:
Teensyduino 1.59.0Teensyduino 1.58.2
FastLED 3.6Not workingOK
FastLED 3.5Not workingOK
FastLED 3.4Not workingOK

Using Windows 10, Arduino IDE 2.3.2, Teensy 3.2, Adafruit Neopixel-12 ring.
Also using the same File > Examples > FastLED > Blink.
FastLED 3.4 is part of the Teensyduino 1.58.2 & 1.59.0 package.

Paul
 
Back
Top