Teensy 3.6 no longer programs

Not open for further replies.
Okay never mind, after a few more attempts of the reset->upload cycle, the 3.6 no longer is recognized though USB (on two computers, various cables).

Something must be damaged. I'll have to replace it.

After several months of use, my Teensy 3.6 no longer responds to uploads from Teensyduino. It has uploaded code on it that continues to work but I cannot upload anything else. I simply get the 'Teensy did not respond to a USB-based request to enter program mode.' continually. Using the pushbutton to manual program does not work - Teensy loader software doesn't respond.

I've read through the existing advice but nothing seems to work for me:

- The device is genuine, it was ordered directly from PJRC
- The computer recognizes the Teensy and its existing uploaded code - it was programmed to be in keyboard mode and will type the keystrokes sequences on it.
- The USB cable has data lines and is brand new.
- The program pin reads 3V and properly drops to 0 when pushed
- it is using Arduino 1.8.9 and Teensyduino 1.46
- I also installed the software on a second computer and it exhibits the same behavior.

Any help would be appreciated.

I had this problem recently, TeensyDuino kept telling me it could not compile for Teensy 3.6. couple of suggestions;

1. delete arduino 1.89 and reextract zip file, then re-install teensduino. That fixed the issue once or twice.
2. If the step above doesn't work, bypass arduino and try using installing the blink program straight from teensy loader.
3. Another screwup i found i'd done. If you open teensyloader, the one downloaded from prjc, before arduino, this is an older version. You need to start teensyduino and let it autatically open the correct teensloader (1.46).

i thought i'd killed my unit too, but after re-programming from teensyloader (1.42), i was able to get arduino to recognize it.
I've done a few reinstalls, but gave it another shot. Same deal. Can't program directly from teensy loader since the button doesn't seem to respond other than reseting the connection.

I'm back to the point where the computer recognizes the Teensy. The HelloSerialMonitor example is stuck on it.
But the button doesn't do the 15 second reset (the sketch remains on the board) nor does the teensy software recognize it's going into program mode. Very confused.
Just my two cents: A new Teensy 3.6 costs 30$. Your working hour costs, let’s assume and include all secondary costs, 100$. I’m sure that you and all the helpful people here in the forum have spent more than 20 minutes trying to reanimate this damn piece of hardware, so trashing it and buying a new one would have been cheaper and quicker...
Perhaps the Teensy 3.6 has been damaged in some way where one or more of the pins (BGA balls) is just barely touching the board? At least a couple other people have reported such a problem, where a damaged board would work when pressing down on 1 of the corners of the chip. Maybe 1 or more essential signals between the chips is sometimes touching, giving you a working board, but other times disconnecting?

A similarly bad or intermittent connection at the USB connector, or in your USB cable, could also explain all the symptoms you've described.
Paul, I think you figured it out.

It now uploads consistently when I press down on the chip. Mystery solved.
Thanks for your help.

I'll replace it eventually but not knowing what was going on was a bad itch i needed to scratch haha.
That was the issue with my problem unit - that's where I was going with the 'firm Button press' - it flexes the board enough to restore connectivity.
Paul - your downgrade instructions were spot on. No problems encountered. However, the Teensy 3.2 pinned board is still not interacting with X-Plane 11.3 as intended. Here are the symptoms:

1. Teensy 3.2 board has been working fine with X-Plane 11 for a couple of years now.
2. Recently, X-Plane stopped responding to inputs from the Teensy board
3. Teensy board will accept programming
4. Built-in Blink sketch runs fine on Teensy board
5. Built-in Blink Transponder sketch does not work
6. Enabled "Show Communication" in the X-Plane plug-in manager for the Teensy plugin. The communication window recognizes when the Teensy board is either plugged in or is unplugged, but there is no further interaction, i.e., exchange of commands or datarefs, when buttons are pushed or encoders turned.
7. The Arduino Serial Monitor works fine and shows programmed Line Print commands when pushing the buttons or encoders on the board
8. I changed USB cables without success.
9. The Teensy processor does not get hot when plugged into the USB

It would seem to me that there may be some type of communication error with the board. Do you think I should try swapping out a new board to see if that fixes the problem? That, as opposed to trying to figure out if there are any loose/broken solder joints on the board?
Paul - the problem turned out to be the USB hub. It is a 7-port hub and my guess is that with all the plugs being used, there was not enough power going to the Teensy board for effective communications with X-Plane. One I plugged the Teensy into a separate port on its own, it worked fine. Now I'm putting the sim back together and hopefully will be flying this afternoon.

Thanks for all your help and input.
Not open for further replies.