Teensy 4.0 not programming


Active member
I just got my 4.0 and tried firing it up. I mounted it in a breadboard and connected USB to my laptop, as in Tutorial #1.
The Teensy powered up and the canned blinking Orange LED worked. I then tried compiling and running the demo BLINK routine.
It would not program and gave an error msg .... "Failed uploading: no upload port provided"

I had already selected 4.0 on the pulldown menu before trying to compile.

I may be doing some wrong. Any ideas? Thx.
Last edited:
Go down to "PORT" on the menu and select one.
I did that already. I selected Teensy 4.0.

I think it's just not detecting the board. I've tried unplugging plugging in the cable a few times. I've also restarted Arduino IDE.
I am using IDE 2.3.2

It's a long shot but I will try swapping the cable.
Last edited:
Got it working. I had to go through 6 cables to find one that worked.
After that it still ran funny. I just tested by modifying the canned BLINK program.
Anyway, with the new cable in place I would press the manual button on the T4.0 and then run compile/upload.
It would then still present the error message. This time the Teensy Loader window would come up and allow me to program and Reboot manually.
Does not follow what the Tutorial says. Oh well. I will get used to it.
I will play some more with it before I feel I can trust it.
Does not follow what the Tutorial says

Sounds like something isn't quite right on your PC. Impossible to guess with so little info. Can't even tell if you have MacOS, Linux or Windows.

Hopefully you'll be able to use the serial monitor, which is covered in the 3rd tutorial. Ability to print to the serial monitor is critically important.
WIN10, Both Board and Port have been set.
I've used this PC (Lenovo laptop) to program the Teensy 2.0 in the past with no issues.
I may try going back to an earlier version of IDE and see if that is any different.