Teensy 4.0 Red Light is Blinking And Not Working


Hello everyone,

I know you have answered these questions before. But I guess my problem is a little different than others. I have Teensy 4.0. When I first plugged the Teensy to the computer, I did not encounter any problems and I did my programming with the Arduino IDE for a long time.

I touched the Teensy today with the Teensy plugged into the computer and powered on. Then Teensy really started babbling. When trying to communicate via COM port, sometimes the serial monitor worked, sometimes it didn't. In the last case, the COM port has become completely inoperable.

After this problem, I took a multimeter and made measurements. The 3.3V and 5V outputs work smoothly.

After doing research, I thought it might be related to cables and tested it with 3 cables. I had the same problem on all of them and I couldn't get Teensy to work. However, the first cable I tried was able to transfer data and electricity very well.

Currently, the red light on the Teensy is flashing at regular intervals. If I leave it like that for a long time, that light goes out completely. But it still doesn't read COM port. Regarding this I tried pressing the reset button for 15 seconds. I also pressed it once. It did not respond to the reset in any way either.

I wanted to summarize the situation better by making a video. Below you can find the video explaining the situation. I really need your help. Thank you for your interest.

I believe this is the blink code you are experiencing. 2 blinks, 0.6 seconds apart, 2 second pause. Which is "NXP JTAG Not Responding". It is possible there is an issue with the GD32 bootloader chip (small chip next to red led) which is not allowing it to communicate with the IMXRT chip, this could cause some of the issues you are describing.

I notice a dark line next to the GD32, is there a trace burned up in between the chip and the led?
Good eye Spencez - saw that too and wondered what was there. Other soldering looks nice on pins - not seeing any other odd splatter showing. But if it was working after soldering before then that shouldn't be trouble.

The Button is not 'reset' but "Program".

It seemed Button was being pressed and held? ... and the 2 blink pattern continued? Normal behavior is holding the Button should take the RED LED to DARK until the 13-17 second window to release and do the Factory Restore.
Last edited:
Thank you all so very much for your help. I used a solder paste when soldering the headers to the Teensy. But after I was done, I couldn't clean the solder paste because I didn't have alcohol on hand. Today I cleaned the place Spencez said nicely with alcohol and I was able to run programs without any problems.

I never thought it could be from solder paste. I thought it was a non-conductive material. If so, I can't understand why the board didn't work before I cleaned the solder paste.

Anyway. Endless thanks to all of you. I was very upset that I couldn't use Teensy. I wish you all good work.
No, I'm having the problem again. But I was able to use Teensy a few times today. That is, when you just insert "Serial.println("Hello World");" If I add a very simple code that says it works. But when I try with a module like Lora E32, it does not automatically reboot from the computer. I have to press the button on it.

If I install a simple and non-functional program, I can reboot the computer as many times as I want and there is no red light on Teensy. Everything is going pretty well.

But today, after experiencing these problems, everything is back to the way it was. Again, the red light above it flashes periodically. And the "program" key does not work at all. I cleaned the top of the card well and that black thing you mentioned is gone. And I thoroughly checked the area where that black area is. I didn't see any problem.

Could this be a problem when programming Teensy? Or is there really a problem with the cable? I tried two cables. I found that they both have a 5 pin connection. But the result is negative. Still the red leds are blinking.
The blink code you displayed in the video is showing a problem with the bootloader chip, it means it can not communicate with the main Teensy chip. You will not be able to program the Teensy over USB, or use the button to put it in programming mode if this is the case. I don't believe the USB cable would be the issue, if the USB data lines were not working I believe you would get 1 blink (not 2) every few seconds.

If it was actually solder paste, there are little beads of solder in the paste which are conductive. Do you mean that or flux? Maybe you had some of it on your finger when you touched the Teensy?

Are you able to show your wiring and code to rule that out? Or does this issue still occur even when the Teensy is not connected to anything?
I disconnected all Teensy's connections. So no other component is connected. The Teensy is only connected to the computer via USB. And now that red light is blinking 4 times. When I researched this I found that there was a problem with the crystal oscillator or the "PTB5" pin.

If the problem is with the crystal oscillator, is it possible to change it on the board? I'm really confused.




This is the part where the crystal oscillator is;

Last edited:
Try cleaning the area around the crystals with 99% isopropyl alcohol. Cleaning the whole board might also be a good idea, if the solder paste you used left a thin layer of conductive residue (many solder pastes have organic acid flux which is meant to be washed away by a special cleaning process).

Desoldering and replacing the crystal or nearby parts is not a good plan. It can be done with great care, but without the very best equipment and a lot of skill, odds of permanent damage to the board are quite high.

With soldering that leaves a conductive residue, while annoying, the good news is those solders are designed to have a way to clean off the residue. You just need the right chemical. Some are designed to come off with just hot water washing. Of course, fully drying the board is also needed before you apply power. PCB manufacturing which uses water wash usually as a low temperature oven to forcibly dry away all the leftover water.

With isopropyl alcohol, it fully dries naturally. The 99% stuff drys in under a minute. If you have diluted, like 70%, it can take hours to fully dry. Use 99% isopropyl alcohol if you can.
Last edited:
Because of my insufficient experience in this field, I made exactly the mistake you said. Unfortunately, the isoproyl alcohol I bought to clean the solder paste after the process was not 99% pure. That's why some liquid has accumulated under the processor.

I took the Teensy to an electronics repair shop today. Then he told me that there was liquid coming out from under the processor. We plugged the Teensy into the computer right after the drying process was complete and it worked really well.

I had the same situation with my MPU6050. But I dried the MPU6050 with a hair dryer I have at home. A little liquid came out from under it.

As a result, I realized that I needed to dry the board after soldering and after cleaning with alcohol. Many thanks to everyone for their help.
Glad you are working again!

Got 91% isopropyl here - and after cleaning ... hairdryer there is used to help evaporate that and push out any fluid trapped under SD socket or other. Bake it in hand to the temp I can stand and flip it over a time or two and not failed [even with impatience {not suggested} of plugging it in minutes later].
Last edited: