Teensy 4.0 Serial monitor with USB RawHID?


The USB Type of RAWHID,

generates two interfaces:


the Serial emulator (SEREMU), and the Teensy Serial monitor knows how to talk to SEREMU as well as TyCommander
Hmm.. I tried that but still don't see anything in the Serial Monitor. The title of the window says "TeensyMonitor: Closed".
I still have not figured out how to get the TeensyMonitor to work with RAWHID and the serial emulator.

My connection on the bottom of the Arduino window says:
Teensy 4.0, Raw HID, 600 MHz, Faster, US English on fake serial

When I open the Serial Monitor the top of the window says:
TeensyMonitor: Closed

Is there something I need to add to my program to get it to work?

Again Hard to know what exactly what is going on, with your setup.
I am running Windows 10 Arduino 1.8.19 Teensyduino 57 beta 3...

But I just loaded the basic example under USB type rawhid, and configured for RAWHID Teensy 4
And I ran the EXE for demo RAWHID from: https://www.pjrc.com/teensy/rawhid.html
After the program uploaded, I made sure that I had the proper Serial port selected...

Note: I also needed to make sure I was not running TyCommander at the time as it might have connected up to the port.

As it it too knows how to talk SEREMU...
Weird... I just can't get it to work.

I did download the TyCommander repo and built it for my Linux machine. It does see both the RadHID and Seremu interfaces:


But I get nothing in the Serial output:


I did make sure that the Serial interface is started in my program:

void setup() {

And I do have a number of messages being sent to the Serial interface:

    TSPoint p = getRotatedPoint();
    if (ts.isTouching()) {
        Serial.print("T: ");
        Serial.print(" Z: ");

But nothing is ever received.

Maybe an issue with Arduino 1.8.13 and Teensyduino 1.53?
Some Hints: Linux... Which? Something like Ubuntu? Which version?
And you are running 1.8.13 and 1.53...

Maybe time to boot up my Ubuntu 22.04 setup.
Again it appears to work on my Ubuntu 22.04 machine.
Screenshot from 2022-06-23 17-57-20.png

Note, I am running TyCommander here 0.9.0-107...
Which I built from current sources

Edit oops, the picture before was without focus...
Screenshot from 2022-06-23 18-16-36.png
I finally got it to work. Not sure what fixed it or what I was doing wrong before but now it works.

Thanks for putting up with my confusion.

Now I can try to figure out why I sometimes get odd touch results with the Teensy 4.0 board.

The TouchScreen library works fine with the Teensy 3.2 But with the Teensy 4.0 I occasionally get garbage results when I hold my finger on the touchscreen.