Teensy 4.1 w/ Zephyr, VSCode, and PlatformIO HOWTO?


Hi all,

I have been trying for multiple days now to get up and running with VSCode, Zephyr, and my recently delivered Teensy 4.1, but I've not been able to even get to "Hello, World!" Does anyone have any recommended links for getting up and running with this combo? I've got 20+ years of software engineering experience (with a lot of embedded stuff in there, including Teensy 3.0), but just nothing I try seems to work. Has anyone spelled this out step-by-step? I've found pages that say that PlatformIO doesn't support Zephyr, but their own docs say they do. Is this hopeless? Anyone doing this?

Edit to add: I did solder on the USB Host pins before booting it for the first time, since that's a primary feature for me. I don't think anything went awry, and this ain't my first rodeo, but...

Lots of people on here use PlatformIO, but I've never seen a step-by-step procedure or how-to guide for using it. I had not heard of Zephyr, but I looked at their site, and they build with Cmake/Ninja. Have you tried that?

I did find the thread below, which seems to imply that the OP has Zephyr up and running on a T4. If you get it to work, it would be great if you would write up how you did it.

The PlatformIO Zephyr support supposedly wraps/hides the whole Cmake/Ninja part of it from you (which, frankly, having suffered in the Cmake/Ninja mines before, is pretty much a pre-requisite to me.)

The conclusion I'm coming to is that Zephyr is still a pretty niche stack, and that I should probably just prototype using the Arduino stack and determine later if I actually need the RTOS stack. Part of my snarky comment above is that I would rather spend time getting stuff done than fighting with a complex build system. There have been weeks and weeks of my professional life spent fighting with Cmake that I can never get back, so the prospect of spending more time trying to figure this out for a hobby project isn't exactly appealing.

If I happen to get it working at some point, I'll report back.
So, I think I found at least part of the problem: The microUSB jack on my Teensy appears to be flaky. I have to kinda wiggle it around just so to get it to power up at all. I guess I'll look into that next.

Edit: Well I'll be! I tried a different cable and it worked much more reliably. It's weird because the original cable I was using has worked great for other applications for years.
Last edited:
So, I switched to using the Arduino stack on PlatformIO, and I can't say it's been a breeze, but at least I got it to work. The Arduino IDE is such hot garbage that I'll deal with PlatformIO's difficulties, but man oh man could this have been easier.