Teensyduino158 and Arduino 202


Well-known member
Just loaded Arduino 2.0.2. I thought I then needed to download Teensyduino and run it, but not the same file structure as older ver. ...??
I am running on Windows 11 desktop PC.
I then followed the guidance to paste the packages link to File > Preferences and install teensy board support. I then installed the Teensy packages.
Teensyduino still not the file structure to allow me to install as I would on older version.
Then tried the blink example and teensyduino was already installed and worked. So is this the shape of things to come, Just add the file to File > Preferences and all teensy support is installed no need for the Teensyduino exe file. The versions I got are teensy 158 and arduino 2.0.2.
Just would like confirmed I am using correct procedure...??.

Thanks for reply. Hadn't seen the blog I was using the notes in the Teensyduino 1.57 released posted here at top of the forum. on my PC when I read the link for the packages the packages/teensy bit of the line reads pa.......nsy. So when I copied and pasted the first time I didn.t notice the dots so it didn't work until I pasted in the full line......
I can see the structure is different than before. I can see libraries in the library manager but cannot go to the files. If I click on more finf it takes me to the github web etc. so is all going to be web based will it work offline. Also I used the windows Zip file to keep it seperate, I also have 1.8.19 and teensy 1.57 on PC as portable folder.??
I was just trying with the blink example, eg I included #include Audio.h at the top and then uploaded to teensy 3.2, I had no audio statements just to see would it find audio.h and compile. It did compile and uploaded to teensy and blink worked.
With the audio.h included I got an error on the first time compile ...... but then compile and upload again no error...... This also happens with my 1.8.19 teensy 1.57 setup. but prog all works. The error is.....something about "flushlen" ???? I cannot get it now while I am typing post, will check out and post again later.
The other thing is the use of portable folder. I have portable folder created and sketch book within it but all the library files are in a folder on C:/user/appdata.....etc.....etc. How can I tell Arduino to use the portable folder instead. I want all installed on my D: to keep my C: as free as possible it is small compared with my D drive..?
PS.... I have found the library files now hovering over the #include shows up the full path....it shows them in app data
Yes, the Forum inserting the '...' on auto converting URL's is problematic for quick copies.

The Blog post has good detail Paul wrote up. It could use some cross linking - but between the build up to getting IDE 2 released and working and all the other hardware updates and exchanges for part swaps and other goings on it isn't perfect yet :)

As far as the structure it is basically similarly just some alternate subdirectories it seems. On Windows going to: %appdata%\..\local\Arduino15\packages\teensy\hardware\avr will show the current install 'VER#' directory with CORES and Libraries and the board and platform '.txt' files. The Tools is up from there in '..\teensy\tools'

To use the PORTABLE folder - Have seen that work with IDE 1.8.x ... not sure of the steps for having IDE 2 see and use that. It does have to exist before the IDE is opened. In the IDE 2.0 Coming Thread there was some use of that, and notes left IIRC.

<< seeing crosspost - IDE 2 not fully supporting Portable >>
Thanks for the replies and pointing me to investigate more.......
I think it nearly all works......sort of portable...
I edited the arduino-cli.yaml file to change the paths to D drive....I didnt need to create the empty folders on D drive..
I then run the Arduino202.exe in my unzipped folder and Arduino created the new AppData and library folders on D drive as given on the new path names.
I then deleted the old Arduino15 folder in C:\users\etc\etc...
All seems to be working. I disconnected the internet and the only thing I noticed was it told me I was offline and also failed to do update check, but my simple sketch compiled and uploaded.

Arduino Libs CtoD.jpg