Forum Rule: Always post complete source code & details to reproduce any issue!
Tab Content
  • mjs513's Avatar
    Today, 05:46 PM
    Ok Tony. All is well and right with the world. BTW here are the settings I am using T3.5 at 168Mhz, T3.2 at 120Mhz SPI_SPD 24000000 (your right 30 does not want to work for some reason, probably what we...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Today, 05:22 PM
    ok. now I am frustrated. Using the same settings as you posted for the 3.5 and 3.2 and using the same cpu speed still not working right. Going to redo the wiring and if that doesn't work going to solder up another...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Today, 04:26 PM
    Hi tony. Just got back in. Thanks for checking - didn't think about reducing the SPI. Last time I had to increase it. Oh boy. I will give it a try and play around some more. Love your setup in the video. :)
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Today, 01:10 PM
    Sorry - yeah yeah, beat you go back to the 3.6/3.5 combo :). My guess is that if I am not having an issue with the 3.5's Tim won't have any with the 3.6/3.6. Just based on past comments. BTW just got a Teensy LC...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Today, 12:53 PM
    Guess I am the trouble maker. At least I made some progress. Anyway, its just interesting that the 3.5/3.2 combo is such an issue with the new updates. I thought we had it working with the GitHub version. I will...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Today, 11:48 AM
    Thanks for your help Tony. To be honest, I forgot about the delay in the .h file. Its been awhile since I played with it. Think I had it 1 originally when I was playing with the 3.2. I will give it a try. Mike...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Today, 12:31 AM
    Ok. Got the 3.2 to respond at least. But heres the deal: I get a response but slave fires once for It gets to close to 1 for 1. I tested at 2500 but loop as to be on the order of 1 sec. Don't know if the...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 10:41 PM
    Going to reinstall after diner and try again.. Maybe I screwed something up .. but I remember I zipped the old files and then copied and pasted - hope I opened the right zip though.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 09:59 PM
    Just not working. Tried 300, 500, 800 and 100 on the master at 168 and the slave at 120. Same thing keeps happening. I also tried different combos of CPU speed on the master and slave, same thing. EDIT> Need a...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 09:29 PM
    No didn't change the events just used what you had for settings - will update and let you know. Stay tuned.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 09:08 PM
    Here is a new update for you. Decided to let it sit for about 10-15 minutes and finally got some data over to the slave: 0.00, #, #, #, #, #, #, #, #, #, #, #,1,0
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 09:04 PM
    I agree, avoids having to play around with timing - just defaults to the minimum. - regardless of the config issues I am having with the 3.5/3.2 combo.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 09:02 PM
    on the t3.5/T3.2 combo - master on T3.5 at 168 and slave on T3.2 at 120 - nothing: all I got on the master was: C:\Users\CyberPalin\Documents\Arduino\tontons_i2c_master\tontons_i2c_master.ino Apr 19 2018 16:32:24 SUM:...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 08:15 PM
    I think its a problem with the T3.5/T3.2 combo again, or I have a bad T3.5 or T3.2. On the t3.5/3.5 combo able to transfer no problem as demonstrated by the uNav sketch which it could do before. I am going to load up...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 08:10 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Tim - my post was just trying to document the delta's I incorporated between version 4 and 6. I agree that using a constant dt (depending on SRD) is the way to go. I don't think the changes made to detect misses would...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    Yesterday, 06:19 PM
    Just tested the SPI2wayCom examples on GitHub and something strange happened. The test was between a T3.5 and T3.2. When both online would not get any transfers but if I unplugged the master and replugged it back in I...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 04:44 PM
    Nice tonton81. Looks like you got a performance improvement as well. Will give it a shot in a little while. In the middle of something else right now :) Told you, you were a wizard :) EDIT: Success. I loaded...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 02:01 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Tim. Yep experienced gimbal lock before but I don't think this is the same behavior. Gimbal lock usually occurs at the crossover points, for instance pitch around 90degrees. But as Onehorse put it, gimbal lock...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    Yesterday, 01:05 AM
    Remember - no good deed goes unpunished. Looks like you may have licked the problem with MST again :)
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    Yesterday, 01:03 AM
    mjs513 replied to a thread uNav INS in General Discussion
    Don, Yep - qw is usually 1 to start with., or q0 in Brian's filter. "What filter are you running for your plots above? One of the AHRS variants" - version 6 of your filter. Using the library calibration from your...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    Yesterday, 12:18 AM
    mjs513 replied to a thread uNav INS in General Discussion
    Don - Tim Just did a test displaying the quaternions as well as the YPR values. While I said the YPR values were strange so are the quaternions during and after movement. Before I pitched I rotated to about 0...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 11:31 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Tim. You are right - with out movement GPS is no good for heading. If its moving you can actually read it from the COG variable in the PVT message. But it VelN, VelE, VelD are used while stationary you are going to...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 10:19 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Don If you want the files I will zip them up and post the link. Since I am a hobbyist I got matlab for free - imagine that. Just don't get the extras :) By the way did some more testing and here are a couple...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 09:35 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Don Its written in Python but I converted it a windows executable file. But there is a matlab equivalent once you have the accel and mag data files if you are interested. Still have play around with it some more...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 08:50 PM
    Geez - just got back on the computer - wow missed a lot again. Well guess you found out bools are not atomic :) Should have checked sooner but nothing came through on the emails. BTW: Didn't we talk about atomic...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-18-2018, 08:41 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi all. Decided to try an old approach for accel and magnetometer that is reminiscent of what is done for the propshield. I am attaching two images - you might say accel and mag data before calibration and one after...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 01:54 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Oops - look like our messages past in the night :)
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 01:53 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Don, My last post was on eeprom save was how you would do it for static cals. For the library version, after calibration of accel and mag is complete you just have to hit "l". Then the eeprom is updated. By...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 01:27 PM
    Tony. Don't worry about it, no rush. This is what testing is suppose to do - identify problem areas that need to be tweaked. Part of the process. SPI_MSTransfer got more and more complicated as you started adding...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-18-2018, 01:09 PM
    Not a problem. Don't mind testing. Just to let you that I got uNav working with the old library working again - it was something with the new calibration methodology that Don put together. Test1: no events in...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-18-2018, 12:50 PM
    Tony, tried that already but that version is causing me problems as well. Remember I am also setting sSer3 to serial3 to pass arguments back to the master. But based on your examples not using sSer3 events in the...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-18-2018, 11:15 AM
    mjs513 replied to a thread uNav INS in General Discussion
    Morning Don, Haven't tried v2 yet but I will this morning. Just wanted to let you know think I found the problem with the eeprom save. You have to save it to the IMU library first then save it to the eeprom. The...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-18-2018, 10:47 AM
    Morning Tony, Understand. Just wanted to let you know about the issue and kind of confirm that the problem is with events. So I was going to revert to the GitHub version for now. Didn't mean to sound upset. Was...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-18-2018, 12:40 AM
    Hi tonton81. Something has to be going on with events and the master. I just tried your https://forum.pjrc.com/attachment.php?attachmentid=13608&d=1523978355 with the uNav sketches and it failed miserably. Master...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 11:21 PM
    mjs513 replied to a thread uNav INS in General Discussion
    A little off between runs of 'r'. Here is a copy of the data runs: axb Sigma (m/ss): 0.009827 ayb Sigma (m/ss): 0.007082 azb Sigma (m/ss): 0.013256 gxb Sigma (deg/s): 0.000703 gyb Sigma (deg/s): 0.000409 gzb...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-17-2018, 10:49 PM
    mjs513 replied to a thread uNav INS in General Discussion
    I tried that method as well with the same results. Can you do me one favor. After your last step if you do a "d" again you should be getting back the values that were stored, correct. That is where the problem I have...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-17-2018, 10:32 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Don Just tried your calibration routine. A lot to like but having a problem. Doesn't want to save calibrations to eeprom or the imu it seems. Here is what I get after running all calibrations on accel, mag and...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-17-2018, 09:16 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Thanks for posting Don. Will have to give it a try. Probably later tonight. Looks real interesting. Mike
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-17-2018, 07:50 PM
    Just to let you know in case you missed I had uncommented that line.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 06:17 PM
    Sorry I am giving you so many headaches but .... at least you are finding the issues before going live with the changes.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 05:51 PM
    Just as a point of info its the same sketch I ran on the 2 T3.5s except for the change from Wire1 to Wire. So I am really lost. events(0)? EDIT-UPDATE: Just to be contrary I loaded up the SPI2WayComm example...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 05:17 PM
    As for code its the same as posted in post #1302. Except I remembered to uncomment the events()? Remember that one from the previous time I forgot it :) I give just the F&F examples a shot. Didn't think about...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 04:43 PM
    I just tested the new library with the t3.5 (Master) and T3.2 (slave) combination. I didn't test it with the T3.5/3.5 combo yet before you ask. With the 3.5/3.2 combo I running into an interesting situation but before...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 01:42 PM
    Nice one Tony. Going to try it out next on the T3.5/T3.2 Combo. Know it works on the T3.5/T3.5 combo. In the mean time going to reload the uNav sketches and do a double check. Sure it will work as it doesn't only...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 01:17 PM
    Morning tonton81 :) Any other than I can't figure out why its not converting uint8's to chars it working like a charm. onDetect method is working. When I unplug the slave and replug in the slave it comes right up -...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 02:27 AM
    Get some rest - have it running now the T3.5s. Only thing is the prints: Size: 24 Slave: 15 Port: 1 Gibberish is printed Enjoy your nap - think I am done for the night
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-17-2018, 12:49 AM
    Took a quick look at the blog post and the scala files. Looks like it is based on a java jwave library. I just found this that may help: http://wavelet2d.sourceforge.net/ . If you search on c++ discrete wavelet...
    4 replies | 239 view(s)
  • mjs513's Avatar
    04-17-2018, 12:32 AM
    I did manage to finally get it working on 2 T3.5s using Wire1 but was like pulling teeth. Had to remove threads and its still intermittent on startup. Sometimes it would even hang. Now aren't you glad, or not, that I...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 10:43 PM
    I got something weird going on between the 3.5 and 3.2 combo. For the hell of it I just tried this: http://www.instructables.com/id/I2C-between-Arduinos/ just as test. No I didn't use pullups. Again 3.5 was master...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 10:39 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Tim "TeensyThreads could help - but only if it is on a separate i2c bus?" Yep - that was what I was thinking. There aren't many 9250 breakout boards out there that have a pressure sensor on board. Don Nice...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-16-2018, 08:17 PM
    mjs513 replied to a thread uNav INS in General Discussion
    You won't see it in the debug - the delay is enum in the MS5637 library.
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-16-2018, 07:55 PM
    Ok Tony all debugging finished, I know my I2C lines work, tested with a MS5637 and a I2CScanner. Loaded your new version of SPI transfer and using single read bytes. 1. Tried your simplified sketch but didn't...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 05:48 PM
    Cool on the LC's will eventually have to pick a couple up. Anyway was still in the process of doing debugging - turns out two things - the 3.2 breakout board I put together yesterday I missed some solder joints. ...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 05:03 PM
    Thanks - think I may have found the problem but no guarantee. Have more debugging to do - going to test it on my old reliable setup up that I have been using except I am going to change to wire1 since wire is tied up.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 03:51 PM
    Yep "W0.onReceive(hello); " in wrapped in your onDetect test.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 03:42 PM
    Ok.. slave.events is there and I just uncommented the line out in the master for teens_gpio.events. Hoping that was it - have to check sda/scl now. Oh boy, nothing ever works out of the box for me :) but on the other...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 03:28 PM
    Got it. Oh, one more question, where does i2c address 0x22, come in? Reason why I am asking is that I am not getting anything from i2c and trying do some bebugging :) and SPI transfer is awfully slow?
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 03:07 PM
    yeah I forgot. So I would do: { Threads::Scope scope(MST_QUEUE); Wire.beginTransmission(0x22); Wire.write(text, sizeof(text)); Wire.write(text1, sizeof(text1)); Wire.sendTransmission(); } and...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 01:17 PM
    Had to ask. I recognized the test sketch and wanted to reduce it to its basic form - easier to understand and not get confused. Yeah I noticed how it mimics the library. Going to give it a try today and let you...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 12:54 PM
    Hi Tony. Had to stop last night after I posted was trying to do something but making too many mistakes so I just packed it in. Started going through the sketch and removing most of the commented out lines (just for my...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-16-2018, 11:53 AM
    mjs513 replied to a thread uNav INS in General Discussion
    Tim - know I put a lot into the last message. But I did trace what was causing the doubles - it was the MS5637 pressure sensor causing the problem. Depending on the OSR selected there is a built-in delay (per...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 11:56 PM
    Hey Tony - that one is easy to test. You just fixed the one thing that would always drive me crazy Mike
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-15-2018, 11:54 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Don Just double checked and you are absolutely right. I just fixed in my version of the 9250. Interesting to see your new cal sketch. Mike
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 08:35 PM
    mjs513 replied to a thread uNav INS in General Discussion
    MS5637 pressure sensor update: 1. No osr level works at 200hz. 2. At 100hz the max OSR that you can use without double hits is OSR_1024. Mike
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 08:27 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Here's what I am getting on startup: Accel Biases and Scale Factors: 0.000000, 1.000000 4.872069, 0.998839 -0.431508, 1.002156 Mag Biases and Scale Factors: 12.615913, 0.995010 3.826580, 0.970366...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 08:08 PM
    mjs513 replied to a thread uNav INS in General Discussion
    UPDATE: Without the Baro at max OSR I can run the IMU at 200 hz without a double. Going to play around with the OSR to see where it impacts
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 08:03 PM
    I'll give it a try after I play around with uNAVIns a little more. There are a couple of test cases I want to go through on that. I still want to get back and figure out to best use the SPI_MSTransfer with the other...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-15-2018, 08:01 PM
    mjs513 replied to a thread uNav INS in General Discussion
    No I haven't. Don't think its a NVIC issue. Baro's are notorious for taking time to get an stable accurate reading. You have to use a high over sampling rate but that comes with a large delay in getting a reading. I...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 07:49 PM
    Nice Tony. You are giving me more work to do. Already spent the day soldering up some new toys. :)
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-15-2018, 07:46 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Now back to the program. I do something similar to "parameter " when updating the baro sea level pressure. Basically, all I do is in the case block for the command I do Serial.parseInt() and then you can test on the...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 07:43 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Tim The T3.5 is running at 168Mhz as well as the slave. I just changed to 100Hz updates for the IMU and still getting doubles, here is a sample: ---Lp#:21771 IMU#:70 > 1S:100030800 > IMUcc:683196 >> Mcnt:64 >>...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 09:21 AM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Tim, By the way when I said I was running at 100hz I was wrong. Somewhere along the line I must have changed it. The problem I was seeing was because I was running at 500hz :). Changed it to 200hz and running as...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-15-2018, 12:18 AM
    mjs513 replied to a thread uNav INS in General Discussion
    Will give it a try later. I am only running at an SRD of 9. By the way are you printing odt.average() or just odt?
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-14-2018, 11:33 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Tim - by choppy dt, from more of observational quality than measurement, is that as the data streams to the Tviewer it periodically stops streaming smoothly, like a longer time between samples, than at other times. ...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-14-2018, 09:32 PM
    Great - I thought so but I had to ask - too many changes too fast :)
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-14-2018, 09:30 PM
    Cool, just as I was beginning to figure out what we are doing now for I2C and Serial :) Maybe I am just confusing my self here. So with the SPI support you added I can run everything on the master side and just...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-14-2018, 09:18 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi Tim, Loaded up your code, yes I used code compare. Still missed one thing on first go :) Anyway here are my observations, not sure if you see the same things: 1. Yaw is a more stable that it was before, now...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-14-2018, 09:08 PM
    Not a problem tonton81. Am I assuming something like w0.setCLK(XXXXXXXXX) is supported? Also I used i2c_t3 in the i2c library example that I posted. Just used the defaults for that :)
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-14-2018, 05:30 PM
    your too much tonton81. Will eventually have to give it a try.
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-14-2018, 05:29 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Thanks Tim. I will check it out. Have a few things to do on the house while the weather is nice today. To be honest don't know. Never tried. I know you can 'extern' variables. Maybe try putting extern...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-14-2018, 01:15 PM
    Will have to eventually give it a try :)
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-14-2018, 12:57 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Tim - your probably right. For now I put it back mostly and will wait for the new version to make sure everything is covered. MIke
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-14-2018, 04:11 AM
    mjs513 replied to a thread uNav INS in General Discussion
    "MS5611 baro board in today." Have fun with it. I still getting better and more consistent results with it than the GPS altitude - it may be the GPS has to be moving to get a better results. Good luck with the code...
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-14-2018, 04:05 AM
    tonton81 - you just top yourself. Ok. Now for the serious question before I go back to sleep and after I post in the other thread :). 1. spi -> begin in library a good thing since we are already creating it...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-14-2018, 12:49 AM
    mjs513 replied to a thread uNav INS in General Discussion
    Thanks Tim. Put it back to the original while I was testing some SPI changes. Thanks for the dbug. Just wanted to make sure there were no other changes to timing. Mike :)
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-13-2018, 11:37 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hi all With tonton's help I am now able to send commands over serial from the slave to master so if I want to change messages while on the slave I don't have to switch back and forth - works nice. Mike
    599 replies | 12288 view(s)
  • mjs513's Avatar
    04-13-2018, 11:30 PM
    I usually do that - but didn't in this case- user error as usual. :)
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-13-2018, 10:02 PM
    Yep that is exactly whats suppose to happen. Never mind my error - I can't count, was 1 pin off. Dummy. Working fine. Figured this was easier. Guess I should document it a little bit and then post it as another...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-13-2018, 09:35 PM
    SPI begin MUST BE CALLED ok that was kind of dumb on my part. Actually was part of the uNav code but I decided to make an example - easier to test. Completely forgot about the SPI.begin code. ok, I also jumpered...
    1395 replies | 29289 view(s)
  • mjs513's Avatar
    04-13-2018, 08:48 PM
    mjs513 replied to a thread uNav INS in General Discussion
    Hey Don About the only thing I can do is generate a Jar file for java. I use intelijidea and it makes it easy - lots of instructions out there. Don't really have to know Java just how to generate the JAR. Mike
    599 replies | 12288 view(s)
More Activity
About mjs513

Basic Information

About mjs513
Location:
New York
Interests:
Robotics, Image Processing
Occupation:
Aerospace Eng (Retired)

Statistics


Total Posts
Total Posts
1,382
Posts Per Day
0.99
Last Post
Project: SPI_MSTransfer Today 05:46 PM
General Information
Last Activity
Today 06:08 PM
Join Date
07-01-2014