Forum Rule: Always post complete source code & details to reproduce any issue!
Tab Content
  • mjs513's Avatar
    Today, 07:37 PM
    @KurtE Have a question for you - how the heck do you include GFX fonts with your library - couldn't figure that out. Keeps giving me an error on adafruit buttons.... EDIT: Will have to download your master...
    167 replies | 34715 view(s)
  • mjs513's Avatar
    Today, 07:36 PM
    Interesting - when I hooked up my ILI9488 didn't have to do anything with the MISO - have to read your post again on that issue - remember you said you had to cut the MISO trace? The spew comes from the KeyPadLoop...
    167 replies | 34715 view(s)
  • mjs513's Avatar
    Today, 07:30 PM
    @defragster I did it for the wired versions with the values shown in hex - the values in the lib are decimal. To be honest got lazy and was going to clean it when I got it working on the T$ but having problems as...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Today, 05:23 PM
    @defragster Cool you got it working the C64. Did you see my post in the other thread about the speed change? Also, did you see this post:...
    167 replies | 34715 view(s)
  • mjs513's Avatar
    Today, 03:11 PM
    Cool. Amazing how one thing leads to another :) Congratulations, that must have been a lot of worked and headaches to get it going. I hope so too. Think he is real busy about now... I just ordered by Beta...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Today, 03:09 PM
    @KurtE Just for reference I have been using your T4 WIP version for awhile now with the T3.6 and T4 and its working great. I have been playing around with those functions but I am a little handicapped in that I...
    167 replies | 34715 view(s)
  • mjs513's Avatar
    Today, 02:57 PM
    I agree with that it probably should be in the read function to disable the PKE bit. But by that same token, most users won't be automatically setting the PKE bit. I think that when I checked alternate functions...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    Today, 11:21 AM
    @KurtE and @defragster and others In going through this https://github.com/Bodmer/TFT_ILI9341_ESP ILI9341 library there are some interesting functions that might be worth it to add to a ILI9341 library. Would...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Today, 11:03 AM
    @defragster Actually it was originally designed for buttons but he had a modification to allow to be used with a SNES controller. Was thinking at some point to change it to use the joystick :). Think I mentioned...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Today, 01:37 AM
    @KurtE Since we are beginning to digress from Bluetooth to Displays maybe its time to start a new thread on the changes to ILI9341 library?
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Today, 12:55 AM
    @KurtE Progress is still progress. I found another ILI9341 library that has a ton of examples that look like a lot of fun. A couple work out of the box. But a couple I have questions on if I may. The sketch...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Yesterday, 10:15 PM
    @Jean-Marc. After reset try loading the blink sketch - you will probably have to press the reset key. It should then find the port. At least that was what worked for me. If not sure.
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    Yesterday, 09:41 PM
    Interesting, could just be something with my T4. Good luck with the making change over, sounds like its going to be a bear.
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Yesterday, 09:28 PM
    @KurtE Ok loaded up the pacman sketch and it ran fine no problem, just way too fast so I went in to make 1 change and T$ hung again - lost usb: Board at usb:0/140000/0/A/7 is not available. Have you tried it, i.e.,...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    Yesterday, 09:04 PM
    Kurt No pride of authorship here :) Community effort will make it better Glad you made the changes and good idea about comment on screen :) Mike
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-23-2019, 11:08 PM
    @KurtE - not sure what happened that it didn't work. Think its on the T4 side though not the USBHost side. Did a bunch of testing just now and reloaded Pacman - not it hung USB> So I think the issue is T4 USB which...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-23-2019, 07:55 PM
    @KurtE In regards to your post 2021 I think I already gave you my opinion. But like you said it all depends on what you are doing: So it would be nice to give the user the option maybe in a single define on the way...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-23-2019, 01:10 PM
    I was just intending on using it as a demo of integrating the controllers via Bluetooth into an application that everyone can load up. That was it - real good app would be a Bluetooth rover which I have done before...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-23-2019, 02:20 AM
    @KurtE and @defragster Tried an experiment with trying to connect multiple BT devices - but doesn't seem to want to work. Maybe something I did wrong - will have to play tomorrow again a little more carefully -...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-23-2019, 01:34 AM
    Evening @KurtE - should have warned you about the change in pins - maybe we should put an define in for different configurations between you, me and @defragster if he was to get into it :) Was fun playing with it -...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 10:20 PM
    Well you can make that 2 confirmed cases - broke it off my T3.5 by dropping on floor with the cable on - and of course it fell cable end first - just plain carelessness . EDIT: Based on the next post - guess I am...
    3 replies | 58 view(s)
  • mjs513's Avatar
    03-22-2019, 06:50 PM
    @defragster and @KurtE First I switch over to the PS3 and it runs a heck of a lot faster - actually too fast to play - need to slow the game down :) But I made the modifications to use a PS3: ATTACMENT DELETED ...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 05:29 PM
    @KurtE Got the new ILI9341 (2.8 in display) tested and it works - yea - finally. Loaded packman and display works and when I hit start it goes into demo mode. Now to start playing with the code to see whats going...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 04:25 PM
    @KurtE I like your approach to modifying ILI9341_t3. Gives the user a lot more flexibility. Assuming you will be combining elements from t3n? Back to the joystick - the funny thing is when I press the buttons...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 02:48 PM
    Morning Kurt Did it both way (1) set dc = 10 and cs=9 with RST=18 (remember I am using the breakout board) on the T$, (2) for second test I just had rst going to 3.3v. Both tests just had the display blinking but...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 10:51 AM
    I loaded up the straight ili9341_t3 lib and same thing. Wonder maybe should try different pin. Anyway just tried it with the T4 - what is a valid DC pin for the T4? I am trying to use the shield so I can use USB2 ...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 01:08 AM
    Yep did that. I am using your t4-wip version and just tried graphictest but that didn't work either - going to download the master and try again UPDATE: @KurtE - loaded the master version. Ran the graphics test...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 12:45 AM
    @KurtE and @defragster Not having much luck with displays I think today. Using the T3.6 and your sketch - it turns black and I connect (using a PS4) and nothing displays just a blank screen - looks like it wants to...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-22-2019, 12:30 AM
    @KurtE That's great news - have to give it a try now - glad I figured out what I did wrong
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-21-2019, 11:48 PM
    @KurtE Ah, have to confess - hooked up the ILI9488 to the T3.6 and it worked out of the box with the connections that in the other thread - no changes. This is the same unit that @defragster has. Now for the...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-21-2019, 11:03 PM
    @KurtE - just woke up :) Thanks for checking that the display works with the T3.6. Has to be something with the one I have. Anyway - yeah you have to use the latest Adafruit ILI9341 and GFX libraries to get it...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-21-2019, 07:02 PM
    @KurtE - failing on both the T3.6 and the T4 and I know I had it working on the T4 beta, which is frustrating :) Can't find my backup display, but have another one coming tomorrow so just in a hold pattern until it...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-21-2019, 04:44 PM
    @KurtE Stuck on the display - can't get the display working anymore. Tried t3n and adafruit no joy. Works fine on the T3.5 though. Maybe I screwed something up with the display. Did test SPI on the T$ by reading...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-21-2019, 01:32 PM
    Looks like an interesting dongle but don't think its available anymore. Check a couple of places too bad.
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-20-2019, 08:18 PM
    I been trying to get the Adafruit ILI9341 lib working with the T4 again and its failing miserably. The first thing is that the adafruit 9341 lib is a very old version and has not been updated to the latest version...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-20-2019, 03:42 PM
    ALL Just had something strange going on with ILI9341_t3 library with the T4. I tried to do a compile and keep getting errors like: F:\arduino-1.8.8-t4\hardware\teensy\avr\libraries\ILI9341_t3/ILI9341_t3.h:314:9:...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-20-2019, 02:27 PM
    @KurtE I been playing around this morning and after your comment on the T4 I managed to get it to compile. If you want a distraction. EDIT: For the connections LED/VCC go to 5v and RST goes to 3.3v?
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-20-2019, 12:59 PM
    @KurtE - yep - you are right deleted too much :). Just couldn't see last night for the life of me. Once I put it back in it compiled and uploaded to the T3.6 no problem. But having another problem I hook up a...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 11:54 PM
    Wow Kurt - you have been busy - maybe we should just make a list instead of continuing to update the table. It is a bit much to keep updating. :) I do have a Wacom tablet - I should give it a try :)
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 11:21 PM
    To be honest Kurt never looked at t3n just t3 :( So I just decided to see if I can kludge it to work with a PS4. Got through all the changes and errors I got (just using SPI.transfer) - which is my kludge to start but...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 09:01 PM
    @KurtE and @defragster and others I started going through the reference pacman sketch for the due. The biggest problem I am seeing, for me is there use of the ili9341_due. It is based on the ILI9341_t3 lib for the...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 07:16 PM
    Yeah - you are right, that table is no fun - but don't think I have anything else to add to it right now. :) As for an example found this for a PS4 type joystick: https://forum.arduino.cc/index.php?topic=375394.0
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 06:18 PM
    @KurtE - @defragster funny you should mention it - was thinking about that last night. But put it on the back burner because trying to make sure we have the basics done first and everything working. Was also...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 04:16 PM
    @KurtE, @defragster Thanks and agreed respectively :) BTW - been busy updating the table in Post #1. Broke it up into two sections - dongles and devices. Figured it might be easier to read.
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 03:33 PM
    Ok messed up the push - meant for it to overwrite what was already there - sorry. Guess for now this is as good as anywhere else until we decided.
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 01:58 PM
    @KurtE When I used the windows sixaxis I did notice that BDADDR was in the reverse order that you had it. The other I noticed for the BT dongle that I was using the SN of the BT dongle contained the BDADDR. Meant to...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-19-2019, 12:26 PM
    @KurtE and @defragster Kurt. Thanks for merging the joystick sketches update. Tim- I incorporated your PS3 pairing comment into the BT sketch :) I added a couple of dongles that I have been using to post#1. Not...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 11:27 PM
    Yep - that's exactly whats needed and we should probably add to the sketch as well
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 06:35 PM
    Your not the only one that forgot - me too :)
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 03:57 PM
    Interesting though I tested the LEDs and it worked in BT mode but not with a wired connection. Guess something to add to the list to check - not sure why rumble doesn't work wired though. I remember testing the...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 03:00 PM
    @KurtE Can you do me a favor. The next time you hook up your PS3 wired can you check rumble and LEDS. Wired those functions don't seem to work. I am not getting any rumble. This is an updated sketch I am using...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 02:39 PM
    Just loaded up the updated library and tested with my BT mouse (keyboard is in garage) and the fixes you put seem to do the trick - mouse is working again.
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 01:19 PM
    As a test I installed the commit prior to @KurtE's XBOX changes: https://github.com/KurtE/USBHost_t36/tree/4e2a27a61c5d604bda67ed9671ac135a7f82bdfe and loaded and the mouse started working. So something in the latest...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 01:06 PM
    @KurtE , @defragster and @milan7 I just tried BT mouse as well with 4 different dongles and couldn't get it to connect. One thing that you have to remember todo is press the connect button on the bottom of the mouse...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 01:39 AM
    @milan7 - suggest you run the KeyboardBT sketch instead of the JoystickBT sketch along with the pairing instructions that @defragster provided.
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-18-2019, 01:34 AM
    @KurtE and @defragster Working through the examples but found a couple of gotchas that I am working on - starting with joystick (wired) version. In so doing I am also making a key map that I am attaching for...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-17-2019, 05:39 PM
    Maybe a wiki or new page in the main area. Think once XBOX one is done then it can all be finalized. Think that is the only open piece of the existing lib. Don't have a XBOX 360 controller to test with so can't be of...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-17-2019, 04:43 PM
    @KurtE You know you bring up a good point with your explanation. The examples that we have are good, especially since we know what they are doing, but maybe we need to do a little reorganizing of the examples, i.e.,...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-17-2019, 01:02 PM
    The basic joystick example in the examples folder should get you started. A lot of stuff but its a start. If you look at the JoystickBT example you can see how we mapped axes to the actual joystick for the PS4. ...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-17-2019, 12:38 PM
    Morning Frank Its pretty much plug and play. Only problem is, you have to eventually do is map the button values to the joystick buttons and the axes values as well - there really is no automatic way to do that. ...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-16-2019, 08:08 PM
    Think I am going to have to get up to speed on bus servos. That swappy rover I was looking at uses 10 LewanSoul LX-16A Serial Bus Servo. Can't find them anywhere so may have to switch.
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-16-2019, 06:54 PM
    Frank, doesn't digikey have a site over there that you can use? May be faster.
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-16-2019, 05:31 PM
    @KurtE You really filled in a lot of the missing pieces. That XBOX controller seems to be a lot different than the PlayStation controllers. Think I read somewhere that XBOX BT is kind of unique to the xbox...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-16-2019, 12:19 PM
    Using @defragsters comments as a base: Same experience as defragsters. On second run of the Arduino IDE no issue with Windows defended "blocking" execution. Only had a T3.5 and T4 hooked up and both showed. ...
    9 replies | 1184 view(s)
  • mjs513's Avatar
    03-16-2019, 11:33 AM
    @KurtE - you might want to check this out - maybe it will give you a few ideas: https://github.com/bluekitchen/btstack/commit/1b9cb13d36fa2f810df618b2851ddf2c9c1ec975 @defragster - I kind of remember your map...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-16-2019, 02:13 AM
    @KurtE and @defragster and others Just as a test I ran 3 tests. The first using a hub and connecting the 2 Logitech joysticks that I have and second using the PS4 in Bluetooth mode using the T$ as the test bed. The...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-15-2019, 11:10 PM
    @KurtE that's a lot of stuff to go through but looks like you are beginning to get a better handle on whats going on. Did a little more poking around and found this article that talks about xbox controller bt on a rpi:...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-15-2019, 05:25 PM
    @Paul When you issue the new 1060 boards are you planning are retaining support for the 1052 board? Was thinking it might be advantageous for debugging to retain until kickstarter, i.e., communications between two...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-15-2019, 02:52 PM
    Sounds like a plan :)
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-15-2019, 01:46 PM
    Hi Tim - just saw this - jumping around too much I guess. Glad I got it working too - was frustrating. I did manage to get tonton81's WIP library working as well on Can2 - haven't tested CAN1 though. Really was only...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-15-2019, 01:40 PM
    @KurtE Was thinking this morning that maybe its time to push the WIP2-bluetooth branch to the master with the caveat that XBOX BT is still an open issue. Think its far enough along that maybe we can might be able to...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-15-2019, 12:43 PM
    :) Well at least it got me off my you know what to finish off the board design. So I guess you are a good distractor.
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-15-2019, 12:07 PM
    @KurtE You and me both for being distracted - I blame Frank for that for asking that question on pin positions - troublemaker. Yeah - not worried about winging it - do it all the time. Just didn't know if there was...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-14-2019, 11:58 PM
    @KurtE Don't know if you noticed or not - I updated the prior post with the HID reports for the throttle joystick I am using.
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-14-2019, 10:15 PM
    Thanks Paul = appreciated - going to take a while for me to finish the layout - am pretty slow :)
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-14-2019, 09:25 PM
    TPS2055A circuit for T4 I pulled the spec but a little unsure of the connections = I put together a crude schematic and was wondering if someone could give me a sanity check before I lay it out in kicad?
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-14-2019, 09:05 PM
    Should have asked earlier - was laying out against my breakout board and things looked shifted against the 1052 layout. Know this is funny but can you tell me the coordinates of the Vin pin - looks like the width is...
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-14-2019, 08:15 PM
    @Paul - know this may sound like a silly question but the dimensions you gave - those are for the current 1052 or the new 1062 board? If 1052 then I messed something up as usual :)
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-14-2019, 07:30 PM
    First check to see if the ADO pin is reading Hi or Low (3.3 or gnd). If it its Hi change: #define ADO 0 to #define ADO 1
    10 replies | 170 view(s)
  • mjs513's Avatar
    03-14-2019, 05:50 PM
    Hang on - before desoldering anything - I ran into that problem before - let me check something.
    10 replies | 170 view(s)
  • mjs513's Avatar
    03-14-2019, 03:18 PM
    Actually this is a brand new joystick - just got it the other day as a test unit for the USBHost_t36 library. What I tested was the throttle unit. Guess it was a good choice. So I never posted the HID dump (actually...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-14-2019, 12:35 PM
    @manitou = what breakout board are you using. You know Adafruit is recommending to:
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-14-2019, 02:28 AM
    Just to confirm should this be USB2 D+, x=72, y=395 D- instead of D+
    2034 replies | 297352 view(s)
  • mjs513's Avatar
    03-14-2019, 02:08 AM
    @KurtE: Ok - uncommented the right dbgprint statement. Think the problem is that the missing data falls under additional axis which is not captured: Joystick: usage=90021, value=0 Mode Switch position S1 UP:...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-14-2019, 01:25 AM
    @KurtE Not a problem - didn't look at the changes you made this time - usually I do but of course not this time. :) BTW I cant seem to get a usage report that shows for the joystick - all I see printed is UP: …...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-13-2019, 09:39 PM
    @KurtE and @defragster and others Just hooked up the throttle unit of the Logitech G Pro Flight X56 Rhino HOTAS which has all kinds of buttons, sliders, hats and switches as a test for the USB. First thing that I...
    111 replies | 2847 view(s)
  • mjs513's Avatar
    03-12-2019, 10:54 PM
    @KurtE and @defragster I just retested with the PS4 and the PS3 with the latest release - just as a double check. All is good - still pairs fine and sketch runs.
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-12-2019, 10:47 PM
    @KurtE and @defragster I downloaded the updated library and gave it a spin for the xbox. If I use pairing I am seeing this: BT rx_data(16): 2f ff 1 e9 a7 db 1b aa 9c 1 0 8 5 0 ff a BT rx_data(16): cb 19 9 58 62...
    472 replies | 7773 view(s)
  • mjs513's Avatar
    03-12-2019, 08:07 PM
    Will keep that all in mind - don't want to fry by 1052 - getting rather attached to it:) The dueling supplies was really my concern - having that trace there on the T3.x was nice to have for designs. Have to...
    2034 replies | 297352 view(s)
More Activity
About mjs513

Basic Information

About mjs513
Location:
New York
Interests:
Robotics, Image Processing
Occupation:
Aerospace Eng (Retired)

Statistics


Total Posts
Total Posts
2,688
Posts Per Day
1.55
Last Post
Playing around with yet another version of ILI9341_t3 library (ILI9341_t3n) Today 07:37 PM
General Information
Last Activity
Today 07:38 PM
Join Date
07-01-2014