Forum Rule: Always post complete source code & details to reproduce any issue!
Tab Content
  • vangalvin's Avatar
    Today, 03:41 AM
    I had all sorts of issues on various projects over the last year that were traced back to the DuPont crimps. My last few projects ended up being shipped to Antarctica for a couple of research teams so to ensure there...
    3 replies | 105 view(s)
  • vangalvin's Avatar
    Today, 03:21 AM
    The initial click when moving the pot is not too much of an issue as once you have the level set it should be nice and stable at that level. setting the pot to get to the desired delay etc will only be done during the...
    4 replies | 60 view(s)
  • vangalvin's Avatar
    Yesterday, 10:46 PM
    I can see many bonuses in doing this on the next project, however for this one I was trying to use what I had in my parts bin. I have not yet played around with encoders but after seeing the i2c alps encoder that is...
    4 replies | 60 view(s)
  • vangalvin's Avatar
    01-17-2019, 11:46 PM
    I have been working on a project for my son who has just moved from an acoustic guitar to electric guitar. The teensy 3.2 seems to be a great platform to build an effects pedal that has all sorts of features. One of the...
    4 replies | 60 view(s)
  • vangalvin's Avatar
    01-16-2019, 08:20 PM
    This has been a huge help thank you, I was having issues with adjusting an audio delay due to the jotter in the pot, this smoothed it out perfectly.
    2 replies | 1023 view(s)
  • vangalvin's Avatar
    01-16-2019, 05:26 AM
    @PaulStoffregen would I have been better off running two SPI's one for the CF and the other for RAM? especially if i am going to be recording and playing audio using the SD and passing it through a delayEXT. am i likely...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-16-2019, 04:37 AM
    FIXED!!!! Well it turns out that there is a fix!!!! and it works a treat. Kind of stunned I managed to do this with my beast soldering iron that has a tip measuring about 2mm in diamiter :) but its still not the most...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-16-2019, 03:02 AM
    Well it would appear that the issue is Hardware and not software. If i pull the MISO link to the CF the sram works. connect the MISO to the CF and it stops working. I have it all running on 3.3V just to be sure there...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-16-2019, 02:35 AM
    The issue seems to be with the MISO connection, it seems as if the Caltex adapter is holding the MISO line at 3.3V when its not in use.
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-16-2019, 01:43 AM
    Yes, that's what I thought. Must be something else going on somewhere possibly in my test code. I have tried the 5V rail and jumpered the regulator so it will run on 3.3V direct. I have altered the test code to...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-16-2019, 12:56 AM
    Neither option seemed to work. The Caltex card is using an LCV125A. I wonder if the regulator could be causing an issue. the version board I have has not way to bypass it with a jumper/pads. I guess i could just...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-16-2019, 12:27 AM
    I have added a pull-up on the SRAM and ended up hard wiring a MicroSD adapter similar to this as well as added the pullup on the CS pin. now the ram is working OK but the CF is not. I will go back to the Caltex...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-15-2019, 10:33 PM
    HA, I think i found the issue.... The Caltex board is a 5V board. Although it is supposed to be 3.3V compliant and have a level converter it looks like if you try and run it with the 23LC1024 on the same SPI lines it...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-15-2019, 09:29 PM
    Still waiting for my audio adapter to arrive, Shipping down to this part of the planet is a little slow so it looks like its still about 3 weeks away. In the interim I have hooked up a Calted SD card adapter and that...
    10 replies | 109 view(s)
  • vangalvin's Avatar
    01-15-2019, 09:16 PM
    vangalvin replied to a thread 23lc1024 in General Discussion
    Thanks for that. I did not realise that it was only limited to the DelayEXT.
    2 replies | 80 view(s)
  • vangalvin's Avatar
    01-13-2019, 10:02 PM
    vangalvin started a thread 23lc1024 in General Discussion
    This may be a silly question. I am waiting for my audio board to turn up. Shipping to NZ this time of year is real slow. In the interim I have been using the teensy 3.2 to create a few effects, its destined to end up...
    2 replies | 80 view(s)
  • vangalvin's Avatar
    01-02-2019, 09:41 PM
    Many Thanks for this solution, I was having similar issues. This sorted the issue out perfectly!
    13 replies | 1743 view(s)
  • vangalvin's Avatar
    12-30-2018, 08:57 PM
    Here is what I ended up with, Its still a work in progress but so far it seems to be working OK. now to add in the control's #include <Audio.h> #include <Wire.h> #include <SPI.h> #include <SD.h> #include...
    5 replies | 141 view(s)
  • vangalvin's Avatar
    12-30-2018, 08:46 PM
    Thanks guys, This is what I ended up doing. https://imgur.com/a/PZD9htb I was not sure if using a single input to multiple effects would cause issues in respect to taking up more processing power as power. If the...
    5 replies | 141 view(s)
  • vangalvin's Avatar
    12-30-2018, 04:36 AM
    I am working on a little project for my son and would like to have multiple effects that can be switched on and off. at any time there will only be one effect between the ADC and the DAC / USB / PWM It looks like...
    5 replies | 141 view(s)
No More Results
About vangalvin

Basic Information

About vangalvin
Location:
New Zealand
Interests:
Collecting, Restoring and Using Vintage/Victorian Electrothreapy Devices

Statistics


Total Posts
Total Posts
21
Posts Per Day
0.02
Last Post
fake dupont/molex pins troubles Today 03:41 AM
General Information
Last Activity
Today 09:02 AM
Join Date
01-04-2016