Forum Rule: Always post complete source code & details to reproduce any issue!
Tab Content
  • wwatson's Avatar
    01-28-2020, 04:00 AM
    wwatson replied to a thread Ra8876 in Project Guidance
    What demo program are you running? Is it one of the RA8876 Lite sketches? Do you have link to the Ra8876 Lite source code you are using? When I bought the ER-TFTM101-1 10.1" from buy display I had problems with the SPI...
    3 replies | 135 view(s)
  • wwatson's Avatar
    01-26-2020, 06:26 PM
    @ALL - Here is something I ran across testing changes to MSC. I noticed that the write speeds of drives are different if using USB hub rather than being directly connected to the T4/3 host port. The write speeds seem...
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-26-2020, 04:11 AM
    Looks like you may have crunched a diode for VBAT or VDD in. There are two diodes one for VBAT and one for VDD (3.3v) from the voltage regulator. Probably steering diodes. Either way if the diode for VDD is inoperative...
    3 replies | 239 view(s)
  • wwatson's Avatar
    01-25-2020, 02:46 AM
    Just edited startrup.c to change : IOMUXC_GPR_GPR16 = 0x00200007; Running a graphics program in STBASIC and pressing <ctrl><alt><del> does a complete soft reset to my boot screen. Next step is to integrate the...
    52 replies | 1285 view(s)
  • wwatson's Avatar
    01-25-2020, 01:51 AM
    @Frank B - Thank you for pointing me to this link. I have the weekend to myself (I think), so hope to integrate this into my system. Also want to play with the soft reset that @everybody and you has put so much work...
    52 replies | 1285 view(s)
  • wwatson's Avatar
    01-24-2020, 01:55 AM
    wwatson replied to a thread Arduino 1.8.11 in General Discussion
    As far as MSC , I have been working an updated version. At this point the old version is working but not what would be called mature. I have updated the error processing portion and reduced the number of function calls...
    11 replies | 623 view(s)
  • wwatson's Avatar
    01-21-2020, 03:02 AM
    Here is something that I was using with the T36 and ESP8266. Not Sure if it can be adapted to to the T4 or ESP32. It is old and I am not sure if it is still being supported. It worked with NTP and FTP Server/Client...
    12 replies | 683 view(s)
  • wwatson's Avatar
    01-14-2020, 05:38 AM
    Did you write to the disk with "#define BUFFSIZE (32*1024)"? This is what I am trying to figure out. Probably something obvious. If I write to the disk with a 32 bit 32768 byte buffer the SSD write speed is 10.7 MB/s....
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-14-2020, 03:45 AM
    Did you ever do any speed testing with the Kingston SSD drive and the StarTech USB to SATA adapter? I bought them and using the latest Arduino 8.10 and TD 1.49b5 I am getting transfer speeds of 10.733134 MB/s for both...
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-05-2020, 01:29 AM
    I see what you are saying. The amber LED on pin #13 should be turning on when setup is called: pinMode(13,OUTPUT); pinMode(13,HIGH); But it does not turn on unless you use: pinMode(13,OUTPUT); ...
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-04-2020, 08:04 PM
    That's good to here. I'm just setting up on the T4. I have been working on an updated version of MSC and am trying to figure out the best way to buffer up reads and writes. (mostly writes). Been checking out using LRU...
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-04-2020, 07:39 PM
    @ all - Back home now. I was able to duplicate this error: Test logger_RawWrite uSDFS_VER:30_Jun_19_07_17 BUFFSIZE :32768 Dev Type :2:/ File System FS_FAT32 Free Disk Size 3183446 clusters Cluster Size 64 sectors...
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-04-2020, 05:58 PM
    @all - Started from scratch with one of my computers using Linux. Using Arduino 1.8.10, TD 1.49B4 I cloned fresh copys of MSC and uSDFS. Here is the results of writes and reads of both exFAT and FAT32 on a USB stick...
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-04-2020, 06:11 AM
    @defragster, @all - Here is a sketch that I have been playing with. It performs the same read speed test as the write speed tests. I think:) I have modified WMXZ's logger_RawWrite.ino example to do read speed tests...
    388 replies | 13697 view(s)
  • wwatson's Avatar
    01-02-2020, 12:50 AM
    wwatson replied to a thread Circular_Buffer in General Discussion
    You are right! Not enough sleep I guess. The print_test.read() has not been performed yet before print_test.size is tested and returns 0.
    176 replies | 13733 view(s)
  • wwatson's Avatar
    01-01-2020, 10:42 PM
    wwatson replied to a thread Circular_Buffer in General Discussion
    Thanks for the quick reply:)
    176 replies | 13733 view(s)
  • wwatson's Avatar
    01-01-2020, 10:18 PM
    wwatson replied to a thread Circular_Buffer in General Discussion
    @tonton81 - I cloned your Circular Buffer library and ran circular_buffer_example.ino. Everything seemed to work fine except print_test.print and print_test.println. Here is a stripped down version with the same...
    176 replies | 13733 view(s)
  • wwatson's Avatar
    12-31-2019, 01:38 AM
    @loglow - Cannot wait for the launch of this. I will order a fully assembled unit with all the fixin's. Thanks for all yours and the others hard work at getting this done:) I had no problems with your T3.6 breakout...
    407 replies | 27214 view(s)
No More Results
About wwatson

Basic Information

Statistics


Total Posts
Total Posts
172
Posts Per Day
0.19
Last Post
Ra8876 01-28-2020 04:00 AM
General Information
Last Activity
01-28-2020 04:50 AM
Join Date
08-10-2017