Forum Rule: Always post complete source code & details to reproduce any issue!
Tab Content
  • wwatson's Avatar
    08-05-2020, 10:40 PM
    I hope to have time to test this weekend. I am really curious how works on my 10.1" display. As far a rotation with putPicture() goes probably need to study the guru's code before I can even begin to play with it:)
    321 replies | 8279 view(s)
  • wwatson's Avatar
    08-05-2020, 03:42 PM
    @blackketter - I created a second branch in the Ra8876LiteTeensy repository the link is here: https://github.com/wwatson4506/Ra8876LiteTeensy/tree/Ra8876LiteTeensy-ER-TFTM0874 Even though I do not have your type...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    08-04-2020, 02:46 AM
    Sorry about the backtrack. I think that maybe I need to create a separate branch for testing with the ER-TFT0784 to keep things pure for us that do not have that particular display. I have downloaded your version of the...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    08-03-2020, 06:28 PM
    If you look at the line that says fatal error: you are missing the f oward slash between "c++" and "config.h". The compiler thinks "c++config.h" if a filename.
    14 replies | 292 view(s)
  • wwatson's Avatar
    07-31-2020, 04:33 AM
    Decided to upload my working version. Please let me know if things are working correctly. Then I will do pull requests. Everything you guys have done is working on my display with all examples. No lockups or problems😀
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-31-2020, 12:10 AM
    I done a bad thing again didn't I? Can I revert back to my original library through GitHub or do I need to upload my working version of it and then go from there? Sorry for any inconvenience I probably caused:( Thanks
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-30-2020, 01:47 AM
    @kurtE, @mjs513, @blakketter - I did the pull requests. I have not had the time to test yet. I have to back up the original library locally because of the the issues with the scroll function that I fixed and a couple of...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-27-2020, 12:38 PM
    I have updated my GitHub repository. Hope it works with your displays. Headed for work now:(
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-27-2020, 03:34 AM
    @mjs513 - I have other than the VT100 sketch working + others on my setup. Can't test the touch screen because mine is not cap touch. I had to make a few changes to make all of the sketches work and will push the...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-20-2020, 12:39 AM
    @vjmusik - Dang me! I did not realize your update for NativeEthernet was 07/02/2020. I thought the update was included in the release of TD 1.53. Off buy one again which was 07/01/2002:) Anyway, Everything seems to...
    75 replies | 4102 view(s)
  • wwatson's Avatar
    07-19-2020, 01:54 AM
    Having what I believe is the same problem. Working on the Arduino FTP server I am losing packets from server to client if the file size is > 512 bytes. If transfer from client to server there is no problem. File sizes...
    75 replies | 4102 view(s)
  • wwatson's Avatar
    07-12-2020, 11:59 PM
    @All - SUCCESS! I now have the T4.1 version of Arduino-Ftp-Server giving me directory listings using FileZilla and gFTP. The library is using NativeEthernet, Arduino-Ftp-Server, Arduino-FatLib, Arduino-FatFS, uSDFS...
    75 replies | 4102 view(s)
  • wwatson's Avatar
    07-12-2020, 02:26 AM
    @mjs513 @defragster - Got my chips today. Ready to see if I can solder up and test. I have one more T4.1 and the T4.1 beta test board to play with. My humidity Indicator was blue - never seen this before but I guess...
    158 replies | 3309 view(s)
  • wwatson's Avatar
    07-12-2020, 12:04 AM
    @manitou @vjmuzik - Have lwip_ftpd and lwip-ftpd-sd working with NativeEthernet. I originally had this Arduino FTP server working with the T3.6 and WIFISpi. https://github.com/gallegojm/Arduino-Ftp-Server. Since...
    75 replies | 4102 view(s)
  • wwatson's Avatar
    07-07-2020, 12:34 AM
    @manitou - Again thanks for responding. You pointed me to a lot of info. I have worked through all of @vjmuzik's FNET examples and tftpd with success. Now to checkout lwIP. So many things to explore and learn about....
    75 replies | 4102 view(s)
  • wwatson's Avatar
    07-06-2020, 02:35 AM
    Thanks for responding. I think I will start playing with the Arduino FTP server program I found and maybe even the ones I used with wifispi. There are some others that I was checking out but never finished working with....
    75 replies | 4102 view(s)
  • wwatson's Avatar
    07-06-2020, 02:09 AM
    @vjmuzik - I added the Ethernet kit to my T4.1's and tested with this library. All works well. Can you recommend a good FTP library to use. On my T3.6 I was using the Adafruit ESP8266 huzzah board with wifispi and...
    75 replies | 4102 view(s)
  • wwatson's Avatar
    07-06-2020, 01:52 AM
    @mjs513 - Can you give me the exact part number for the NAND chip you are using? When I looked it up I saw that there were at least three different package types available and I want to make sure that I order the proper...
    158 replies | 3309 view(s)
  • wwatson's Avatar
    07-06-2020, 01:33 AM
    @All - just to let you know I touched up the soldering job on the extram chips on the one T4.1 board that I was having a problem with. That fixed the the issue I was having with having to add delay's to the config...
    797 replies | 36778 view(s)
  • wwatson's Avatar
    07-05-2020, 12:15 AM
    @All - Worked on several example sketches today. piptest.ino, scroll.ino and MemoryTransfer.ino. These are working now. MemoryTransfer.ino was just a problem with setup(). Had to do with Serial initialization. Here is...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-04-2020, 04:27 PM
    @mjs513 - Here is a sketch to demonstrate the issue with drawRect() and printStatusLine(). #include "Arduino.h" #include "RA8876_t3.h" #include <math.h> #define RA8876_CS 10 #define RA8876_RESET 8 #define...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-04-2020, 12:50 AM
    Got it. That was the difference. Completely missed the fact that you were using graphic fonts. Right now I am working with piptest.ino. Discovered a conflict between drawRect() and printStatusLine(). Eliminating all but...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-03-2020, 09:06 PM
    I did the PR and am playing with the example sketches right now. It blows me away the way you guy's redid the library. It is going to be fun working with a quality library. I did not realize you had the rotation working...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    07-03-2020, 07:40 PM
    @mjs513, @Kurte - I just got back to Ra8876LiteTeensy today. I have been going through all of the work that you guy's did trying to reorient myself to the changes. Did not realize all of the work you put into it. WOW!...
    321 replies | 8279 view(s)
  • wwatson's Avatar
    06-27-2020, 11:57 PM
    @Silverlock - The other build did not work. I think you both are right. I will touch up the soldering and see what happens. I have two more T41's and more psram chips to solder up and test. Will probably just do one...
    31 replies | 1798 view(s)
  • wwatson's Avatar
    06-27-2020, 10:47 PM
    @Silverlock, Thanks for the the download. I will upload and test without my mod's to startup.c. I do not have a windows machine so this will help verify the validity of the Linux compiler. @defragster, The...
    31 replies | 1798 view(s)
  • wwatson's Avatar
    06-27-2020, 09:31 PM
    @defragster, @Silverlock, I am running a 600MHz, Optimize Fast, psram purchased directly from PJRC. I have done further testing and found some interesting results. Instead of this modification: // look for the...
    31 replies | 1798 view(s)
  • wwatson's Avatar
    06-27-2020, 08:56 PM
    Thanks for checking. Will wait for results.
    31 replies | 1798 view(s)
  • wwatson's Avatar
    06-27-2020, 08:35 PM
    Linux Ubuntu 18.04.1 Installed on Ardunio 1.8.13. So far everything is working well. The only thing I have trouble with is running teensy41_psram_memtest.ino. It still fails unless I modify startup.c as per this...
    31 replies | 1798 view(s)
  • wwatson's Avatar
    06-20-2020, 09:54 PM
    @ftrias - This is so awesome!! It all comes up and works:) The gdbgui pops up in my Firefox browser after compiling and when I type in step in the command line I see 'mark =' values increasing in the terminal window....
    70 replies | 2206 view(s)
  • wwatson's Avatar
    06-20-2020, 08:25 PM
    Thanks for the link. I will definitely check this out. I remember using 'DDD' as front end to GDB. I also remember using 'make' from within GDB.
    70 replies | 2206 view(s)
  • wwatson's Avatar
    06-20-2020, 07:19 PM
    I have it working now and changed the terminal program from xterm to mate-terminal in 'teensy_debug'. My eye's need bigger fonts:) Anyway it's working and now have to refresh my memory on using gdb. It's been years...
    70 replies | 2206 view(s)
  • wwatson's Avatar
    06-20-2020, 06:10 PM
    Thanks for the work around. That worked:)
    70 replies | 2206 view(s)
  • wwatson's Avatar
    06-20-2020, 05:44 PM
    @ftrias - Having problems installing TeeensyDebug on My Linux laptop.Using Ubuntu 4.4.0. Running './install-linux.sh -i=/home/wwatson/arduino-1.8.13' I got this: wwatson@wwatsonl1:~/TeensyDebug$ ./install-linux.sh...
    70 replies | 2206 view(s)
  • wwatson's Avatar
    06-17-2020, 04:04 AM
    Thanks @defragster - I understand now. I am seeing the 'mark' variable changing values. This brings back cool memories:)
    70 replies | 2206 view(s)
  • wwatson's Avatar
    06-17-2020, 02:54 AM
    OK I am really embarrassed here:( I was using gdb with the Motorola 68332 back in the 90's and cannot remember how it all worked. I was part of the EFI332 forum which used the 68332 for a fuel injection system that...
    70 replies | 2206 view(s)
  • wwatson's Avatar
    06-14-2020, 09:27 PM
    Probably the easiest way would be to use the example programs in the USBHost_t36 library. Maybe try a USB keyboard or mouse. Edit: I would be interested this. Looks like it take minimal soldering of those dinky...
    22 replies | 584 view(s)
  • wwatson's Avatar
    06-10-2020, 05:15 PM
    Just had it happen on one of my three Linux machines. Backed up the original .arduino15 folder and restarted arduino-1.8.12 with no problem. I use the laptop more than the two desktops and that is the one that failed....
    8 replies | 227 view(s)
No More Results
About wwatson

Basic Information

Statistics


Total Posts
Total Posts
300
Posts Per Day
0.27
Last Post
RA8876LiteTeensy For Teensy T36 and T40 08-05-2020 10:40 PM
General Information
Last Activity
08-05-2020 10:40 PM
Join Date
08-10-2017