Forum Rule: Always post complete source code & details to reproduce any issue!
Tab Content
  • Jean-Marc's Avatar
    08-21-2019, 05:12 PM
    MCUME multi-systems emulator has been upgraded to support Teensy4.0 and ST7789 Display. Now with Atari 520ST support (Motorola 68k core running full speed!) https://github.com/Jean-MarcHarvengt...ster/README.md ...
    0 replies | 71 view(s)
  • Jean-Marc's Avatar
    08-21-2019, 03:05 PM
    As promised, MCUME multi systems emulator updated to Teensy4.0 and ST7789. Now with Atari 520ST support (Motorola 68k core running full speed!) https://github.com/Jean-MarcHarvengt/MCUME/blob/master/README.md Check...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-19-2019, 10:12 AM
    MQS sound is now ok. With pin10 mono (not using pin 12). I am still interested to know how to disable fully MQS on pin 12 in case I would use MISO one day. I now soldered the SD using SDIO iso SPI. I will post a...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-17-2019, 07:19 PM
    Thanks for the tip. Mono sound is is enough. If I could use pin 10 only for audio (CS can be whatever pin) and disable MQS on pin 11. As soon the SPI init is called, MQS sound stops. I guess I need to do something in...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-17-2019, 12:03 PM
    Thank you Manitou! I never noticed it was on the card. It works also for me with the guitar sample. I thought it was on pin 2 (out2). You know if it can be reconfigured somewhere else. 10 and 12 are often used for SPI...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-17-2019, 11:12 AM
    Hi Frank, Is the MQS output still supported in the Audio library for the T4? On what pin does it output sound? I tried pin2 with 100uF (+ at pin 2 side), speaker in series to ground but I hear nothing. Thanks, ...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-17-2019, 08:44 AM
    Sorry, just saw this link now: https://www.pjrc.com/breakout-board-for-teensy-4-0/ Thanks Paul.
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-17-2019, 08:31 AM
    Hi Kurt, Not sure if you tried yourself to connect the 4pin SDIO at the bottom (8pins) to a micro SD. Could somebody help me to find the type of connector required for the SDIO pins, the one use for the ribbon cable?...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-14-2019, 04:50 PM
    Hi Paul, is the PWM audio output working in the Audio lib on the T4? I have a compilation error with the T4 but not with the T3.6? I am not familiar with using PWM as for audio output. Is there a tutorial somewhere?...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    08-07-2019, 05:55 PM
    Congratulations for the great job! Many people were waiting for this milestone. And I am really amazed by its price. Very competitive and unique for many points. I wish the T4 a very successful life!
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    07-12-2019, 05:22 AM
    @manitou,@wmxz, Is there a way to specify the CS when using uSDFS in SPI mode (audio board or when using the SD of the ili9341 display) iso the Sdio build-in pins? A bit like SD lib does?
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    07-11-2019, 07:18 AM
    If someone wants to try the emulators on the T4, use teensyMCUME on https://github.com/Jean-MarcHarvengt Pinout file is included. For more details, use the doc in espMCUME. At the exception of teensyvectrex, the rest...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    07-11-2019, 06:49 AM
    Thanks, I had noticed that you could also use uSDFS with the SD card but when I tried it was not working. May be it is because of my card. I use to format it Fat on the Mac. I will try again when I am back from holiday....
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    07-10-2019, 03:22 PM
    I have tried USDFS with USB MSC library, it goes very well. I created a small app on the ILi9341 to browse files from USB and SD card (using Sdio connected of the break out board). For the SD file browsing I had to use...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    07-02-2019, 06:07 AM
    Talking back about the cache management, I also had the issue using the SD card library to load content into OCRAM. I just wrap up the file.read in a custom function that reads in everything in chunks of 256 bytes in a...
    4159 replies | 426434 view(s)
  • Jean-Marc's Avatar
    06-25-2019, 05:45 PM
    Thanks for your advice Paul, it did help. I now have a picture for the Atari520ST emulator port. I still miss 8K to allocate outside the OCRAM but I can now see how fast the T4 is compare to the ESP32 with the SPI RAM....
    4159 replies | 426434 view(s)
No More Results
About Jean-Marc

Basic Information

Statistics


Total Posts
Total Posts
45
Posts Per Day
0.10
Last Post
Atari 520ST emulator on Teensy4.0 08-21-2019 05:12 PM
General Information
Last Activity
Yesterday 06:52 AM
Join Date
05-26-2018