Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.05 seconds.

  1. Replies
    544
    Views
    9,579

    Morning @KurtE :) Funny you should mention...

    Morning @KurtE :)

    Funny you should mention about CSI/OV7670 was just looking at that this morning. Great minds.

    Anyway for now think I have gone about as far as I can go with mods - still...
  2. Replies
    544
    Views
    9,579

    Thanks @defragster. Now that there is some life...

    Thanks @defragster. Now that there is some life I think I may know what the problem may be.

    EDIT: Nope what I thought may be wrong looks correct. But I did add my change to get GPIO 'F' working...
  3. Replies
    544
    Views
    9,579

    Thanks for checking - have to retest. Yes 'f'...

    Thanks for checking - have to retest.

    Yes 'f' only in GPIO-8bit for now - that's on the todo list to fix
    Yep - VID only works in DMA mode as it did before but 'F' and 'f' works with FlexIO as...
  4. Replies
    544
    Views
    9,579

    Yep 'f' - single shot, 'F'-continuous (still not...

    Yep 'f' - single shot, 'F'-continuous (still not working if in DMA_8BIT mode but it does give you what you describe - what about 'V' ideo ? That's the one I am curious about.

    NOTE: I haven't...
  5. Replies
    544
    Views
    9,579

    Thanks would appreciate - all else seems to be...

    Thanks would appreciate - all else seems to be working with DMA though. Already created WIP branch on github: https://github.com/mjs513/TMM-HB01B0...ree/API-Rework
  6. Replies
    544
    Views
    9,579

    Just a quick update. Been trying to figure it...

    Just a quick update. Been trying to figure it out most of the day. Found a couple errors but still no luck with video mode. So I bypassed my readframe's etc and used direct calls but no luck. Not...
  7. Replies
    544
    Views
    9,579

    As a test I just pushed some more changes to the...

    As a test I just pushed some more changes to the API_rework branch: https://github.com/mjs513/TMM-HB01B0-Camera/tree/API-Rework

    I supports 3 cases for the Mircomod only:

    /*
    * ...
  8. Replies
    544
    Views
    9,579

    @KurtE Forgot about the table you have in the...

    @KurtE
    Forgot about the table you have in the FlexIO library - was actually looking to create one - sort of.

    Right now the way it looks is the DMA is used for both for DMA mode and FlexIO mode...
  9. Replies
    544
    Views
    9,579

    Now for instance. For DMA I see that the...

    Now for instance. For DMA I see that the function:

    startReadFrameDMA(bool(*callback)(void *frame_buffer), uint8_t *fb1, uint8_t *fb2)
    does setup framebuffers if fb1 and fb2 are not specified. ...
  10. Replies
    544
    Views
    9,579

    Good Morning all Started work on mods to the...

    Good Morning all
    Started work on mods to the lib. Created the following in the lib:

    typedef enum {
    HM01B0_SPARKFUN_ML_CARRIER = 0,
    HM01B0_TEENSY_MICROMOD_GPIO_8BIT,...
  11. Replies
    544
    Views
    9,579

    @All Good Morning. Decided to play a bit more...

    @All
    Good Morning.

    Decided to play a bit more with the camera so I ported over the CMSIS NN example using CIFAR10 example that identifies several objects. Did have to reduce the size of the...
  12. Replies
    544
    Views
    9,579

    Actually yes, on and off thought about but...

    Actually yes, on and off thought about but something always distracted me. Just took another look and found this one as well: https://create.stephan-brumme.com/toojpeg/ == it has some good...
  13. Replies
    544
    Views
    9,579

    @luni Nice toy. Must be nice to have room for...

    @luni
    Nice toy. Must be nice to have room for things like that :)

    Guess I will have to see about about sending a continuous stream to the PC :)
  14. Replies
    544
    Views
    9,579

    No - you are going to be in trouble if you use...

    No - you are going to be in trouble if you use that one. Down the version I am using from here: https://github.com/ArduCAM/Arduino/tree/master/ArduCAM/examples/host_app/ArduCAM_Host_V2.0_Windows
  15. Replies
    544
    Views
    9,579

    Actually not really. FlexIO is so intertwined...

    Actually not really. FlexIO is so intertwined with the DMA stuff that 98% of its still being called for flexIO dma. :) which I chose to leave in. That caused me some problems when doing that :)
    ...
  16. Replies
    544
    Views
    9,579

    Got it. I wouldn't hold it up either. It does...

    Got it. I wouldn't hold it up either. It does seem to be working.

    @Paul - @defragster
    I did just make a few changes in prep for final release. I add 3 defines (at least for now) in the HM01B01...
  17. Replies
    544
    Views
    9,579

    I just tried it with your change and saw the same...

    I just tried it with your change and saw the same thing but only if I changed the default size "Arial_10_Bold", otherwise it hung after only 1 cycle.
  18. Replies
    544
    Views
    9,579

    Not a problem, just wanted to let you know. Took...

    Not a problem, just wanted to let you know. Took a while to find a display that you didn't test with - saw you tested with the 240x240 and the 320x240.

    One curious thing about the HM01B0. Was...
  19. Replies
    544
    Views
    9,579

    Just tested your latest changes on a T4.1 with a...

    Just tested your latest changes on a T4.1 with a Adafruit 128x128 display. Starts up fine and display looks good however after I toggle updates off screen stops but I can't seem to toggle it back...
  20. Replies
    544
    Views
    9,579

    Morning all @KurtE - Just downloaded your...

    Morning all
    @KurtE - Just downloaded your updates from last night and yep resolved the compile issue. Did you sort out your compile issue?

    @ecurtz
    Your guess was pretty good. With a couple of...
  21. Replies
    544
    Views
    9,579

    @KurtE Think your latest rounds of updates to...

    @KurtE
    Think your latest rounds of updates to the 7735 lib broke something in the HM01b0 library:
    ...
  22. Replies
    544
    Views
    9,579

    @KurtE Ok I give up. Got be doing something...

    @KurtE
    Ok I give up. Got be doing something wrong someplace and not sure where. What I am trying to duplicate is what we did in your CSI_41_main in the send_image function. But just can't seem to...
  23. Replies
    544
    Views
    9,579

    No comment on git :) Any I just compile the...

    No comment on git :)

    Any I just compile the test sketch that you posted with the latest updates to the ST7735 library and got no errors. I tried 7789 only, 9341 only, and both uncommented still...
  24. Replies
    544
    Views
    9,579

    Afternoon @KurtE Thanks for the references on...

    Afternoon @KurtE
    Thanks for the references on the regulators - now have no idea which to put on the breakout board :) Any suggestions. Leaning to the 1.5 amp one just in case :)

    I'll give the...
  25. Replies
    544
    Views
    9,579

    Got a side question on regulators for the T4.1...

    Got a side question on regulators for the T4.1 breakout board.

    Someone gave me a link for 5v VIN reg (https://www.ezsbc.com/product/psu5-2/ or I was looking at...
  26. Replies
    544
    Views
    9,579

    Ok - thats strange would have thought it would...

    Ok - thats strange would have thought it would have worked.

    Not having much luck with my project. Think going to ditch it. Something is off have I can't figure it out.
  27. Replies
    544
    Views
    9,579

    @KurtE - glad all is working. The testing I did...

    @KurtE - glad all is working. The testing I did was on the 320 display and just waiting for the mail to hook it up to the T4.1 display adapter I have. Will let you know when I get it. Rainy cool...
  28. Replies
    544
    Views
    9,579

    Yesterday and this morning was working on sending...

    Yesterday and this morning was working on sending an image to Arducam Imaging App. The app takes images - bmp or video and displays it rathe quickly. But looks like I have to resize from down to...
  29. Replies
    544
    Views
    9,579

    Exact same one - will arrive this afternoon...

    Exact same one - will arrive this afternoon probably :)
  30. Replies
    544
    Views
    9,579

    Morning @KurtE Just got my coffee then...

    Morning @KurtE
    Just got my coffee then downloaded your updated lib and tried on the Micromod - seems to be working as far as I can see - toggled the updates on/off several times and no issues.

    I...
  31. Replies
    544
    Views
    9,579

    You know never thought about looking up the ascii...

    You know never thought about looking up the ascii character - no wonder I was having a problem - thanks :) So obvious after the fact
  32. Replies
    544
    Views
    9,579

    Nope: hm01b0_testv3:503: error: duplicate case...

    Nope:

    hm01b0_testv3:503: error: duplicate case value
    case 48:
    ^
    hm01b0_testv3:489: error: previously used here
    case '0':
    ^
    only wants single characters - maybe redo...
  33. Replies
    544
    Views
    9,579

    @KurtE Just gave your 'V' mode a try with the...

    @KurtE
    Just gave your 'V' mode a try with the ST7789 and....
    1. Sparkfun config - worked very nicely, however when I exited video mode the TMM was basically hung. Could not enter any other...
  34. Replies
    544
    Views
    9,579

    Afternoon all @KurtE - looks like you been busy...

    Afternoon all
    @KurtE - looks like you been busy this morning and afternoon between the new board design and fixing ST7735 lib. Kind of been a bit distracted with running errands again and in...
  35. Replies
    544
    Views
    9,579

    Good luck @KurtE. Be interesting see how it...

    Good luck @KurtE. Be interesting see how it works.

    Thinking about changing the name of the test sketch in prep for release to: HM01B0-KitchenSink :) Then start breaking some of the code out...
  36. Replies
    544
    Views
    9,579

    The last PR incorporated from @KurtE included the...

    The last PR incorporated from @KurtE included the 'V'ideo command.

    Tested with both Sparkfun and non-Sparkfun. Only thing is for DMA video/continuous it does take a while for the image to synch...
  37. Replies
    544
    Views
    9,579

    Good Morning all Just gave our latest set of...

    Good Morning all
    Just gave our latest set of updates a spin. Tested the same as @defragster and agree all is working well. The only thing not tested was the 'z' command.
  38. Replies
    544
    Views
    9,579

    All Had a strange thought - not sure where it...

    All
    Had a strange thought - not sure where it came from must have been a nightmare. With the lack of PSRAM on the MM board is there a way to use the SDIO pins to simulate having a PSRAM and maybe...
  39. Replies
    544
    Views
    9,579

    Didn't play much today just on and off. As you...

    Didn't play much today just on and off. As you said it was a nice day. Day is pretty much done here now and they are talking rain for tomorrow so probably will play some more tomorrow.

    One thing...
  40. Replies
    544
    Views
    9,579

    Yeah broke down and tested the Sparkfun...

    Yeah broke down and tested the Sparkfun Input/Display Carrier board. The display is 9341 compatible. Did get it working with the 9341 library but had to add a command - invert display on, then it...
  41. Replies
    544
    Views
    9,579

    Merge completed - good timing was doing...

    Merge completed - good timing was doing @defragster's merge. Have to figure out my 9341 - really giving me a hard time working.
  42. Replies
    544
    Views
    9,579

    Downloaded the latest set of changes. No...

    Downloaded the latest set of changes.

    No change to the way normal and DMA versions work. Same as last revision. With the latest fixes for FlexIO it kind of works but only a few rows on top of...
  43. Replies
    544
    Views
    9,579

    PR just merged. Sorry for the delay - had to run...

    PR just merged. Sorry for the delay - had to run out and do a few errands.
  44. Replies
    544
    Views
    9,579

    My turn for Oops - missed that in the PR was...

    My turn for Oops - missed that in the PR was looking at the changes more :) I don't mind the debug stuff.
  45. Replies
    544
    Views
    9,579

    @KurtE Just merged your PR :) EDIT: Just...

    @KurtE
    Just merged your PR :)

    EDIT: Just tested it and something strange going on with continuous mode. For the first bunch of frames the images are totally out of synch then all of sudden it...
  46. Replies
    544
    Views
    9,579

    @PaulStoffregen - Just gave it a quick test spin...

    @PaulStoffregen -
    Just gave it a quick test spin using 'f' and continuous "F" mode. "f" works as well as before however "F" is having issues. The image seems to be loosing synch. Another run had...
  47. Replies
    544
    Views
    9,579

    Noticed - PR already merged :) Just downloaded...

    Noticed - PR already merged :) Just downloaded it and now to play again.
  48. Replies
    544
    Views
    9,579

    @KurtE Once things settle down will have to go...

    @KurtE
    Once things settle down will have to go play with SublimeText and TSET again. Always something going on.
  49. Replies
    544
    Views
    9,579

    Work with v3. The only difference between v2 and...

    Work with v3. The only difference between v2 and v3 is the 'z' command for saving the last buffered image. Just tested it and its seems to be working with 's', 'D' and 'f' snapshots with hard...
  50. Replies
    544
    Views
    9,579

    Nice cheat. Anyway to the point. Just got rid...

    Nice cheat. Anyway to the point. Just got rid of the last use of imageBuffer so deleting that one. As for the sendImageBuf that's really only used for when you are sending images to the Processing...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4