Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Search: Search took 0.01 seconds.

  1. Replies
    21
    Views
    354

    @KurtE @PaullStoffregen Sorry - been...

    @KurtE @PaullStoffregen

    Sorry - been repairing holes in walls today and grouting tile. Anyway I tested your changes with the BNO055 and the propshield with the MPL3115 that I was having a...
  2. Replies
    21
    Views
    354

    @KurtE That seems to make sense - fifo_used...

    @KurtE

    That seems to make sense - fifo_used comes in at 4 so the fifo prints never seem to hit.
  3. Replies
    21
    Views
    354

    @KurtE @PaulStoffregen fifo_used always...

    @KurtE @PaulStoffregen

    fifo_used always seems to be = 4. Not sure if that means anything.
  4. Replies
    21
    Views
    354

    @KurtE Yeah that's pretty much what I am...

    @KurtE

    Yeah that's pretty much what I am seeing as well.

    It will make it through the first read8 which gets the CHIP ID. The next write8 is to Switch Mode's to Configuration mode. The third...
  5. Replies
    21
    Views
    354

    @KurtE Not sure if this will help but I...

    @KurtE

    Not sure if this will help but I uncommented the printf's in endtransmission in wireIMXRT.cpp:

    Orientation Sensor Raw Data Test

    Chip ID
    m=1
    MSR=1, MFSR=0
    t=0
  6. Replies
    21
    Views
    354

    @KurtE Thanks for checking - Mike Edit: I...

    @KurtE

    Thanks for checking - Mike

    Edit: I did put some prints and delays in write function in wire but it hangs on that one command but not on the T3.6?
  7. Replies
    21
    Views
    354

    @Maikeru - @PaulStoffregen Just as a quick...

    @Maikeru - @PaulStoffregen

    Just as a quick test I hooked up the BNO055 to a T3.6 with the reset command uncommented:

    write8(BNO055_SYS_TRIGGER_ADDR, 0x20);

    and the examples work without a...
  8. Replies
    21
    Views
    354

    Just as a test - I had found this on the adafruit...

    Just as a test - I had found this on the adafruit forum: https://forums.adafruit.com/viewtopic.php?t=133511#p664391
    which equates to this instead of the write8

    pinMode(3, OUTPUT);
    ...
  9. Replies
    21
    Views
    354

    I found the issue on the bosch site and the work...

    I found the issue on the bosch site and the work around. Also just saw something on the Adafruit site about something like it and resetting. So think the issue is probably on the Adafruit side.
  10. Replies
    21
    Views
    354

    @Maikeru - @PaulStoffregen No. This is the...

    @Maikeru - @PaulStoffregen

    No. This is the place to ask abou the BNO055. The problem with the BNO055 is a known problem that was hightlighted in this thread:
    ...
Results 1 to 10 of 10