Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.04 seconds.

  1. Replies
    45
    Views
    1,411

    Wow - was just going to start reading up on HAB...

    Wow - was just going to start reading up on HAB to play around with it but looks like its solved - really is great news. Looking forward to see what you did to get it working ?
  2. Replies
    40
    Views
    3,934

    Sticky: I didn't try running it manualy but I did try and...

    I didn't try running it manualy but I did try and just press the button on the T4,1 just in case but didn't load - probably got impatient and didn't wait long enough.

    Agree - Paul probably needs...
  3. Replies
    40
    Views
    3,934

    Sticky: @KurtE - I am using 1.8.13 aarch64 version -...

    @KurtE - I am using 1.8.13 aarch64 version - arduino-1.8.13-linuxaarch64

    If i turn on verbose mode I didn't notice anything strange, looks like it compiled without error. Also as I mentioned when...
  4. Replies
    40
    Views
    3,934

    Sticky: Just checked and /tmp has drwxrwxrwt 15 root...

    Just checked and /tmp has

    drwxrwxrwt 15 root root 4096 Oct 14 19:05 tmp

    If I compile Blink for the Uno I don;t get the error?
  5. Replies
    40
    Views
    3,934

    Sticky: Good Morning all Running into a something while...

    Good Morning all
    Running into a something while trying to get a sketch to load to a brand new toy I got recently and something out of my normal wheel house. So here goes.

    I picked up a PI4 with...
  6. Replies
    11
    Views
    393

    Ok hooked up a T4.1 with 1 PSRAM chip and ran the...

    Ok hooked up a T4.1 with 1 PSRAM chip and ran the three example programs:
    Simple.ino

    f1 address: 0x20000de8, value: 3.141593
    f2 address: 0x20000e90, value: 1.414214
    t2 address: 0x20000e0c,...
  7. Replies
    11
    Views
    393

    Indeed - very cool - have to give it a try soon! ...

    Indeed - very cool - have to give it a try soon! Nice find :)
  8. Replies
    12
    Views
    297

    A while ago @KurtE and I and others worked on...

    A while ago @KurtE and I and others worked on getting a RPI Kedei display working with the T3x-T4. You might want to give the library we developed for that a try:...
  9. Replies
    162
    Views
    5,423

    Sorry for the delay in responding but been busy...

    Sorry for the delay in responding but been busy with a few other projects.

    Was trying to figure out where the problem was but no luck. Probably best that you switch to the BNO055, as you said...
  10. Replies
    162
    Views
    5,423

    I agree @KurtE. Should be usable in both cases...

    I agree @KurtE. Should be usable in both cases just never checked it out, that was one of the reasons I suggested adding pinMode(int pin, INPUT). But INPUT_PULLUP is probably better but in the...
  11. Replies
    162
    Views
    5,423

    Ok - ran the motionTracker sketch again and saw...

    Ok - ran the motionTracker sketch again and saw the same thing after 15mins of running - then i ran my test sketch and its still running after 15mins with no issue. Has to be something with that...
  12. Replies
    162
    Views
    5,423

    Well in my testing i never saw the issue after I...

    Well in my testing i never saw the issue after I changed the begin statement - so question is are you using the modified lib I provided or the original if you are using the INT pin again. Really...
  13. Replies
    162
    Views
    5,423

    My guess is that there is some issue with using...

    My guess is that there is some issue with using the int pin on BNO080 with the sketch you are using. With out the int you don't get the error of a dead BNO080. I haven't had time to read the docs...
  14. Replies
    162
    Views
    5,423

    Good Luck and definitely keep us posted.

    Good Luck and definitely keep us posted.
  15. Replies
    162
    Views
    5,423

    Ok think I found the issue - tried short...

    Ok think I found the issue - tried short durations and very long durations with power off and in each case the BNO080 starts right up. I basically told it to ignore the interrupt pin and default to...
  16. Replies
    162
    Views
    5,423

    Yes when the sensors are all working can see the...

    Yes when the sensors are all working can see the data using the keystrokes.

    If you have the Arduino IDE open and you just loaded a sketch you can reload by pressing the button on top of the T4 -...
  17. Replies
    162
    Views
    5,423

    Ok here is a sketch that i just tested with 2...

    Ok here is a sketch that i just tested with 2 BNO055s and 1 BNO080.

    #include <Wire.h>

    #include "SparkFun_BNO080_Arduino_Library.h"
    BNO080 myIMU;

    #include <Adafruit_Sensor.h>
    #include...
  18. Replies
    162
    Views
    5,423

    @marcob Please pay close attention to...

    @marcob

    Please pay close attention to @KurtE's post #122 as well. Good possibility that in your use case with the Motion Tracker app there is an issue with latency and report updates.
  19. Replies
    162
    Views
    5,423

    You should be able to run it with your setup -...

    You should be able to run it with your setup - leave both BNO055's connected. You modify the sketch to use both BNO055's as well by creating another instance of it with the second BNO055 address.
  20. Replies
    162
    Views
    5,423

    I modified the previous test sketch so that it...

    I modified the previous test sketch so that it works plus added a BNO055 into the mix at I2c Addr of 0x29:

    #include <Wire.h>

    #include "SparkFun_BNO080_Arduino_Library.h"
    BNO080 myIMU;
    ...
  21. Replies
    162
    Views
    5,423

    If you look at the details of the code it seems...

    If you look at the details of the code it seems to be failing on the BNO080 update function:

    void update()
    {
    // Serial.print(String(myIMU->dataAvailable()) + "\t");
    //...
  22. Replies
    162
    Views
    5,423

    What we were saying is that you can test to see...

    What we were saying is that you can test to see if it matters with the PU's just by testing with the example sketches as a first step. By the way - Sparkfun had responded some time ago:
  23. Replies
    9
    Views
    266

    @el_supremo set it up so you can use the Arduino...

    @el_supremo set it up so you can use the Arduino IDE!
  24. Replies
    162
    Views
    5,423

    As you have shown the 2 bno055 and and bno080 are...

    As you have shown the 2 bno055 and and bno080 are detected on teensy. So not sure what else to help with you with the teensy until you try running some of the example sketches fro the Adafruit and...
  25. Replies
    162
    Views
    5,423

    I will second what @KurtE has stated. Have you...

    I will second what @KurtE has stated. Have you tried to run any of the example sketches for the BNO080 to see if they work. If the scanner is seeing the 2 BNO055's and the BNO080 then the next...
  26. Replies
    9
    Views
    266

    I would start by looking at main.cpp file. It...

    I would start by looking at main.cpp file. It looks like you can just copy and paste that into your Arduino IDE and then add all the .h files into the sketch as new tab's - you don't have to worry...
  27. Replies
    162
    Views
    5,423

    Ok jumping in here a bit late but if you have 1...

    Ok jumping in here a bit late but if you have 1 BNO080 and 1 BNO55 there should be no address conflicts. If you add a second BNO055 you will have to connect the ADDR pin on the BNO055 to 3.3v and it...
  28. Replies
    3
    Views
    162

    Not 100% sure that chip will be compatible. A red...

    Not 100% sure that chip will be compatible. A red flag for me from the data sheet shows the maximum clock on that chip is only 20 Mhz. You might want to check this post out:...
  29. Replies
    162
    Views
    5,423

    Short answer is yes. Several of us have tested...

    Short answer is yes. Several of us have tested the BNO080 in I2C mode. There was an issue but as Paul mentioned in post #71 that has been fixed since Teensyduino 1.49. We are up to 1.53 (latest). ...
  30. PSRAM is mentioned in this post...

    PSRAM is mentioned in this post https://forum.pjrc.com/threads/59040-CircuitPython-on-Teensy-4!?p=241797&viewfull=1#post241797 on the thread mentioned by @defragster. But you might still want to...
  31. Replies
    21
    Views
    485

    Yeah - theres that too - just didn't know how to...

    Yeah - theres that too - just didn't know how to phrase it and still on first cup of coffee :)
  32. Replies
    8
    Views
    290

    While the MotionSense library loads the cal data...

    While the MotionSense library loads the cal data for the accel and gyro I don't believe its ever been updated to do accelerometer calibration. See this PR in the MotionCal Library: Missing ability...
  33. Replies
    21
    Views
    485

    Re the CS pin change. Well the default CS pin...

    Re the CS pin change. Well the default CS pin for SPI is 10 and it was basically a hunch that pin 36 may not work automatically with the Lib. Was easier to suggest the pin change to see if it...
  34. The PSRAM runs at a default speed of 88Mhz which...

    The PSRAM runs at a default speed of 88Mhz which is set up in the core startup.c. However, you can change this to run at its max speed of 132Mhz if you want to try it by add the following in setup...
  35. I couldn't duplicate the problem you are seeing...

    I couldn't duplicate the problem you are seeing with my setup at all. Screen updated no problem. No problem with the config then - thought you were using a ST7735. Have to see if I can find my...
  36. Morning All I spent the morning looking over the...

    Morning All
    I spent the morning looking over the 2 libraries and there shouldn't be any conflicts that I can see. So while I don't have the same encoder and screen that you have I hooked up a...
  37. Replies
    21
    Views
    485

    I would recommend trying to change the CS pin...

    I would recommend trying to change the CS pin from 36 to 10 and see if that works. Not sure about pin using pin 36.
  38. Replies
    831
    Views
    32,451

    @KurtE Gave it a try and posted my comments in...

    @KurtE
    Gave it a try and posted my comments in the other thread. But I like it when you have a wired device. Be interesting if we could do that with attached Bluetooth devices as well :). May...
  39. Replies
    129
    Views
    20,089

    Gave it a try with my 3d Connection Mouse...

    Gave it a try with my 3d Connection Mouse attached.

    On startup it shows all the basic connection info:


    USB Host Testing

    960

    USB2 PLL running
  40. Well to be on the safe size you can just comment...

    Well to be on the safe size you can just comment the clock code out and it will use the default clock of 88Mhz, otherwise use that table I posted to set the correct settings for 104 Mhz.
  41. Replies
    831
    Views
    32,451

    Out of curiosity (that one always gets me), I...

    Out of curiosity (that one always gets me), I added a delay(4) in rx_data after que:

    default:
    DBGPrintf("BluetoothController::rx_data : Unknown BT rx_data");
    break;
    }
    //...
  42. Replies
    831
    Views
    32,451

    @KurtE timing issue ran through my idea last...

    @KurtE
    timing issue ran through my idea last night as well. Tried turning off the debugging stuff just to see what would happen. Basically nothing - had same issue. But had no idea where to even...
  43. Replies
    129
    Views
    20,089

    Out of curiosity what Buydisplay model are you...

    Out of curiosity what Buydisplay model are you using?
  44. Replies
    831
    Views
    32,451

    Important thing is keeping as much of the smoke...

    Important thing is keeping as much of the smoke out of your house.

    Anyway back to the XBOX. One thing I noticed on bot the T3.6 and T4.1 test is that if I loose the BT connection (either pull the...
  45. Replies
    831
    Views
    32,451

    @KurtE Something strange. Was adding a couple...

    @KurtE
    Something strange. Was adding a couple of debug prints to your stuff and all of a sudden after the upload it started working! Getting data.

    When i reloaded as a test went back to...
  46. A couple of things. First I gave you a link to...

    A couple of things.

    First I gave you a link to the BME280, keep getting them backwards. The link to the adafruit lib is: https://github.com/adafruit/Adafruit_BMP280_Library

    Second adafruit...
  47. Just a cursory look at the cactus bme280 library...

    Just a cursory look at the cactus bme280 library looks like its hardcoded to just use 1 Wire bus. So simple answer is that with the library you are using you can't use 2 BME280's. However, with...
  48. Replies
    831
    Views
    32,451

    In going through the Host shield code I noticed...

    In going through the Host shield code I noticed this:

    else if(l2capinbuf[6] == interrupt_dcid[0] && l2capinbuf[7] == interrupt_dcid[1]) { // l2cap_interrupt
    #ifdef PRINTREPORT
    ...
  49. Replies
    831
    Views
    32,451

    Morning @KurtE I just tried the whole process...

    Morning @KurtE
    I just tried the whole process again and at least now its not trying to connect to the TV. :)

    Anyway, just a couple of observations: (1) After I get the EV_MAX_SLOTS_CHANGE the...
  50. Replies
    831
    Views
    32,451

    @KurtE Just reread your post and redownloaded...

    @KurtE
    Just reread your post and redownloaded your lib, while I get connected I only get this far, so please ignore what post 816. Also had the teensyduino version still installed. Thats what i...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4