None of the Teensy Audio Library works on Teensy-LC yet. Someday a subset of the library will support LC, and some initial work has already started towards that goal... but a *lot* more remains to...