Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: wwatson

Page 1 of 6 1 2 3 4

Search: Search took 0.01 seconds.

  1. Replies
    307
    Views
    7,976

    Sorry about the backtrack. I think that maybe I...

    Sorry about the backtrack. I think that maybe I need to create a separate branch for testing with the ER-TFT0784 to keep things pure for us that do not have that particular display. I have downloaded...
  2. Replies
    9
    Views
    178

    If you look at the line that says fatal error: ...

    If you look at the line that says fatal error: you are missing the f
    oward slash between "c++" and "config.h". The compiler thinks "c++config.h" if a filename.
  3. Replies
    307
    Views
    7,976

    Decided to upload my working version. Please let...

    Decided to upload my working version. Please let me know if things are working correctly. Then I will do pull requests. Everything you guys have done is working on my display with all examples. No...
  4. Replies
    307
    Views
    7,976

    I done a bad thing again didn't I? Can I revert...

    I done a bad thing again didn't I? Can I revert back to my original library through GitHub or do I need to upload my working version of it and then go from there?
    Sorry for any inconvenience I...
  5. Replies
    307
    Views
    7,976

    @kurtE, @mjs513, @blakketter - I did the pull...

    @kurtE, @mjs513, @blakketter - I did the pull requests. I have not had the time to test yet. I have to back up the original library locally because of the the issues with the scroll function that I...
  6. Replies
    307
    Views
    7,976

    I have updated my GitHub repository. Hope it...

    I have updated my GitHub repository. Hope it works with your displays.

    Headed for work now:(
  7. Replies
    307
    Views
    7,976

    @mjs513 - I have other than the VT100 sketch...

    @mjs513 - I have other than the VT100 sketch working + others on my setup. Can't test the touch screen because mine is not cap touch. I had to make a few changes to make all of the sketches work and...
  8. Replies
    75
    Views
    3,914

    @vjmusik - Dang me! I did not realize your update...

    @vjmusik - Dang me! I did not realize your update for NativeEthernet was 07/02/2020. I thought the update was included in the release of TD 1.53. Off buy one again which was 07/01/2002:)

    Anyway,...
  9. Replies
    75
    Views
    3,914

    Having what I believe is the same problem....

    Having what I believe is the same problem. Working on the Arduino FTP server I am losing packets from server to client if the file size is > 512 bytes. If transfer from client to server there is no...
  10. Replies
    75
    Views
    3,914

    @All - SUCCESS! I now have the T4.1 version of...

    @All - SUCCESS! I now have the T4.1 version of Arduino-Ftp-Server giving me directory listings using FileZilla and gFTP. The library is using NativeEthernet, Arduino-Ftp-Server, Arduino-FatLib, ...
  11. Replies
    158
    Views
    3,229

    @mjs513 @defragster - Got my chips today. Ready...

    @mjs513 @defragster - Got my chips today. Ready to see if I can solder up and test. I have one more T4.1 and the T4.1 beta test board to play with. My humidity Indicator was blue - never seen this...
  12. Replies
    75
    Views
    3,914

    @manitou @vjmuzik - Have lwip_ftpd and...

    @manitou @vjmuzik - Have lwip_ftpd and lwip-ftpd-sd working with NativeEthernet. I originally had this Arduino FTP server working with the T3.6 and WIFISpi....
  13. Replies
    75
    Views
    3,914

    @manitou - Again thanks for responding. You...

    @manitou - Again thanks for responding. You pointed me to a lot of info. I have worked through all of @vjmuzik's FNET examples and tftpd with success. Now to checkout lwIP.

    So many things to...
  14. Replies
    75
    Views
    3,914

    Thanks for responding. I think I will start...

    Thanks for responding. I think I will start playing with the Arduino FTP server program I found and maybe even the ones I used with wifispi. There are some others that I was checking out but never...
  15. Replies
    75
    Views
    3,914

    @vjmuzik - I added the Ethernet kit to my T4.1's...

    @vjmuzik - I added the Ethernet kit to my T4.1's and tested with this library. All works well. Can you recommend a good FTP library to use. On my T3.6 I was using the Adafruit ESP8266 huzzah board...
  16. Replies
    158
    Views
    3,229

    @mjs513 - Can you give me the exact part number...

    @mjs513 - Can you give me the exact part number for the NAND chip you are using? When I looked it up I saw that there were at least three different package types available and I want to make sure...
  17. Replies
    797
    Views
    36,365

    @All - just to let you know I touched up the...

    @All - just to let you know I touched up the soldering job on the extram chips on the one T4.1 board that I was having a problem with. That fixed the the issue I was having with having to add delay's...
  18. Replies
    307
    Views
    7,976

    @All - Worked on several example sketches today....

    @All - Worked on several example sketches today. piptest.ino, scroll.ino and MemoryTransfer.ino. These are working now. MemoryTransfer.ino was just a problem with setup(). Had to do with Serial...
  19. Replies
    307
    Views
    7,976

    @mjs513 - Here is a sketch to demonstrate the...

    @mjs513 - Here is a sketch to demonstrate the issue with drawRect() and printStatusLine().


    #include "Arduino.h"
    #include "RA8876_t3.h"

    #include <math.h>

    #define RA8876_CS 10
    #define...
  20. Replies
    307
    Views
    7,976

    Got it. That was the difference. Completely...

    Got it. That was the difference. Completely missed the fact that you were using graphic fonts. Right now I am working with piptest.ino. Discovered a conflict between drawRect() and printStatusLine()....
  21. Replies
    307
    Views
    7,976

    I did the PR and am playing with the example...

    I did the PR and am playing with the example sketches right now. It blows me away the way you guy's redid the library. It is going to be fun working with a quality library. I did not realize you had...
  22. Replies
    307
    Views
    7,976

    @mjs513, @Kurte - I just got back to...

    @mjs513, @Kurte - I just got back to Ra8876LiteTeensy today. I have been going through all of the work that you guy's did trying to reorient myself to the changes. Did not realize all of the work you...
  23. Replies
    31
    Views
    1,758

    @Silverlock - The other build did not work. I...

    @Silverlock - The other build did not work.
    I think you both are right. I will touch up the soldering and see what happens. I have two more T41's and more psram chips to solder up and test. Will...
  24. Replies
    31
    Views
    1,758

    @Silverlock, Thanks for the the download. I...

    @Silverlock,

    Thanks for the the download. I will upload and test without my mod's to startup.c. I do not have a windows machine so this will help verify the validity of the Linux compiler.
    ...
  25. Replies
    31
    Views
    1,758

    @defragster, @Silverlock, I am running a...

    @defragster, @Silverlock,

    I am running a 600MHz, Optimize Fast, psram purchased directly from PJRC. I have done further testing and found some interesting results.

    Instead of this modification:...
  26. Replies
    31
    Views
    1,758

    Thanks for checking. Will wait for results.

    Thanks for checking. Will wait for results.
  27. Replies
    31
    Views
    1,758

    Linux Ubuntu 18.04.1 Installed on Ardunio...

    Linux Ubuntu 18.04.1

    Installed on Ardunio 1.8.13. So far everything is working well. The only thing I have trouble with is running teensy41_psram_memtest.ino. It still fails unless I modify...
  28. @ftrias - This is so awesome!! It all comes up...

    @ftrias - This is so awesome!! It all comes up and works:) The gdbgui pops up in my Firefox browser after compiling and when I type in step in the command line I see 'mark =' values increasing in the...
  29. Thanks for the link. I will definitely check this...

    Thanks for the link. I will definitely check this out. I remember using 'DDD' as front end to GDB. I also remember using 'make' from within GDB.
  30. I have it working now and changed the terminal...

    I have it working now and changed the terminal program from xterm to mate-terminal in 'teensy_debug'. My eye's need bigger fonts:)
    Anyway it's working and now have to refresh my memory on using gdb....
  31. Thanks for the work around. That worked:)

    Thanks for the work around. That worked:)
  32. @ftrias - Having problems installing TeeensyDebug...

    @ftrias - Having problems installing TeeensyDebug on My Linux laptop.Using Ubuntu 4.4.0. Running './install-linux.sh -i=/home/wwatson/arduino-1.8.13' I got this:


    wwatson@wwatsonl1:~/TeensyDebug$...
  33. Thanks @defragster - I understand now. I am...

    Thanks @defragster - I understand now. I am seeing the 'mark' variable changing values. This brings back cool memories:)
  34. OK I am really embarrassed here:( I was using gdb...

    OK I am really embarrassed here:( I was using gdb with the Motorola 68332 back in the 90's and cannot remember how it all worked. I was part of the EFI332 forum which used the 68332 for a fuel...
  35. Replies
    22
    Views
    578

    Probably the easiest way would be to use the...

    Probably the easiest way would be to use the example programs in the USBHost_t36 library. Maybe try a USB keyboard or mouse.

    Edit: I would be interested this. Looks like it take minimal soldering...
  36. Replies
    8
    Views
    225

    Just had it happen on one of my three Linux...

    Just had it happen on one of my three Linux machines. Backed up the original .arduino15 folder and restarted arduino-1.8.12 with no problem. I use the laptop more than the two desktops and that is...
  37. Replies
    390
    Views
    18,052

    All - Finally got back to working with MSC. In...

    All - Finally got back to working with MSC. In particular trying to speed up write speeds. I have been experimenting with queuing an array of transfers and was hitting a road block with queuing the...
  38. Replies
    307
    Views
    7,976

    I did miss that. If choosing a random number...

    I did miss that. If choosing a random number between 0 and 1023 for width you would not need to subtract 1 from the width. The other thing that pop's into my mind is if the random(...) function would...
  39. Replies
    307
    Views
    7,976

    Thank you for the link. Everything you guys have...

    Thank you for the link. Everything you guys have done so far seems to be working on my display as well at what appears to be 50 MHz. Cool:)

    I am running 'grahpics.ino' and anything to do with...
  40. Replies
    307
    Views
    7,976

    @mjs513 and @ KurtE - I need a little direction...

    @mjs513 and @ KurtE - I need a little direction here. I am so easily confused:) Who's branch of Ra8876Teeny should I be pulling from to keep up with you guy's? I have to take a break from MSC for a...
  41. It all works but on power up of a PC with thumb...

    It all works but on power up of a PC with thumb drive connected to a T4.0 through a HUB the T4.0 hangs in the HUB part of initialization.What you have to do is unplug the T4.0 from the PC after the...
  42. I actually have not tried it with a powered HUB...

    I actually have not tried it with a powered HUB yet. I was using a Belkin and another no name brand HUB that works with the T4.1. The T4.0 board I was testing with was @Paul's original beta breakout...
  43. Replying to my own thread because it was to late...

    Replying to my own thread because it was to late to edit it. Come to find out the problem does not happen on the T4.1. Only the T4.0.
  44. USBHost_t36 HUB issue on power up with T4.x connected.

    I am having a minor issue with MSC and USB thumb drives on power up. When I have a T4.x connected to a PC USB port and power up the PC the T4.x will not complete the initialization process. Here is...
  45. Replies
    307
    Views
    7,976

    @KurtE, @msj513, @MorganS - You guys really are...

    @KurtE, @msj513, @MorganS - You guys really are on it. It is fascinating to me to see what you are doing with this display controller. I have been following what you are doing and testing it on my...
  46. Replies
    307
    Views
    7,976

    To be honest I have not. It is very readable with...

    To be honest I have not. It is very readable with all my lights on including the maglite hanging over it in my little cave but I have never had it exposed outside in the sunlight.
  47. Replies
    307
    Views
    7,976

    Yep. Me to. I think the display draws to much...

    Yep. Me to. I think the display draws to much current for the Teensy to supply. I have never actually measured it but I know that with using the USB host port it's not enough. Again I think that is...
  48. Replies
    307
    Views
    7,976

    I had the same problem. In setup: //I'm...

    I had the same problem. In setup:

    //I'm guessing most copies of this display are using external PWM
    //backlight control instead of the internal RA8876 PWM.
    //Connect a Teensy pin to pin 14...
  49. Replies
    307
    Views
    7,976

    Nice work. And it is a start. This display...

    Nice work. And it is a start. This display controller and the RA8875 are not easy to work with.One of the things that I remember Sumotoy was working on with his RA8875 display driver was bit mapped...
  50. Replies
    797
    Views
    36,365

    @All - I have the PSRAM chip working. It wasn't...

    @All - I have the PSRAM chip working. It wasn't my soldering or a ruined chip:)

    I could not figure out why the one sketch 'teensy41_extram.ino' appeared to be working and...
Results 1 to 50 of 298
Page 1 of 6 1 2 3 4