Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: FLEOX

Search: Search took 0.00 seconds.

  1. Replies
    78
    Views
    12,374

    Hi LoShu Ok I see. I haven't messed around...

    Hi LoShu

    Ok I see. I haven't messed around with the Audio library at all. I' just added the "analyze_fft4096.c/h" files directly to my Arduino Sketch (in the same folder, it get's opened in a...
  2. Replies
    78
    Views
    12,374

    Hi LoShu Ok, that's interesting. In my opinion...

    Hi LoShu

    Ok, that's interesting. In my opinion you don't need to change "arm_cfft_radix4_q15" to "arm_cfft_q15", because "arm_cfft_radix4_q15" does support FFT4096. Have a look here...
  3. Replies
    78
    Views
    12,374

    Hi LoShu Ok, it seems that your Arduino IDE is...

    Hi LoShu

    Ok, it seems that your Arduino IDE is broken or something is corrupt. I would completely uninstall the Arduino IDE and then reinstall firstly the Arduino IDE and secondly the teensyduino...
  4. Replies
    78
    Views
    12,374

    Hi everyone! I'm sorry for the very late reply...

    Hi everyone!
    I'm sorry for the very late reply to this discussion. I was very busy the last few weeks.

    Of course I will post the complete source code of my project. I've made two small code...
  5. Replies
    78
    Views
    12,374

    Here are the results of the CPU and Memory usage:...

    Here are the results of the CPU and Memory usage:

    Only one 4096FFT running:


    fftPre = 0 (0 max), fftPost = 77 (78 max), All = 78.71 (79.56 max), Memory: 19 (37 max)
    fftPre = 0 (0 max),...
  6. Replies
    78
    Views
    12,374

    Ok, I've changed the second FFT to 1024 and that...

    Ok, I've changed the second FFT to 1024 and that works fine. But this is not really a solution for me, because I really need both Signal displayed in "high resolution".
    After changing the CPU Clock...
  7. Replies
    78
    Views
    12,374

    Hi! I've just run into a problem with the...

    Hi!
    I've just run into a problem with the 4096FFT. Everything works fine as long as I use only one instance of the 4096FFT.
    As soon as I connect a second FFT to the Input "AudioConnection patchCord...
  8. Replies
    78
    Views
    12,374

    Hi! I've just made a quick test with the...

    Hi!

    I've just made a quick test with the 4096FFT (using the files goldhausen has provided). It seems to work ok with the ILI9341_t3n Library (using frame buffer) I get 22 FPS.
    I'm using the Audio...
Results 1 to 8 of 8