Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.02 seconds.

  1. Replies
    3
    Views
    35

    @tonton81 also just posted that he updated the...

    @tonton81 also just posted that he updated the FlexCAN_t4 library to work on the T3.x's. So would suggest you start with that library.
  2. Replies
    3
    Views
    35

    @RoboticsDolphin Well first you haven't told...

    @RoboticsDolphin

    Well first you haven't told us what Flexcan library you are using and showed us the examples you are using. Usually the FlexCan libs have examples for reading and writing.

    As...
  3. @Slapstick Ok confused here are 2 questions...

    @Slapstick

    Ok confused here are 2 questions that should clarify the situation:
    1) HX8357 works with both Adafruit touchscreen.h and their HX8357 driver? From your description you said it was...
  4. Replies
    60
    Views
    1,963

    Nice work @tonton81. Have to break out all my...

    Nice work @tonton81. Have to break out all my boards again and test :)
  5. @Slapstick Think I mentioned this before but...

    @Slapstick

    Think I mentioned this before but the ILI9488 driver was designed for the ILI9488 controller not the HX8357 controller. There are differences at the controller level that may be...
  6. Never used a hx8357d display and suprised that...

    Never used a hx8357d display and suprised that the ILI9488 library works with that controller. I did read on the Adafruit site for that display:
  7. @KurtE Just got back to reading posts. For...

    @KurtE

    Just got back to reading posts. For some strange reason not getting notified from GitHub. I will go do it right now.
  8. Replies
    21
    Views
    317

    Nice Board - but you are out of stock on the...

    Nice Board - but you are out of stock on the battery charger and coin cell?
  9. Replies
    0
    Views
    38

    T4 TimerOne vs TimerThree

    Right now it seems that TimerOne has been ported over for the T4. The Timer1 is using flexPWM so I believe those are pins 0,1,24,15, I think.

    I am trying to figure out what the differences are...
  10. @KurtE - @Slapstick Never ran into that...

    @KurtE - @Slapstick

    Never ran into that problem before so something new for me as well. @Slapstick - you could reduce the SPI clock as @KurtE suggested but looking through the data sheet if you...
  11. @slapstick Oops sorry just reread your post -...

    @slapstick
    Oops sorry just reread your post - using a touch screen without a controller on a T3.6.

    I don't have a display like yours to test with. But just looking at the library I see no reason...
  12. Replies
    21
    Views
    317

    Was actually thinking about starting from an...

    Was actually thinking about starting from an initial layout like this:
    17863
    It would need some rearranging but its a start. Oh btw the header is for a ili9341/9488 display on SPI.
  13. Replies
    21
    Views
    317

    @PaulStoffregen That was the approach I was...

    @PaulStoffregen

    That was the approach I was taking. The rationale for that approach was a couple fold was mainly for expandability and customization almost like the Arduino concept of stacking...
  14. Replies
    21
    Views
    317

    That is one possibility, would be simpler for one...

    That is one possibility, would be simpler for one or 2 modules but if you have a few different ones... Was thinking actually thinking of having the modules plug into themselves then you can daisy...
  15. Replies
    51
    Views
    1,547

    Video and camera really sounds like cool features...

    Video and camera really sounds like cool features to add to the system. But would like to see maybe a beefier power supply and the sd card on the next revision.

    Had a radical idea for you - maybe...
  16. Replies
    21
    Views
    317

    One of things that I did with most of my...

    One of things that I did with most of my breakouts for the t3.5/6 and the T4 was use the Arduino shield concept so I could stack custom shields or already available shields but that has some...
  17. Replies
    58
    Views
    1,655

    Sticky: @KurtE - thanks - 1st pic with new phone :) ...

    @KurtE - thanks - 1st pic with new phone :)

    Running sketch with no heatsink on one of my breakout boards. Just ran it at 816 and getting pretty much the same temp as you about 58 degC.
    17847
  18. Replies
    58
    Views
    1,655

    Sticky: @defragster Sat here a while this morning...

    @defragster

    Sat here a while this morning watching clk pin while sketch was running at 600Mhz and 996Mhz. Run the 996Mhz up to 71degC without issue. Nothing obvious on my scope with the SPI...
  19. Replies
    58
    Views
    1,655

    Sticky: @defragster I modified my tempmon_t4 sketch to...

    @defragster

    I modified my tempmon_t4 sketch to include the drawing the Buddabrot on a ILI9341 display - ISRs never tripped but at 1Ghz the T4 hung at about 74.5 degC:

    Test results:

    @600Mhz -...
  20. Sorry - when I posted my question there were no...

    Sorry - when I posted my question there were no edits in you post #261.

    So - glad you got it working :)
  21. Scrolltest has issues with the ST7789 probably...

    Scrolltest has issues with the ST7789 probably should delete that function but hoping to figure out how to readpixels from the display. Please try and run the graphicstest.ino sketch.

    EDIT: did...
  22. Replies
    58
    Views
    1,655

    Sticky: @defragster Just ran a simple test sketch that...

    @defragster

    Just ran a simple test sketch that prints out the temp every 2 seconds with the T4 @1Ghz. TempMon does work - it shuts the T4 down at 90degC so now going to put a bit more test the...
  23. @KurtE Just downloaded and tested with that...

    @KurtE

    Just downloaded and tested with that FB_and_clip test sketch. Put it through its paces with DMA on/off and with Screen offset on the T4 and T3.6. Looks like the changes are working...
  24. Will check it out - had a feeling you were going...

    Will check it out - had a feeling you were going to go ahead and make the change

    That's a great addon. Thanks. I want to fix up the constructor as well.

    Will give it a try as soon as I get...
  25. Sorry for the delay been out running errands most...

    Sorry for the delay been out running errands most of the day and still have a couple more things to do. Nope - still having problems with reading pixels for 9341 and 9488. Meant to mention that but...
  26. Replies
    58
    Views
    1,655

    Sticky: @defragster Sorry was out running errands with...

    @defragster

    Sorry was out running errands with the wife. Yes it is posted but easier if I just attach it here:
  27. Replies
    58
    Views
    1,655

    Sticky: @defragster - @Paul I just ran my original...

    @defragster - @Paul

    I just ran my original tempmon sketch, the standalone one, that sets the registers. Ran it until it hit the High Temp of 85 and it seems to working without issue. It tripped...
  28. Replies
    4
    Views
    231

    @Bill G Thanks for the info some of the...

    @Bill G

    Thanks for the info some of the multi-thread problems I recognize from using TeensyThreads.

    Primarily the libraries I am talking about are things like PWMServo, NewPing, MPU-9250 etc. ...
  29. Replies
    58
    Views
    1,655

    Sticky: @defragster Think something else is going on...

    @defragster

    Think something else is going on besides overtempt at 996Mhz. I just ran your tempmon sketch using my ILI9341 buddabrot sketch linked into loop. At 996Mhz I runs for a bit and then...
  30. Replies
    58
    Views
    1,655

    Sticky: @defragster Those are the same coremarks that...

    @defragster

    Those are the same coremarks that I got in post https://forum.pjrc.com/threads/57894-Teensyduino-1-48-Beta-3?p=218007&viewfull=1#post218007. I was able to get 1.008Ghz(996Mhz) without...
  31. Replies
    24
    Views
    579

    Have to find the original doc I used to set 90...

    Have to find the original doc I used to set 90 may be able to raised to 95.
  32. Ok - lets start with your wiring: Display -...

    Ok - lets start with your wiring:


    Display - Pin Desc - T4 (what you have) - T4 what should be
    1,2,5,6,12 - Ground - Black - no problem
    3,4 - 3.3v - Red -...
  33. Replies
    24
    Views
    579

    I'll check it out - you guys are night owls while...

    I'll check it out - you guys are night owls while I am a morning person - so give me a little bit. Still have my original sketch where I can adjust the temps. If I remember right it is currently...
  34. Ok - never seen any display like that before -...

    Ok - never seen any display like that before - where did you find the specs for the pinouts etc?
  35. Replies
    24
    Views
    579

    @defragster Thanks for moding the example. ...

    @defragster

    Thanks for moding the example. When I ran coremark up to 1.008Ghz(1ghz) it ran without issue. When I ran demosauce that was when things started happening with resetting and loosing...
  36. Can you post a link to the exact display you are...

    Can you post a link to the exact display you are using and maybe a schematic/photo of your wiring to the T4. Have to remember that the T4 is not 5v tolerant. The adafruit display I have uses 3.3v...
  37. Replies
    24
    Views
    579

    @PaulStoffregen This seems to be the same...

    @PaulStoffregen

    This seems to be the same issue associated with SCB_AIRCR not resetting the T4. Its like the T4 appears to turn-off instead of resetting. If you reapply power it turns back on.
  38. Yes SDA goes to MOSI. You will need to do some...

    Yes SDA goes to MOSI.

    You will need to do some reconfiguration for your display though. The 7789 example is set up to use SPI and SPI1 as well as a 240x240 displat. If you are using only SPI...
  39. Replies
    24
    Views
    579

    Just ran the Coremark up through 1Ghz, no...

    Just ran the Coremark up through 1Ghz, no problems. Was running Demosauce so a heavier load:
    17827

    Believe @manitou also ran coremarks
  40. Replies
    4
    Views
    100

    You are correct. I2C slave mode isn't supported...

    You are correct. I2C slave mode isn't supported yet on the T4. Currently in the wire lib there are places that identify that.
  41. Replies
    4
    Views
    231

    @Bill G Starting looking at giving this is a...

    @Bill G

    Starting looking at giving this is a try now and start playing with it. Think I get the basics. There is one question though - if I want to use one of the Teensy or Arduino libraries can...
  42. Replies
    24
    Views
    579

    Morning all Downloaded and install on a...

    Morning all

    Downloaded and install on a Windows10x64 with no issues during the install.

    Can copy from a closed sermon of course.

    Tried the demosauce sketch that identified the issue hang...
  43. @KurtE Just did the merge and it now works...

    @KurtE

    Just did the merge and it now works like a charm with and without frame buffer. :)
  44. @KurtE Worked on the T3.6 and just did the...

    @KurtE

    Worked on the T3.6 and just did the merge to the master ILI9488_t3 branch. Yeah
  45. @KurtE - thanks for checking - I just finished...

    @KurtE - thanks for checking - I just finished incorporating your opaque and transparency changes. Just tested on the T4 and it looks like its working. I pushed the changes up to the 9488...
  46. @KurtE - fixed final issue with BG for non-gfx. ...

    @KurtE - fixed final issue with BG for non-gfx. Tomorrow the rest then the PR to the master
  47. @KurtE and any else you wants to try it I just...

    @KurtE and any else you wants to try it

    I just pushed the changes to 9488 adafruit_font branch of the lib. Got the background color working but now getting a white line between blocks. Right now...
  48. @KurtE Damn - missed that one - was...

    @KurtE
    Damn - missed that one - was concentrating so much on the other functions.

    One final issue - with that though. If I us FB it doesn't draw the black background when i do opaque now. ...
  49. @KurtE Sorry - was upstairs installing new...

    @KurtE

    Sorry - was upstairs installing new blinds without moving furniture for better angle - man I am getting old - every thing aches going up and down the ladder.

    The ILI9488 display that I...
  50. Must be doing something wrong. Using the...

    Must be doing something wrong. Using the following sketch with my 320x240 st7789 but seems to only work when FB = 0?

    #include <Adafruit_GFX.h> // Core graphics library
    #include...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4