Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.02 seconds.

  1. You can try to use this for your interrupt: ...

    You can try to use this for your interrupt:

    #define RFM95_INT digitalPinToInterrupt(2) as opposed to
    #define RFM95_INT 2
  2. Replies
    3,744
    Views
    387,584

    I have a optoresitor in the loop attached to pin...

    I have a optoresitor in the loop attached to pin A2 but I've run the sketch with one display with and without it attached.... besides on compile/upload it should be an issue until it runs - so it...
  3. Oh boy - hope you had some fun. Yes I know you...

    Oh boy - hope you had some fun.

    Yes I know you will massage it but fair warning there are some blocks that don't follow cmd/data blocks - I was doing that earlier. Then there are a whole bunch of...
  4. Replies
    3,744
    Views
    387,584

    @defragster - @Frank B Running into problem...

    @defragster - @Frank B

    Running into problem with GCC6 - Eigen library that runs fine under GCC7 is now throwing errors so sketch can not compile. Not sure if there will be an impact to anything...
  5. Replies
    3,744
    Views
    387,584

    Yep - replaced it with the contents of arm6 ...

    Yep - replaced it with the contents of arm6

    EDIT = make sure you back it up first
  6. Replies
    3,744
    Views
    387,584

    @defragster Change "arm6" to arm and it will...

    @defragster

    Change "arm6" to arm and it will run. I zipped the present toolchain and then copied arm6 over and renamed it to "arm". I also deleted the 5.3.1 folder.
  7. @KurtE I was beginning to do that before you...

    @KurtE

    I was beginning to do that before you got the initial sketch that we started from working so I just left it at that. Don't know if it worth it at this point to spend that much time going...
  8. Replies
    3,744
    Views
    387,584

    @KurtE Tried several SPI freq lowering it down to...

    @KurtE Tried several SPI freq lowering it down to 8Mhz but no change to the distorted image.

    Note that if I do and include debug_tt it the eyes on both screens display normally.

    It looks...
  9. Replies
    3,744
    Views
    387,584

    @Frank B and @defragster @KurtE Hope you don't...

    @Frank B and @defragster @KurtE

    Hope you don't mind but I just downloaded and installed your GCC 6. Ok don't get the that error anymore but without debug_tt the eyes on the two screens are...
  10. @KurtE Had to make a slight change to get...

    @KurtE

    Had to make a slight change to get colors to match and touchpaint to match what you had:

    // Define at most only one of these...
    //#define RGB_COLORS
    //#define BGR_COLORS
    //#define...
  11. Replies
    3,744
    Views
    387,584

    Isn't it though :). Wonder if it shows the same...

    Isn't it though :). Wonder if it shows the same behavior with other optimizations? Oh - it does work on a T3.6 last I looked.
  12. Replies
    3,744
    Views
    387,584

    Yes - writeRect was added later so definitely...

    Yes - writeRect was added later so definitely need KurtE's fork branch that he referenced in post3723.
  13. Oh wasn't clear - none of them worked. Sorry. ...

    Oh wasn't clear - none of them worked. Sorry.

    I did break down and ordered another display just as a test - I screwed up that second one that I bought. Will get it Thursday. Don't know if its...
  14. @KurtE Just gave it a try and the changing the...

    @KurtE
    Just gave it a try and the changing the madtl does change the colors to the correct ones. The only thing that does it is to invert RGB colors. Then it works as you show. Sorry.

    Strange...
  15. @KurtE - @defragster If you do the following...

    @KurtE - @defragster

    If you do the following in the GITHUB .h file:

    #define RGB_COLORS 1
    // Color definitions
    #ifdef RGB_COLORS
    #define KEDEIRPI35_BLACK 0xFFFF-0x0000 /* 0, 0,...
  16. @KurtE - @defragster Ok in the loop if I change...

    @KurtE - @defragster
    Ok in the loop if I change in your kedei_simple sketch

    lcd_fillframe(0, 0, lcd_w, lcd_h, (colors[color]));
    to

    lcd_fillframe(0, 0, lcd_w, lcd_h, 0xFFFFFF...
  17. @KurtE - @defragster Playing around with the...

    @KurtE - @defragster

    Playing around with the simple kedei sketch in post #386 the colors are still off so I put in a wait for input loop so I can try to match the colors to screen. I got this, it...
  18. @KurtE - @defragster Didn't realize there was...

    @KurtE - @defragster

    Didn't realize there was a white box on the far right - when I hit White the sermon shows black, when I hit black it shows White.
  19. @KurtE No worries about the pic. I just...

    @KurtE

    No worries about the pic. I just checked the back of my display and it has the exact same identification that is on your display:
    17003
  20. Replies
    3,744
    Views
    387,584

    @el_supremo Thanks for the code - I was looking...

    @el_supremo
    Thanks for the code - I was looking at this one to port - but much more complicated: https://github.com/marczych/RayTracer/tree/master/src
  21. @KurtE - @defragster @defragster - was just...

    @KurtE - @defragster

    @defragster - was just letting you know what I had to get it to work. Anyway I just retry mine with the latest updates and this is what I am seeing:

    16998

    Not sure why...
  22. @defragster - that looks exactly like my screen...

    @defragster - that looks exactly like my screen with the exception that touchscreen worked :) I don't have to use the full constructor though to get it to work.
  23. Replies
    3,744
    Views
    387,584

    Ok you peaked my interest - starting to play with...

    Ok you peaked my interest - starting to play with 3d graphics and ray tracing for the T4 - what lib did you port? Started discussing here:...
  24. @Frank B - haven't done 3d graphics since my...

    @Frank B - haven't done 3d graphics since my college days and that was on Apollo computers, IBM360 and PDP11's and of course TRS80 - yes I am old :) So with the T4 going to have some fun. Found a...
  25. @KurtE Just can't help yourself :) Ready to...

    @KurtE

    Just can't help yourself :)

    Ready to do 3d graphics on the T4 and adding to the libs: http://crawlingrobotfortress.blogspot.com/2015/12/, Better 3D graphics on the Arduino: avoiding...
  26. Just tried it and it does work - my colors are...

    Just tried it and it does work - my colors are just off compared to what you have = but that may be my display.
  27. To be honest - I believe so. I should go back to...

    To be honest - I believe so. I should go back to my eigen sketch and rerun it with debug_tt included.

    <edit> but I haven't lost usb except for this sketch in a very long time. Eigen threw it...
  28. Replies
    3
    Views
    100

    @TelephoneBill Hey man - still got one of...

    @TelephoneBill

    Hey man - still got one of those - but didn't start using it in earnest until 1972. Think at that time it was made by K&E as opposed to PRJC :)
  29. Replies
    3,744
    Views
    387,584

    @PaulStoffregen (@KurtE, @defragster) If you...

    @PaulStoffregen (@KurtE, @defragster)

    If you look at the scenario's from what I was doing as well as @KurtE and @defragster, I am seeing the following if I load uncanyeyes on a clean T4 (did a 15s...
  30. @defragster You will need the latest core,...

    @defragster

    You will need the latest core, Kurt's modified Adafruit_GFX library and latest SPI with the writeRect PR (still open). The uncannyeye sketch is in post #353.

    To duplicate load up...
  31. @KurtE Kedei: Think with the Kedei it started...

    @KurtE

    Kedei: Think with the Kedei it started off with the challenge of just getting it working now we just cant help ourselves. :)

    I downloaded your last GitHub - I hope - but my colors are...
  32. @KurtE Here is the exact sketch that I am...

    @KurtE

    Here is the exact sketch that I am using. Problems occur when you comment out @defragster's debug_tt.

    16977
  33. @degragster - @KurtE Yep - got the old screen...

    @degragster - @KurtE

    Yep - got the old screen finally working. New I think I put 5v to one of the other pins by accident and may have fried the chip.

    Runs nice but backlight I very bright...
  34. @KurtE Gave up the RPI display - cant get a...

    @KurtE

    Gave up the RPI display - cant get a damn thing displaying on it. Even tried it on the T3.6. Even tried using pin 9 for CS. I also reinstalled Arduino IDE 1.8.9 and the latest...
  35. @defragster - @KurtE Tried that as well when I...

    @defragster - @KurtE

    Tried that as well when I saw it but no luck - nothing displays.

    But something looks funny with the LA dump I made:
    16975

    and still nothing on the display - have no...
  36. @KurtE There are .h files in the zip - which...

    @KurtE

    There are .h files in the zip - which to use?
  37. @KurtE My Kedei displayed arrived today, same...

    @KurtE

    My Kedei displayed arrived today, same one as yours:...
  38. Replies
    3,744
    Views
    387,584

    @defragster Couldn't sleep thinking about this...

    @defragster

    Couldn't sleep thinking about this so I had to give it a test. I must have a very unique T4 with the ribbon cable on it because when it resets due to temp it resets but then doesn't...
  39. Replies
    3,744
    Views
    387,584

    @defragster My guess is that the ribbon...

    @defragster

    My guess is that the ribbon cable/connector is lower your the temp of the board. If you are running at 49-50C and your panic temp is 50C probably wont trip - not above the threshold -...
  40. Replies
    3,744
    Views
    387,584

    @defragster - Essenstially that's it - the system...

    @defragster - Essenstially that's it - the system automatic triggers reset when panic temp is exceeded - it will keep resetting unless you do something to lower the temp. Believe so on the init and...
  41. Replies
    3,744
    Views
    387,584

    @KurtE I did add the capability to the Talkie...

    @KurtE

    I did add the capability to the Talkie library to use a PWM pin on the T4 with @defragster's comments. Volume was just low. However I just found this regarding using PWM that might be of...
  42. Replies
    3,744
    Views
    387,584

    Well tested it pretty good to make sure things...

    Well tested it pretty good to make sure things tripped when they were suppose to in that test sketch. Just for the fun of it I also lowered the panic temp and tested to see if it really reset using...
  43. Replies
    3,744
    Views
    387,584

    @defragster - went back into my original...

    @defragster - went back into my original standalone sketch: https://github.com/mjs513/WIP/tree/master/TempMonitorStuff/T4-TEMPMON. You can see how I did the Callbacks if the ISR is tripped for HIGH...
  44. @KurtE Oops - sorry I misunderstood thought...

    @KurtE

    Oops - sorry I misunderstood thought you were referring to the other sendcommands - sorry my bad. Will have to download the latest copy. Only problem now I am running into is that that...
  45. @KurtE - @defragster Ok - got it displaying on...

    @KurtE - @defragster

    Ok - got it displaying on both screens now - actually turned out easy fix but had to add one function to your lib :)

    Here is my kludged up version just for the SSD1351 -...
  46. @KurtE Wanted to let you know about the power...

    @KurtE

    Wanted to let you know about the power issue using 2 OLEDs. Remember you told me about SendCommand yesterday :). There are so many ifdef's in there to cover the different displays I...
  47. @KurtE Progress on the SSD1351 UncannyEyes. ...

    @KurtE

    Progress on the SSD1351 UncannyEyes. Turns out the primary problem with running 2 LED displays is power. I added a external supply to supply power to the OLEDs and got the eyes to...
  48. @KurtE Well I lied - had to try something,...

    @KurtE

    Well I lied - had to try something, turn debug back on:

    C:\Users\Merli\OneDrive\Desktop\uncannyEyes\uncannyEyes.ino Jul 11 2019 20:06:43
    >>> Reason for 'reset': 1 IPP_RESET_B :: done...
  49. @KurtE Not 100% sure about the schematics...

    @KurtE
    Not 100% sure about the schematics either. One that was for an earlier revision of the board and two it was reversed engineered - never could find anything official on the display which is...
  50. @defragster For the RPI display relatively...

    @defragster

    For the RPI display relatively easy hook - MOSI=11, L_CS=10, T_CS=6, CLK=13, Gnd=Ground, 5v=5v. No addition Libs necessary. Everything self contained.

    As for the ST7735 using...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4